Pressing Alt+Backslash locks up all windows (no focus)

Bug #1779846 reported by Marco Gaiarin on 2018-07-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

I've recently switched from 16.04/Unity to 18.04/Gnome3, with new hardware (a Lenovo Thinkpad T470s) used mostly with a docking station and external keyboard.

I do heavily use of in-workspace windows switch (eg, Alt+Esc) and i've found that every time i press Alt+Backslash (in Italian keyboard layout Backslash is all left, between TAB and Esc keys) my session ''lock up'': i can switch between windows, i can use the gnome shell and the top bar (status bar?), i can even run other application (via Alt+F2 or gnome shell menu) but every window (old or new) are ''locked'', like there's no focus: no keyboard nor mouse interaction is possible.
Application are not 'locked', they continue to run, but there's no way to interact with them.

I can also lock the screen, or put the system in standby: i can awaken from that, insert the password but still no focus on windows.

The only solution: logout.

I've also tried to define a keyboard shortcut to map Alt+Backslash, but... gnome keyboard configurator locks as every other window when i press the keys.

Please, help me at least to disable that 'killer' keyboard shortcut! ;-)

Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Jul 3 12:16:18 2018
DisplayManager: gdm3
GsettingsChanges:
 b'org.gnome.shell' b'enabled-extensions' b"['<email address hidden>', '<email address hidden>', '<email address hidden>']"
 b'org.gnome.shell' b'command-history' redacted by apport
 b'org.gnome.shell' b'favorite-apps' redacted by apport
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2018-05-25 (38 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Marco Gaiarin (marcogaio) wrote :
Daniel van Vugt (vanvugt) wrote :

First, please try removing these shell extensions:

['<email address hidden>',
 '<email address hidden>',
 '<email address hidden>']

If that solves the problem then this is a bug in an extension and not in gnome-shell.

Otherwise, please look in /var/crash and tell us if you find any .crash files there.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Marco Gaiarin (marcogaio) wrote :

> First, please try removing these shell extensions:

A-Ha! Sorry, i've played with some extensions and never minded about them.

I've disabled (it suffices, it was not needed to uninstall them) 'system-monitor' and 'windows-alt-tab' and problem desappear.

Many thanks and sorry for that bug report!

Changed in gnome-shell (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers