Desktop is displayed when resuming from suspend

Bug #1768786 reported by Will Cooke on 2018-05-03
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Olivier Tilloy
Bionic
High
Olivier Tilloy

Bug Description

[Impact]
Failing to trigger lockscreen before suspend compromises user privacy.

[Test case]
1. Open Settings -> Privacy and make sure that "Automatic screen lock" is OFF.
2. Suspend your machine
3. Resume your machine
4. Make sure that the lockscreen is shown on resume and that you can't see the desktop

[Regression Potential]
System fails to lock before suspend when "Automatic screen lock" is ON.

[Original Bug]

Steps to reproduce and description:

First test case - where things work correctly:

1. Open Settings-> Privacy and make sure that Automatic screen lock is ON.
2. Suspend your machine
3. Resume your machine
4. Notice that the lockscreen is shown on resume and that you can't see the desktop

Second test case - where things are broken

1. Open Settings -> Privacy and make sure that Automatic screen lock is OFF.
2. Suspend your machine
3. Resume your machine
4. Notice that the desktop is visible for a second, then the screen blanks, then the lock screen appears, then the screen blanks again. You are left at a black screen and need to unlock.

Related branches

Changed in gnome-shell (Ubuntu):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Timo (timo-tk) wrote :

I can confirm this happens on Gnome, Budgie and Unity.

Jeremy Bicha (jbicha) wrote :

There is a much older gdm3 bug for this issue so I'm marking this a duplicate of that one.

Timo (timo-tk) wrote :

It also happens on LightDM for me, so I am not sure if it is duplicate.

Andrea Azzarone (azzar1) wrote :

This is actually a different bug due to the ubuntu_lock_on_suspend.patch. Reopening.

Changed in gnome-shell (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Andrea Azzarone (azzar1) on 2018-05-24
tags: added: rls-bb-incoming
summary: - Screen is displayed when resuming from suspend
+ Lock screen is displayed when resuming from suspend

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in budgie-desktop (Ubuntu):
status: New → Confirmed
Changed in ubuntu-unity-meta (Ubuntu):
status: New → Confirmed
summary: - Lock screen is displayed when resuming from suspend
+ Desktop is displayed when resuming from suspend
Daniel van Vugt (vanvugt) wrote :

Is this related to bug 1730543?

Timo (timo-tk) wrote :

No, this is different. I think it's the same as https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1532508

Iain Lane (laney) on 2018-06-05
Changed in gnome-shell (Ubuntu):
assignee: Andrea Azzarone (azzar1) → Didier Roche (didrocks)
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Olivier Tilloy (osomon) on 2018-06-05
Changed in gnome-shell (Ubuntu):
assignee: Didier Roche (didrocks) → Olivier Tilloy (osomon)
Changed in gnome-shell (Ubuntu Bionic):
assignee: Didier Roche (didrocks) → Olivier Tilloy (osomon)
tags: removed: rls-bb-incoming
Changed in gnome-shell (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in budgie-desktop (Ubuntu Bionic):
status: New → Confirmed
Changed in gnome-shell (Ubuntu Bionic):
status: New → Confirmed
Changed in ubuntu-unity-meta (Ubuntu Bionic):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.2-0ubuntu1

---------------
gnome-shell (3.28.2-0ubuntu1) cosmic; urgency=medium

  [ Olivier Tilloy ]
  * New upstream release
    - fixes valid password rejection at login screen (LP: #1765261)
  * Drop patches applied upstream:
    - debian/patches/polkitAgent-Guard-against-repeated-close-calls.patch
    - debian/patches/popupMenu-Fix-wrong-call-to-clutter_actor_add_child.patch
    - debian/patches/workspaceThumbnail-initialize-porthole-based-on-workArea.patch
    - debian/patches/workspaceThumbnail-only-update-_porthole-if-the-overview-.patch
    - debian/patches/workspaceThumbnail-rebuild-thumbnails-if-workareas-size-c.patch

  [ Andrea Azzarone ]
  * debian/patches/ubuntu_lock_on_suspend.patch: inhibit suspend until the
    screen is locked also in the case where automatic screen lock is disabled
    and screen lock on suspend is enabled (LP: #1768786)

  [ Marco Trevisan (Treviño) ]
  * Cherry pick upstream patches:
    - debian/patches/st-label-Unset-clutter-text-instance-on-disposal.patch (LP: #1714989)
  * debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch:
    - Cherry pick updated version from upstream, splitted in:
    + debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch
    + debian/patches/st-texture-cache-Save-cairo-surfaces-to-a-different-map.patch
  * debian/patches/authPrompt-Do-not-enable-sensitivity-if-retries-are-disal.patch
    debian/patches/authPrompt-Unset-preemptiveAnswer-on-reset.patch
    debian/patches/gdm-util-Always-allow-to-retry-login-in-unlock-mode.patch:
    - GDM gnome-shell greeter fix to fix unneeded login attempts (LP: #1777956)
  * debian/patches/series:
    - reorder to apply upstream cherry-picks before the others

  [ Daniel van Vugt ]
  * debian/patches/magnifier.js-Fix-zoom-juddering.patch:
    - magnifier.js: Fix zoom juddering (LP: #1691675)

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 21 Jun 2018 01:59:11 +0200

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2018-06-25
description: updated
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → In Progress

Hello Will, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.2-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Will Cooke (willcooke) wrote :

Test on Bionic:

gnome-shell:
  Installed: 3.28.2-0ubuntu0.18.04.1
  Candidate: 3.28.2-0ubuntu0.18.04.1

With auto-screen-lock OFF suspending and resuming displays the lock screen as it should do. I.e. the fix is working.

Verification done.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.2-0ubuntu0.18.04.1

---------------
gnome-shell (3.28.2-0ubuntu0.18.04.1) bionic; urgency=medium

  [ Olivier Tilloy ]
  * New upstream release (LP: #1775145)
    - fixes valid password rejection at login screen (LP: #1765261)
  * Drop patches applied upstream:
    - debian/patches/polkitAgent-Guard-against-repeated-close-calls.patch
    - debian/patches/popupMenu-Fix-wrong-call-to-clutter_actor_add_child.patch
    - debian/patches/workspaceThumbnail-initialize-porthole-based-on-workArea.patch
    - debian/patches/workspaceThumbnail-only-update-_porthole-if-the-overview-.patch
    - debian/patches/workspaceThumbnail-rebuild-thumbnails-if-workareas-size-c.patch

  [ Andrea Azzarone ]
  * debian/patches/ubuntu_lock_on_suspend.patch: inhibit suspend until the
    screen is locked also in the case where automatic screen lock is disabled
    and screen lock on suspend is enabled (LP: #1768786)

  [ Marco Trevisan (Treviño) ]
  * Cherry pick upstream patches:
    - debian/patches/st-label-Unset-clutter-text-instance-on-disposal.patch (LP: #1714989)
  * debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch:
    - Cherry pick updated version from upstream, splitted in:
    + debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch
    + debian/patches/st-texture-cache-Save-cairo-surfaces-to-a-different-map.patch
  * debian/patches/authPrompt-Do-not-enable-sensitivity-if-retries-are-disal.patch
    debian/patches/authPrompt-Unset-preemptiveAnswer-on-reset.patch
    debian/patches/gdm-util-Always-allow-to-retry-login-in-unlock-mode.patch:
    - GDM gnome-shell greeter fix to fix unneeded login attempts (LP: #1777956)
  * debian/patches/series:
    - reorder to apply upstream cherry-picks before the others

  [ Daniel van Vugt ]
  * debian/patches/magnifier.js-Fix-zoom-juddering.patch:
    - magnifier.js: Fix zoom juddering (LP: #1691675)

 -- Marco Trevisan <email address hidden> Tue, 21 Jun 2018 01:45:42 +0200

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Daniel van Vugt (vanvugt) wrote :

Please consider moving the remaining open tasks into bug 1532508.

This one probably should have been a duplicate of that all along.

Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

Removed the uncompleted tasks. Please use bug 1532508 instead.

no longer affects: budgie-desktop (Ubuntu)
no longer affects: ubuntu-unity-meta (Ubuntu)
no longer affects: budgie-desktop (Ubuntu Bionic)
no longer affects: ubuntu-unity-meta (Ubuntu Bionic)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers