gnome-shell crashed with SIGSEGV in meta_kms_resources_init() from meta_gpu_kms_read_current() from meta_gpu_read_current() from meta_monitor_manager_read_current_state() from meta_monitor_manager_setup()

Bug #1765269 reported by alex on 2018-04-19
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Nominated for Bionic by Marco Trevisan (Treviño)
mutter (Ubuntu)
Undecided
Unassigned
Nominated for Bionic by Marco Trevisan (Treviño)

Bug Description

[ Impact ]

Gnome shell crashes on meta_kms_resources_init

[ Test case ]

No clear reproducer is know for such issue, crashes should be monitored in e.u.c checking that this is not happening anymore for the version in proposed.

[ Regression potential ]

Low, the proposed fix is part of the current stable branch upstream and not changed in further revisions.

---

https://errors.ubuntu.com/problem/1e18be3177eec7b64bb8d8b6f51d7dc727e21bc1

---

At upstart the problem occurred

ProblemType: CrashDistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.0-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME-Greeter:GNOME
Date: Wed Apr 18 19:50:57 2018
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2018-04-08 (10 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180305)
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7f01cd93a89b: mov 0x30(%rax),%edi
 PC (0x7f01cd93a89b) ok
 source "0x30(%rax)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: gnome-shell
StacktraceTop:
 () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
 meta_gpu_read_current () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
 meta_monitor_manager_read_current_state () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
 meta_monitor_manager_setup () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
 () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
Title: gnome-shell crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

alex (alexandersson) wrote :

StacktraceTop:
 meta_kms_resources_init (fd=13, resources=0x7fff171cb950) at backends/native/meta-gpu-kms.c:714
 meta_gpu_kms_read_current (gpu=0x559fa481a520, error=<optimized out>) at backends/native/meta-gpu-kms.c:741
 meta_gpu_read_current (gpu=<optimized out>, error=error@entry=0x7fff171cba10) at backends/meta-gpu.c:82
 meta_monitor_manager_read_current_state (manager=manager@entry=0x559fa4834130) at backends/meta-monitor-manager.c:2614
 meta_monitor_manager_setup (manager=0x559fa4834130) at backends/meta-monitor-manager.c:704

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
summary: - gnome-shell crashed with SIGSEGV
+ gnome-shell crashed with SIGSEGV in meta_kms_resources_init() from
+ meta_gpu_kms_read_current()
information type: Private → Public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :
description: updated
summary: gnome-shell crashed with SIGSEGV in meta_kms_resources_init() from
- meta_gpu_kms_read_current()
+ meta_gpu_kms_read_current() from meta_gpu_read_current() from
+ meta_monitor_manager_read_current_state() from
+ meta_monitor_manager_setup()
Daniel van Vugt (vanvugt) wrote :

See also bug 1765290

Daniel van Vugt (vanvugt) wrote :

And see also bug 1767956

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Changed in mutter (Ubuntu):
status: Confirmed → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers