gnome-shell crashed with SIGSEGV in cogl_object_unref() from iter_remove_or_steal() from g_hash_table_iter_remove() from st_texture_cache_evict_icons() from on_icon_theme_changed()

Bug #1754445 reported by moncete on 2018-03-08
86
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Marco Trevisan (Treviño)
Nominated for Bionic by Marco Trevisan (Treviño)

Bug Description

https://gitlab.gnome.org/GNOME/gnome-shell/issues/210

https://errors.ubuntu.com/problem/990288ee13e03a048791700aa0af1ccfaecd49bc
https://errors.ubuntu.com/problem/e4d313a6d362e991dc79947946d24a22a3a2f84a

---

i don´t know

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.27.92-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: GNOME-Greeter:GNOME
Date: Thu Mar 8 20:18:43 2018
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2018-03-08 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180308)
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7f921c91b510 <cogl_object_unref>: mov (%rdi),%rax
 PC (0x7f921c91b510) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 cogl_object_unref () from /usr/lib/x86_64-linux-gnu/mutter/libmutter-cogl-2.so
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/gnome-shell/libst-1.0.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-shell crashed with SIGSEGV in cogl_object_unref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
moncete (moncete) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 cogl_object_unref (obj=0x0) at cogl-object.c:112
 iter_remove_or_steal (ri=ri@entry=0x7ffda4fa7fc0, notify=notify@entry=1) at ../../../../glib/ghash.c:851
 g_hash_table_iter_remove (iter=iter@entry=0x7ffda4fa7fc0) at ../../../../glib/ghash.c:887
 st_texture_cache_evict_icons (cache=0x561a8fa69a60) at ../src/st/st-texture-cache.c:125
 on_icon_theme_changed (icon_theme=<optimized out>, cache=0x561a8fa69a60) at ../src/st/st-texture-cache.c:133

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Dropped importance to Low, because the stack trace suggests this crash could only happen when changing the icon theme(?)

summary: - gnome-shell crashed with SIGSEGV in cogl_object_unref()
+ gnome-shell crashed with SIGSEGV in cogl_object_unref() from
+ iter_remove_or_steal() from g_hash_table_iter_remove() from
+ st_texture_cache_evict_icons() from on_icon_theme_changed()
information type: Private → Public
Changed in gnome-shell (Ubuntu):
importance: Medium → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
description: updated
Revision history for this message
Andreas Enström (anen) wrote :

My bug #1763850 got marked as a dupplicate (and probably is). It's seems to only occur once after a fresh install on my system. I tried to reproduced and succeeded.
What I did was:
a fresh install with encrypted drive,
login to regular "ubuntu"-session,
update all software,
reboot,
login to "ubuntu wayland"-session -> image freezes -> thrown-back to login screen,
login to regular "ubuntu"-session,
do things for a few minutes (I was surfing with firefox both times) -> crash report appears on-screen.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Revision history for this message
Andreas Enström (anen) wrote :

I'm happy to assist in what capacity I can. Currently I'm not using the computer for anything else, so I can format the drive and reinstall ubuntu again, if some more details are required.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.1-0ubuntu1

---------------
gnome-shell (3.28.1-0ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release
  * Drop obsolete patches:
    - 27-nm-libexec-path.patch
    - fix-wayland-vbox-crash.patch

  [ Marco Trevisan (Treviño) ]
  Cherry-pick patches applied to upstream git master:
  * ui-Theme-lookup-should-respect-XDG_DATA_DIRS.patch:
    - Renamed from ubuntu_theme_lookup_xdg.patch and cherry-picked from
      upstream
  * workspaceThumbnail-only-update-_porthole-if-the-overview-.patch:
    workspaceThumbnail-rebuild-thumbnails-if-workareas-size-c.patch:
    workspaceThumbnail-initialize-porthole-based-on-workArea.patch:
    - Cherry-picks from upstream, avoid unneeded computations in activities
  * popupMenu-Fix-wrong-call-to-clutter_actor_add_child.patch:
    - Cherry-pick from upstream
  * volume-Add-back-sound-feedback-on-scroll.patch:
    - Fix regression causing missing feedback on volume slider scroll

  Add patches proposed upstream:
  * shell-ignore-invalid-window-monitor-index.patch:
    - Fix crash on accessing on invalid monitor windows (LP: #1724439)
  * StIcon-only-compute-shadow-pipeline-when-the-texture-is-p.patch:
    - Don't try to compute shadows on not allocated icons (LP: #1723378)
  * js-fix-invalid-access-errors.patch:
    - Fix javascript errors (LP: #1747566)
  * workspace-fix-repositioned-windows-in-activities.patch:
    - Ensure windows thumbnails coordinates are correct (LP: #1653153)
  * st-texture-cache-Cancel-sliced-image-loading-on-target-ac.patch:
    - Fix possible crash on cache loading
  * st-texture-cache-Don-t-add-NULL-textures-to-cache.patch:
    - Fix crash when deleting NULL textures from cache (LP: #1754445)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 17 Apr 2018 14:40:17 -0400

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers