Two instances of a program launch whenever you touch a favorites icon, or app grid won't show

Bug #1745888 reported by PJSingh5000 on 2018-01-29
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Yuan-Chen Cheng
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Bionic
Undecided
Marco Trevisan (Treviño)
Cosmic
Undecided
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

Using a touch screen, if you tap on a favorites icon on the ubuntu dock, two (or more) instances of an application launch.

Also the app grid doesn't show after a quick tap on the apps icon

[ Test case ]

- Look for xterm in gnome-shell activities and add it to favourtes
- With the ubuntu-dock showing in the desktop, touch the xterm icon
- Only one instance if it should open
- Tapping the app icons grid should properly open the g-s overview
- Tapping on dock icons when in overview mode should work normally

[ Regression potential ]

Taps on other gnome-shell buttons could not work poperly (like some menu items or app grid)

ProblemType: BugDistroRelease: Ubuntu 17.10
Package: gnome-shell-extension-ubuntu-dock 0.7.1
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Jan 28 19:47:17 2018
InstallationDate: Installed on 2018-01-28 (1 days ago)
InstallationMedia: Ubuntu 17.10.0 2018.01.26 amd64 "Custom Artful Aardvark"
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: gnome-shell-extension-ubuntu-dock
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

PJSingh5000 (pjsingh5000) wrote :
tags: added: touch
PJSingh5000 (pjsingh5000) wrote :

Copying the description from duplicate bug #1769540, since there is more information in that description. Also, note that this bug is present in 18.04 (as well as 17.10)...

If you touch an icon on the dock using a touch screen, the dock performs duplicate actions for a single touch event.

1. Touching the app-grid icon on the dock with your finger causes the "applications dash" to appear, and quickly disappear, as if you had left-clicked on the app-grid icon *twice* using a mouse button.

2. Touching any favorites icon on the dock with your finger causes the selected application to open *two* instances, as if you had left-clicked on the app-grid icon twice using a mouse button.

THIS ONLY AFFECTS UBUNTU-DOCK
-----------------------------

This only happens when using the touch screen to interact with the dock. Using a mouse or track-pad works as expected.

The top-bar behaves as expected, as well, when using the touch screen. For example, touching the Activities label ovens the "dash overview" as expected; touching the notifications area on the top bar opens the notifications/calendar as expected; touching the indicator icons behave as expected as well.

Interacting with open applications using the touch screen also works as expected. Applications respond to touch events as if a single event was generated.

UBUNTU DOCK
-----------

Only the ubuntu-dock acts as if it received two (or more) touch events for each single touch action.

EXPECTED BEHAVIOR
-----------------

Ubuntu dock should respond as if it received a single click event, for each single touch event.

ADDITIONAL INFORMATION
----------------------

If I touch the "Action" item at the top left of the desk-top, the overview appears. THEN, if I touch an icon in the dock, it behaves correctly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Zyell (astroneer001-gmail) wrote :

I found an issue on the dash-to-dock repository on github that may be related: https://github.com/micheleg/dash-to-dock/issues/128

Zyell (astroneer001-gmail) wrote :

I can confirm that this issue does not affect a wayland session, as stated in the github issue I linked to previously.

Changed in oem-priority:
status: New → Confirmed
Changed in oem-priority:
importance: Undecided → Critical
Sebastien Bacher (seb128) wrote :

Thanks, I've added it to the desktop team trello backlog work for next cycle (e.g after next week)

affects: gnome-shell-extension-ubuntu-dock (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Will Cooke (willcooke) on 2018-10-11
tags: added: 2in1
Jerry Kao (jerry.kao) wrote :

I hit the same issue on XPS13 with 18.04.

Changed in oem-priority:
importance: Critical → High

I think this is mostly happening with snaps when they are updated too.
So, might imply some further changes around.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: added: somerville
tags: added: bionic
removed: somerville
tags: removed: artful
Changed in oem-priority:
importance: High → Critical
tags: added: somerville
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
PJSingh5000 (pjsingh5000) wrote :

I'm willing to help test this, so please let me know what to do.

Upstream fix is at https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/272

Ther are also workarounds in the extension itself which I mentioned in: https://github.com/micheleg/dash-to-dock/issues/128#issuecomment-432913072
  -

PJSingh5000 (pjsingh5000) wrote :

Marco,

I tried the extension level patch at https://github.com/micheleg/dash-to-dock/issues/128#issuecomment-432913072.

Here are my findings...

#1
It worked great for preventing two instances of am application from launching when touching an icon on the dock.

#2
However, touching the App Grid Icon still does not work. (It seems like the App Grid is unresponsive, but what is really happening is that the applications overview appears briefly and suddenly disappears, as if you had tapped on the App grid Icon twice).

Does the fix at https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/272 resolve item #2 above?

System Info...

$ lsb_release --all
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 18.10
    Release: 18.10
    Codename: cosmic

$ gnome-shell --version
    GNOME Shell 3.30.1

$ uname -r
    4.18.0-10-generic

PSJSingh,

As I wrote in the upstream report, #1 wasn't enough for app grid, you had to filter the notify::checked signal callback, but we're going with the fix proposed that just handles both.

description: updated
Iain Lane (laney) on 2018-11-07
Changed in gnome-shell (Ubuntu Bionic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Cosmic):
status: New → In Progress
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu Cosmic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.30.1-2ubuntu2

---------------
gnome-shell (3.30.1-2ubuntu2) disco; urgency=medium

  [ Didier Roche ]
  * debian/patches/ubuntu/background_login.patch:
    - match Yaru theme in the ubuntu session instead of our previous GDM
      background (LP: #1789356)
  * debian/patches/ubuntu/resolve_alternate_theme_path.patch:
    - ensure we resolve finale theme file path to correctly load assets
      under gdm (LP: #1798747)

  [ Marco Trevisan (Treviño) ]
  * debian/patches/st-button-Ignore-pointer-emulated-touch-events.patch:
    - Don't emit two click events on touch under X11 (LP: #1745888)

 -- Iain Lane <email address hidden> Wed, 07 Nov 2018 11:05:30 +0000

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released

Hello PJSingh5000, or anyone else affected,

Accepted gnome-shell into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.30.1-2ubuntu1.18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello PJSingh5000, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Test pass on bionic:
1. on a laptop with a touch screen, touch the file manager icon on the launcher. Saw two file manager is launched.
2. enable proposed channel
3. apt install gnome-shell, it upgrades to version 3.28.3-0ubuntu0.18.04.3
4. log out and log in.
5. touch file manager icon on the launcher, confirmed that only one file manager is launched.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Yuan-Chen Cheng (ycheng-twn) wrote :

On cosmic, even without turn on the proposed channel, with gnome-shell 3.30.1-2ubuntu1, I can't reproduce this issue.

With the gnome-shell 3.30.1-2ubuntu1.18.10.1 from the proposed channel, it still works fine.

description: updated
summary: - Two instances of a program launch whenever you touch a favorites icon
+ Two instances of a program launch whenever you touch a favorites icon,
+ or app grid won't show
no longer affects: gnome-shell (Ubuntu Cosmic)
Yuan-Chen Cheng (ycheng-twn) wrote :

per re-test #16, and #17, confirmed that
1. on bionic, with new gnome-shell, app grid properly appears after upgrade to new version.
2. on cosmic, app grid works without the upgrade to new version. (test with the cosmic cd as live image)

Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)

As per my tests, it appears in all the versions on a long tap, but not quick one (as X in that case doesn't send two events).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.3-0ubuntu0.18.04.3

---------------
gnome-shell (3.28.3-0ubuntu0.18.04.3) bionic; urgency=medium

  * debian/ubuntu.css:
    - use defined color for menu separators (LP: #1739931)
    - set StEntry minimun height to work properly with Ubuntu font (LP: #1743058)
  * debian/patches/st-button-Ignore-pointer-emulated-touch-events.patch:
    - Don't emit two click events on touch under X11 (LP: #1745888)
  * d/p/st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
    d/p/st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
    - Handle NULL scroll bars in st-scroll-view (LP: #1725312)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 06 Nov 2018 17:49:17 +0000

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in oem-priority:
status: Confirmed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Don't forget cosmic (still in proposed)

Yuan-Chen Cheng (ycheng-twn) wrote :

@Daniel, just FYI that per #18 and #19, I can't reproduce the issue with cosmic.

Cubic PPA (cubic-wizard) wrote :

On Cosmic, running on physical hardware, I ~did~ experience the issue with the app grid using gnome-shell 3.30.1-2ubuntu1. So I do not think Cosmic is immune to this issue.

- - - - - - - - - - - - - - - - - - - -

However, I just tested the proposed gnome-shell version 3.30.1-2ubuntu1.18.10.1 in Cosmic.

With the proposed version...
1. The app grid works as expected
2. The favorites icons work as expected

- - - - - - - - - - - - - - - - - - - -

I did notice an odd behavior...
May be it warrants as separate bug report?
Nevertheless, I'll share it here in case others run into this as well.

1. Give a long press on a favorites icon.
2. The icon becomes opaque (as if it is ready to be moved on the dock).
3. The context menu (New Window, Preferences, Remove from Favorites, etc.) appears.
4. Select New Window.
5. A new window opens.

6. Then tap a different favorites icon.
7. Instead of opening the application, the context menu appears.
8. I am then unable to make a selection from the context menu.

9. Sometimes the icon gets moved from its position on the dock.
10. But it doesn't land back on the dock. Instead it is partially on the dock and partially on the desktop.
11. At this point, the desktop becomes unresponsive.

    Alt-F2 does not work.
    Mouse clicking does not work.
    Touch screen does not work.

    Ctrl-Alt-F1 ~does~ work, and you can use the GDM screen to reboot the machine.

Iain Lane (laney) on 2018-12-05
Changed in gnome-shell (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

Verified with 3.30.1-2ubuntu1.

@cubic-wizard - could you please file that as a new issue?

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.30.1-2ubuntu1.18.10.1

---------------
gnome-shell (3.30.1-2ubuntu1.18.10.1) cosmic; urgency=medium

  [ Didier Roche ]
  * debian/patches/ubuntu/background_login.patch:
    - match Yaru theme in the ubuntu session instead of our previous GDM
      background (LP: #1789356)
  * debian/patches/ubuntu/resolve_alternate_theme_path.patch:
    - ensure we resolve finale theme file path to correctly load assets
      under gdm (LP: #1798747)

  [ Marco Trevisan (Treviño) ]
  * debian/patches/st-button-Ignore-pointer-emulated-touch-events.patch:
    - Don't emit two click events on touch under X11 (LP: #1745888)

  [ Iain Lane ]
  * Update Vcs-Git for SRU to cosmic

 -- Iain Lane <email address hidden> Wed, 07 Nov 2018 12:16:25 +0000

Changed in gnome-shell (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.