Bluetooth icon shows "Off" and the only option given below it is "Turn Off"

Bug #1738838 reported by Christopher Barrington-Leigh
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Medium
GNOME Shell
Expired
Medium
gnome-bluetooth (Ubuntu)
Medium
Unassigned
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

See video. I have installed bluetooth, blueman, bluez but it makes no difference to a broken interface to control bluetooth under Gnome 17.10, as shown in the attached video.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: bluetooth 5.46-0ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-19.22-generic 4.13.13
Uname: Linux 4.13.0-19-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Dec 17 22:32:30 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-11-18 (30 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
InterestingModules: bnep btusb bluetooth
MachineType: LENOVO 20BXCTO1WW
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-19-generic.efi.signed root=UUID=02bd5120-a925-442c-a0dd-1cce59920632 ro quiet splash psmouse.synaptics_intertouch=0 vt.handoff=7
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/06/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: JBET54WW (1.19 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20BXCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40697 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJBET54WW(1.19):bd11/06/2015:svnLENOVO:pn20BXCTO1WW:pvrThinkPadT450s:rvnLENOVO:rn20BXCTO1WW:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T450s
dmi.product.name: 20BXCTO1WW
dmi.product.version: ThinkPad T450s
dmi.sys.vendor: LENOVO
hciconfig:

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Because of the method that the dbus proxies are created there is currently a race condition. When an adapter is added it can have an initial "Powered" state of off which is turned on immediately afterwards. However, the signal connect to get the update only happens later.

This can be easily reproduced on thinkpads by running "rfkill block 0" and "rfkill unblock 0" while looking at the gnome-control-center bluetooth panel.

Attaching a patch that should fix the issue. I hope I didn't totally misunderstand how the whole DBus proxy stuff is supposed to work.

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Created attachment 351663
lib: Rework adapter and device proxy registrations.

This fixes a race condition when a property was updated right after the
object appeared on the bus. Due to the old implementation the property
change would not be registered in that case.

This moves the code to use GDBusObjectManagerClient and using the
provided GObject properties instead of a separate proxy to avoid the
race condition.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Review of attachment 351663:

The patch is unreviewable. Make the hunks bigger and try to split up the changes if at all possible.

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Created attachment 351966
lib: Rework adapter and device proxy registrations.

This fixes a race condition when a property was updated right after the
object appeared on the bus. Due to the old implementation the property
change would not be registered in that case.

This moves the code to use GDBusObjectManagerClient and using the
provided GObject properties instead of a separate proxy to avoid the
race condition.

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Created attachment 351967
lib: Always send "default-adapter-powered"

Fix sending of default-adapter-powered in the case that the default
adapter is being disabled.

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Created attachment 351968
lib: Force custom icon code override to run

The property setter currently contains some magic to modify the icon for
certain device types. Send a property change notification to force this
code to run after a device has been added.

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

There, that is all logical changes split out.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

I won't have time to review this in the short-term, but a dbusmock regression test which shows the problem before, and shows it fixed afterwards would be really useful.

See those in gnome-settings-daemon (though they've been broken for a while for different reasons...):
https://git.gnome.org//browse/gnome-settings-daemon/tree/tests/gsdtestcase.py
https://git.gnome.org//browse/gnome-settings-daemon/tree/plugins/power/test.py

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

The patch might be hard to read as it changes all the property accessors, but really it all boils down to the two questions:
 * Is it correct to use GDBusObjectManagerClient to keep track of the objects?
 * Is it good to use GObject properties on the Adapter1/Device1 proxies (instead of manually driving a DBus properties interface proxy)?

I agree that dbusmock test would be nice in here. But I personally think adding that testing infrastructure is out of the scope for me here. In this particular case I would even say that it would be an over specific test to catch a case of synchronous API abuse.

The race is actually surprisingly obvious. The calls to *_proxy_new_for_bus_sync cause the mainloop to run which means DBus messages are processed too early:
 * InterfacesAdded is fired by bluez
 * Properties change notification for "Powered" is fired by bluez
 * adapter_added runs mainloop for adapter1_proxy_new_for_bus_sync
   - at least dbus calls for name resolving happen
 * adapter_added runs mainloop for properties_proxy_new_for_bus_sync
   - at least dbus calls for name resolving happen
 * Properties notification has been lost while running those mainloops
 * adapter_added uses cached property values from InterfacesAdded method call
 * adapter_added connects to "g-properties-changed" on the proxy

The improvements from bug #701399 made this race condition worse.

With the patch, the code becomes:
 * InterfaceAdded is fired on bluez
 * Properties change notification for "Powered" is fired by bluez
 * GLib creates the Adapter1 proxy object
 * glib sends notification about the new object
 * connect to Adapter1 happens
 * Properties are queried from Adapter1 object through GObject

There simply is no scope for a race condition as connecting/querying happens in an atomic fashion.

--

Note that there is quite a lot of cleanup potential. In particular BLUETOOTH_COLUMN_PROPERTIES and creation of the properties proxy can be removed if this doesn't constitute an API/ABI break.

Revision history for this message
In , Mario Sánchez Prada (mariospr) wrote :

Created attachment 361759
Inconsistency in the bluetooth menu

In Endless's fork of GNOME Shell 3.24, we sometimes get an inconsistent state in the system menu for the Bluetooth, that leads to weird situations where you see the menu item as "Off" even if bluetooth is active (and we know that because we can use the BT mouse), with a submenu item showing "Turn Off".

See the attached picture for a better visual description of the problem.

As far as I can see, this is a problem in master too, patch will be coming soon..

Revision history for this message
In , Mario Sánchez Prada (mariospr) wrote :

Created attachment 361760
1. bluetooth: Add missing 'BluetoothHardwareAirplaneMode' to D-Bus interface

Revision history for this message
In , Mario Sánchez Prada (mariospr) wrote :

Created attachment 361761
2. bluetooth: Be consistent when determining whether Bluetooth is off

Revision history for this message
In , Florian-muellner (florian-muellner) wrote :

Review of attachment 361760:

Whoops

Revision history for this message
In , Florian-muellner (florian-muellner) wrote :

Review of attachment 361761:

> otherwise we risk showing inconsistent states in each place if.

I'd be interested in how that sentence continues :-p

Joking aside, I don't think this is correct. As far as I can see, "nConnectedDevices == -1" means there is no Bluetooth adapter that is powered on - we can toggle the AirplaneMode property as much as we want (that's what "Turn On/Off" does after all), that's not going to change. So a better option may be to do

  this._toggleItem.actor.visible = nConnectedDevices > -1;

instead ...

::: js/ui/status/bluetooth.js
@@ +134,3 @@

+ // Bluetooth will be considered 'Off' if either the adapter
+ // is not available or it's set in irplane mode.

*airplane

Revision history for this message
In , Mario Sánchez Prada (mariospr) wrote :

Comment on attachment 361760
1. bluetooth: Add missing 'BluetoothHardwareAirplaneMode' to D-Bus interface

(In reply to Florian Müllner from comment #3)
> Review of attachment 361760 [details] [review]:
>
> Whoops

Thanks for the review. Commmitted:
https://git.gnome.org/browse/gnome-shell/commit/?id=fb3070981c549ad9812d62f8ab868c323ed2ccf5

Revision history for this message
In , Mario Sánchez Prada (mariospr) wrote :

(In reply to Florian Müllner from comment #4)
> Review of attachment 361761 [details] [review]:
>
> > otherwise we risk showing inconsistent states in each place if.
>
> I'd be interested in how that sentence continues :-p

I'd be too, but I can't remember what I had in there :). I suppose it' was something along the lines of "...if the adapter is available but it's set in airplane mode".

> Joking aside, I don't think this is correct. As far as I can see,
> "nConnectedDevices == -1" means there is no Bluetooth adapter that is
> powered on - we can toggle the AirplaneMode property as much as we want
> (that's what "Turn On/Off" does after all), that's not going to change. So a
> better option may be to do
>
> this._toggleItem.actor.visible = nConnectedDevices > -1;
>
> instead ...
>
> ::: js/ui/status/bluetooth.js
> @@ +134,3 @@
>
> + // Bluetooth will be considered 'Off' if either the adapter
> + // is not available or it's set in irplane mode.
>
> *airplane

I thought the same thing, but I'm not 100% sure on whether it's possible to have a BT adapter that would be "powered on"/"available" and would still report to be in airplane mode (either soft or hard), so I thought the sane thing to do was to check both things, just in case.

What looks more clear to me, is that the same condition should be used in both places, since what you want to show in both labels depend on exactly the same thing.

I'm adding Bastien to CC, since he added the original code and might have extra info to decide what's best to do here.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363618
lib: Remove unneeded include

Nothing is using the code in the generated bluetooth-fdo-glue.h
header.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363619
lib: Remove never used FDO_PROPERTIES_INTERFACE constant

It was added as a constant during the BlueZ 5 port (commit 0b05349) but
was never used.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363620
lib: Indent and document gtk_tree_store_new() call

Makes it easier to see which column has which type.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363621
lib: Use GDBusObjectManager

Instead of our home-made ObjectManager proxy. Note that this is a
minimal port and will require more cleaning up to be up to standards.

Loosely based on patch by Benjamin Berg <email address hidden>

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363622
lib: Remove creation of intermediate GDBusProxies

We already have what we need created by the GDBusObjectManager.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363623
lib: Simplify Properties setting

Stop setting properties on adapters or devices by making D-Bus calls
ourselves, and rely on wrapped GObject properties instead.

For the calls we're making, the only change will be the error message
coming from the generated wrapper, rather than being our own custom ones.
We weren't really able to recover from errors in the past anyway, so
this shouldn't make the overall experience any worse.

This also fixes a possible hang on exit in the Bluetooth panel.

See https://bugzilla.gnome.org/show_bug.cgi?id=789654

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363624
lib: Remove last users of "Properties" D-Bus wrapper

As those property objects were not used anywhere anymore.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363625
lib: Remove fd.o Properties API glue

As we removed the last users of that code.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363626
lib: Fix possible race when creating adapters or devices

When new D-Bus objects appear, listen to changes to their properties as
soon as possible to avoid missing out on events. This can happen if a
synchronous D-Bus call is made between the device appearing, and we
start listening to changes.

The window for that race is smaller now that we avoid creating
GDBusProxies and fetching properties synchronously when new adapters or
devices appear, but this close that window altogether.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Created attachment 363627
lib: Always send "default-adapter-powered"

Fix sending of default-adapter-powered in the case that the default
adapter is being disabled.

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Attachment 363618 pushed as b5a6455 - lib: Remove unneeded include
Attachment 363619 pushed as 899eb7d - lib: Remove never used FDO_PROPERTIES_INTERFACE constant
Attachment 363620 pushed as 215acf6 - lib: Indent and document gtk_tree_store_new() call
Attachment 363621 pushed as 17983ac - lib: Use GDBusObjectManager
Attachment 363622 pushed as 9319001 - lib: Remove creation of intermediate GDBusProxies
Attachment 363623 pushed as 27e88fc - lib: Simplify Properties setting
Attachment 363624 pushed as 61f5ad5 - lib: Remove last users of "Properties" D-Bus wrapper
Attachment 363625 pushed as afccb57 - lib: Remove fd.o Properties API glue
Attachment 363626 pushed as 9c6d93a - lib: Fix possible race when creating adapters or devices
Attachment 363627 pushed as dbe815a - lib: Always send "default-adapter-powered"

Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :

Which leaves us with attachment 351968. I have trouble understanding in which case this could happen now. Can you file a new bug if this is still needed?

Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

Oh, right. Attachment 351968 was just my way of to not duplicate the icon override logic.

Revision history for this message
Christopher Barrington-Leigh (cpbl) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Sounds like maybe you need the fix (firmware) from bug 1729389. Please try that...

[ 11.611969] Bluetooth: hci0 command 0xfc8e tx timeout
[ 19.676091] Bluetooth: hci0 sending Intel patch command (0xfc8e) failed (-110)
[ 19.676204] Bluetooth: hci0 sending frame failed (-19)
[ 21.692087] Bluetooth: hci0 command 0xfc11 tx timeout
[ 21.692093] Bluetooth: hci0: Exiting manufacturer mode failed (-110)

Changed in bluez (Ubuntu):
status: New → Incomplete
Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Changed in gnome-shell (Ubuntu):
status: New → Incomplete
summary: - bluetooth does not turn on; settings interfaces are nonsensical
+ Bluetooth icon shows "Off" and the only option given below it is "Turn
+ Off"
Changed in bluez (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Changed in gnome-bluetooth:
importance: Unknown → Low
status: Unknown → Confirmed
Revision history for this message
In , BenjaminBerg (benjamin-sipsolutions) wrote :

*** Bug 775376 has been marked as a duplicate of this bug. ***

Changed in gnome-bluetooth:
status: Confirmed → Invalid
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
no longer affects: gnome-bluetooth
Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Aurélien PIERRE (aurelienpierre) wrote :

Same bug on Ubuntu 18.04 / Thinkpad P51.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-bluetooth:
importance: Medium → Unknown
status: Fix Released → Unknown
no longer affects: bluez (Ubuntu)
no longer affects: gnome-control-center (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Another fix is on the way, specifically for gnome-shell:
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/118

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: added: bionic
Revision history for this message
In , Bugzilla-x (bugzilla-x) wrote :
Changed in gnome-shell:
status: Confirmed → Expired
Revision history for this message
Christopher Barrington-Leigh (cpbl) wrote :

Same/very similar problem in 18.10.

tags: added: cosmic
removed: artful
tags: removed: cosmic
Revision history for this message
In , Daniel van Vugt (vanvugt) wrote :

Please reopen this bug. The above link is not a bug.

Changed in gnome-shell:
importance: Medium → Unknown
status: Expired → Unknown
tags: added: focal
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed the same bug is still in gnome-shell master (version 3.35).

Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Expired
Revision history for this message
Rajesh Chaudhary (rajeshisnepali) wrote :

This bug existed yesterday on my Ubuntu 20.04. I probably had suspended the laptop. A couple of days ago, it was working fine even after suspending the laptop.

I haven't tried rebooting the laptop. Rebooting might work fine. But I want a permanent fix. I don't think it's about the driver issue.

Bug: https://imgur.com/a/0Vx4Sqb

Here's my rfkill outup:
ID TYPE DEVICE SOFT HARD
 1 wlan phy0 unblocked unblocked
 5 bluetooth hci0 unblocked unblocked

and my lspci:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

Revision history for this message
José Vitor Andrade (jose.vitorandrade) wrote :

It is 2021, Ubuntu 20.04 LTS on a Dell Inspiron 15R 5537 with Intel Wireless-AC 7260HMW card installed.

Rfkill output:
ID TYPE DEVICE SOFT HARD
 0 wlan dell-rbtn unblocked unblocked
 2 wlan phy0 unblocked unblocked
 5 bluetooth hci0 unblocked unblocked

And lspci:
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

Revision history for this message
David Gessel (dgessel) wrote :
Download full text (5.9 KiB)

Same problem:

MPOW Bluetooth 5 dongle (Model: BH456A)

$ uname -a
Linux dg-dl 5.8.0-44-generic #50~20.04.1-Ubuntu SMP Wed Feb 10 21:07:30 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

$ rfkill
ID TYPE DEVICE SOFT HARD
 1 wlan phy0 unblocked unblocked
 6 bluetooth hci0 unblocked unblocked

$ lspci
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 05)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation C226 Series Chipset Family Server Advanced SKU LPC Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation SATA Controller [RAID mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GM107GL [Quadro K1200] (rev a2)
01:00.1 Audio device: NVIDIA Corporation GM107 High Definition Audio Controller [GeForce 940MX] (rev a1)
03:00.0 PCI bridge: ASMedia Technology Inc. Device 1182
04:03.0 PCI bridge: ASMedia Technology Inc. Device 1182
04:07.0 PCI bridge: ASMedia Technology Inc. Device 1182
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

$ dmesg | grep -i blue
[ 2.641328] usb 3-7: Product: Bluetooth Radio
[ 6.626592] Bluetooth: Core ver 2.22
[ 6.626603] Bluetooth: HCI device and connection manager initialized
[ 6.626606] Bluetooth: HCI socket layer initialized
[ 6.626607] Bluetooth: L2CAP socket layer initialized
[ 6.626608] Bluetooth: SCO socket layer initialized
[ 6.860576] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000b lmp_ver=0a lmp_subver=8761
[ 6.861534] Bluetooth: hci0: RTL: rom_version status=0 version=1
[ 6.861534] Bluetooth: hci0: RTL: loading rtl_bt/rtl8761b_fw.bin
[ 6.903755] bluetooth hci0: Direct firmware load for rtl_bt/rtl8761b_fw.bin failed with error -2
[ 6.903759] Bluetooth: hci0: RTL: firmware file rtl_bt/rtl8761b_fw.bin not found
[ 97.431707] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 97.431708] Bluetooth: BNEP filters: protocol multicast
[ 97.431711] Bluetooth: BNEP socket layer initialized
[ 246.400802] usb 3-8: Product: Bluetooth Radio
[ 246.406937] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000b lmp_ve...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.