Libreoffice writer / calc etc show as white icon in launcher when opened

Bug #1727958 reported by Tom Moorhouse on 2017-10-27
78
This bug affects 14 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Expired
Medium
LibreOffice
Invalid
Low
gnome-shell (Ubuntu)
Low
Unassigned

Bug Description

Running Liboreoffice 5.4.2.2 in Ubuntu 17.10, there is an issue with the application's icons. The individual icons show up in the list of programs, and can be docked in the launcher - but a generic white libreoffice icon also shows up in the program list, and if any of the docked, correct, icons are clicked, a new, white icon appears that is generic across all libreoffice windows (e.g. if I have open writer and calc, the white icon gets two red dots and to access either the writer or calc window I have to click on the generic icon). This is annoying but not crippling, and not solved by a purge and reinstall.

Daniel van Vugt (vanvugt) wrote :

Are you using Gnome Shell (default in 17.10) or Unity? Only the latter has BAMF, AFAIK.

Changed in bamf:
status: New → Incomplete

I'm using the default Gnome Shell.

Cheers,

     Tom

On 27/10/17 08:57, Daniel van Vugt wrote:
> Are you using Gnome Shell (default in 17.10) or Unity? Only the latter
> has BAMF, AFAIK.
>
> ** Changed in: bamf
> Status: New => Incomplete
>

Thanks

affects: bamf → gnome-shell-extension-ubuntu-dock (Ubuntu)
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Thank you for your bug report.

That seems to be a known gnome-shell upstream issue and a wayland limitation see https://bugzilla.gnome.org/show_bug.cgi?id=779143 and https://cgit.freedesktop.org/libreoffice/core/commit/?id=6903066822900a700ccf67ae70fa171c94644a9a

affects: gnome-shell-extension-ubuntu-dock (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Don Paradis (dparadis) on 2017-11-05
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu):
status: Fix Released → Triaged
Xavier Guillot (valeryan-24) wrote :

It says "Fix released" but it was never for me and I still have the problem of white generic LibreOffice icon in dock - I'm now on Ubuntu 18.04 but was also the case on 17.10...

Daniel van Vugt (vanvugt) wrote :

This bug does not say Fix Released any more. It is open ("Triaged").

Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Invalid
Changed in gnome-shell:
status: Confirmed → Expired
tags: added: artful bionic
summary: - In Ubuntu 17.10 Libreoffice writer / calc etc show as white icon in
- launcher when opened
+ Libreoffice writer / calc etc show as white icon in launcher when opened

The bug is still present in Ubuntu 18.10.

The upstream-bug-report has been migrated to gitlab:

https://gitlab.gnome.org/GNOME/gtk/issues/767

In the above mentioned bug-report there is a patch included.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.