Shell animations are not smooth

Bug #1725180 reported by Hiruna Wijesinghe on 2017-10-20
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
gjs
Fix Released
Unknown
gjs (Ubuntu)
Medium
Daniel van Vugt
gnome-shell (Ubuntu)
Medium
Daniel van Vugt

Bug Description

Upstream fixes required to make all the overview/window/icon animations much smoother (at least halving render times):

https://gitlab.gnome.org/GNOME/gjs/merge_requests/390
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/948
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/936
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/1002

__________________________________________________________________________

+++UBUNTU RELEASE+++

Description: Ubuntu 17.10
Release: 17.10

+++PACKAGE VERSION+++

xwayland:
  Installed: 2:1.19.5-0ubuntu2
  Candidate: 2:1.19.5-0ubuntu2
  Version table:
 *** 2:1.19.5-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status

Bug found on Dell XPS 9560 4K model with GTX1050/Intel HD 630. Currently using Intel HD Graphics 630 as Nvidia seems to have no support for xwayland.

The window/dock/launcher animations are lagging/shaky (not smooth).

__________________________________________________________________________

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xwayland 2:1.19.5-0ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 20 19:09:27 2017
DistUpgraded: 2017-10-20 04:51:46,123 DEBUG icon theme changed, re-reading
DistroCodename: artful
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.10.0-37-generic, x86_64: installed
 bbswitch, 0.8, 4.13.0-16-generic, x86_64: installed
 nvidia-387, 387.12, 4.13.0-16-generic, x86_64: installed
 v4l2loopback, 0.10.0, 4.10.0-37-generic, x86_64: installed
 v4l2loopback, 0.10.0, 4.13.0-16-generic, x86_64: installed
ExecutablePath: /usr/bin/Xwayland
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation Device [8086:591b] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:07be]
   Subsystem: Dell GP107M [GeForce GTX 1050 Mobile] [1028:07be]
InstallationDate: Installed on 2017-05-24 (149 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 138a:0091 Validity Sensors, Inc.
 Bus 001 Device 002: ID 0cf3:e300 Atheros Communications, Inc.
 Bus 001 Device 004: ID 1bcf:2b95 Sunplus Innovation Technology Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 15 9560
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic.efi.signed root=UUID=38514616-2735-4966-91f7-71f1d60beb73 ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UpgradeStatus: Upgraded to artful on 2017-10-19 (0 days ago)
dmi.bios.date: 08/30/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.5.0
dmi.board.name: 05FFDN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/30/2017:svnDellInc.:pnXPS159560:pvr:rvnDellInc.:rn05FFDN:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 15 9560
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.1+17.10.20170901-0ubuntu1
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Hiruna Wijesinghe (hiruna) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

It sounds like you're referring to gnome-shell and not Xwayland.

affects: xorg-server (Ubuntu) → gnome-shell (Ubuntu)
summary: - xwayland animations are not smooth
+ Shell animations are not smooth
tags: added: performance
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

There is a variety of reasons for this. I have tried to start listing (and fixing) them here:

https://trello.com/c/Q6JYXPPs

However please note that a resolution for the original reporter will result in this bug being closed. If you feel your issues are in any way different then please open a new bug of your own using the command: ubuntu-bug mutter

Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: added: bionic cosmic
tags: removed: cosmic
tags: removed: artful
Daniel van Vugt (vanvugt) wrote :

I think this should be resolved with https://gitlab.gnome.org/GNOME/gnome-shell/issues/1271

tags: added: focal
Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: removed: focal
Daniel van Vugt (vanvugt) wrote :

But I won't make it a definite bug link. This bug is a little too vague right now...

Hiruna, can you please provide a video or screenshot indicating which animations are not smooth?

We really shouldn't cover multiple issues in one bug, but I will accept it if we can clarify and narrow the scope of this bug.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in mutter (Ubuntu):
status: Confirmed → Incomplete
Changed in gnome-shell (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in mutter (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
no longer affects: mutter (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
tags: added: champagne focal
Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gjs (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Since I've got a number of fixes coming in this area already and they are quite nearby to each other in the GUI we can treat it as a single issue. I've now listed the required fixes at the top of this bug.

Changed in gjs (Ubuntu):
status: Confirmed → In Progress
description: updated
description: updated
Changed in gjs (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gnome-shell (Ubuntu):
milestone: none → ubuntu-20.03
Changed in gjs (Ubuntu):
milestone: none → ubuntu-20.03
Changed in gjs (Ubuntu):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in gjs:
status: Unknown → New
Changed in gnome-shell:
status: Unknown → New
Changed in gnome-shell:
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

^^^
That's only the window spread performance fix that has landed (to be released in 3.35.91). Not everything yet.

Changed in gjs:
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

^^^
That's fixed in gjs 1.63.91

description: updated
Daniel van Vugt (vanvugt) wrote :

Fixed in (you need both):

gjs 1.63.91+
gnome-shell 3.35.92+

Changed in gjs (Ubuntu):
status: In Progress → Triaged
Changed in gnome-shell (Ubuntu):
status: In Progress → Triaged
tags: added: fixed-in-3.35.92 fixed-upstream
tags: added: rls-ff-notfixing
removed: champagne
Daniel van Vugt (vanvugt) wrote :

Don't panic, those are just tags. The full set of fixes detailed in comment #12 ARE expected to be released in Ubuntu 20.04.

Changed in gjs (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package gnome-shell - 3.36.0-2ubuntu1

---------------
gnome-shell (3.36.0-2ubuntu1) focal; urgency=medium

  * Merge with Debian. Ubuntu bugs resolved since 3.35.91-1ubuntu2:
    - gnome-shell crashed when enable-animations was false (LP: #1866044)
    - Overview animations were not reliably smooth (LP: #1725180)
    - Higher than necessary CPU usage on mouse movement (LP: #1848951)
    - Extension's preferences did not load (LP: #1866146)
  * debian/control:
    - Breaks yaru (<< 20.04.3~)
    - Breaks gnome-session (<< 3.35.3-1ubuntu4~) as per gdm yaru gresources
    - Breaks gnome-shell-extension-ubuntu-dock (<< 67ubuntu20.04.3)
    - Update Vcs-* to point to salsa ubuntu branches
  * ubuntu.json: Use Yaru gresource file for theming in ubuntu mode
  * debian/patches: Refresh
  * d/p/overview-Fade-in-out-over-the-desktop-instead-of-replacin.patch:
    - Fade in/out the desktop instead of replacing it (LP: #1847712)
  * d/p/ubuntu/gdm_alternatives.patch:
    - Set the default theme resource for gdm session to 'gdm3-theme.gresource'
    - Alias the default gnome-shell.css to gdm3.css
  * gnome-shell-common.install: Don't install compiled css file anymore
  * gnome-shell-common.{preinst,prerm}:
    - Remove obsolete alternative gdm3.css symlink
  * gnome-shell-common.postinst:
    - Set gnome-shell-theme.gresource as alternative for gdm3-theme.gresource
  * Remaining changes from debian:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-c...

Read more...

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

gjs (1.63.92-1) experimental; urgency=medium

  * New upstream release
  * tests-Avoid-filename-conflict-when-tests-run-in-parallel.patch: Drop,
    upstream

 -- Iain Lane <email address hidden> Tue, 03 Mar 2020 09:18:17 +0000

Changed in gjs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.