No login screen (mutter silently goes headless) on some AMD GPUs

Bug #1723577 reported by frenchy82 on 2017-10-14
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
High
gnome-shell (Ubuntu)
Critical
Didier Roche

Bug Description

On a fresch install, ubuntu stop and freeze before gdm is opened
With no splah i have "started user manager for uid 121" and then it freeze

need to uncomment WaylandEnable=false in custom.conf to start ubuntu so with xorg.

lspci -nn | grep VGA

return

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850] [1002:6739]

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.26.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-15.16-generic 4.13.4
Uname: Linux 4.13.0-15-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Oct 14 07:36:30 2017
DisplayManager: gdm3
GsettingsChanges:
 b'org.gnome.shell' b'favorite-apps' b"['firefox.desktop', 'thunderbird.desktop', 'rhythmbox.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop', 'org.gnome.Terminal.desktop', 'libreoffice-calc.desktop', 'libreoffice-writer.desktop', 'simple-scan.desktop']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2017-10-13 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Beta amd64 (20171012)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

frenchy82 (cartes) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Yvon TANGUY (vono22) wrote :

Hi

I have the same problem, or at least the same consequences.

Maybe related to #1723602 ?

I no longer have an Radeon HD 6850 (since 2 weeks ^^), but an RX 560.

I tried weston a little bit to know if it was a wayland problem, but weston works fine. I can launch some GTK apps on weston (gedit, nautilus ...), Firefox & Libreoffice don't run, even with xwayland.so module activated.

It's just that gnome-shell (or gdm) don't display anything. The screen stay at is at the moment it launched.

Yvon TANGUY (vono22) wrote :

With the debug option enabled in /etc/gdm3/custom.conf
journalctl -u gdm.service

Yvon TANGUY (vono22) wrote :

More log:
journalctl -b -4 > gdm-wayland-full-log.txt

I had to reboot with sys magic key (alt + print screen + b)

amano (jyaku) wrote :

Even after the updates of today (with the new kernel and the gnome-shell crash fix) the boot splash is getting stuck most of the time (certainly 3 out of 4 tries).

Only switching to the nvidia 340 blob fixes that (then it boots reliably, not showing Plymouth at all).

I don't think that it is a Plymouth bug, but GDM crashing when trying to bring up Wayland.

Since it crashes that early I don't think that it is related to mutter or gnome-shell at all. Or does GDM use mutter these days?

[S]Does apport leave a crash log in /var/crash/ with Ubuntu freezing or crashing that early?[/S] EDIT: Nope, no crash log in /var/crash/ at all :(

A regression in X? In Mesa?

amano (jyaku) wrote :

For me it worked reliably the whole development cycle until the week leading up to the 7th of October. It is borked just for about a week now. On the 5th of October I remember it being fine, it was borked when starting Ubuntu up on the morning of October 7th.

Now it seems like a dealbreaker worth debugging (if I knew where to start).

amano (jyaku) wrote :

If I get past Plymouth and into GDM (I have to try 4 times to succeed), I can log into the “Ubuntu“ session reliably. So I think that this bug is rather a GDM one than a gnome-shell one.

amano (jyaku) wrote :

Rather a GDM bug. I it doesn't get stuck on Plymouth, it starts up the “Ubuntu“ gnome-shell session reliably for me.

affects: gnome-shell (Ubuntu) → gdm3 (Ubuntu)
Xavier Guillot (valeryan-24) wrote :

Same here, all worked fine until 6th October, since 7th impossible to boot : screen stays frozen at the Ubuntu logo step, nothing works (even Ctrl Alt F1).

Last line says "Started User Manager for UID 121"

lspci -nn | grep VGA
07:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] [1002:683d]

Today I booted on a USB and with chroot I updated my main Ubuntu 17.10 partition, it didn't solve the issue...

frenchy82 (cartes) wrote :

Xavier , as a workaround you can use the option nomodeset as boot option and then disable wayland in custom.conf to start with xorg

tags: added: ubuntu-fr-artful
tags: added: amdgpu
summary: - Artfull won't start with wayland activated
+ Artful won't start with Wayland activated

the issue there seems with amd cards?

Changed in gdm3 (Ubuntu):
importance: Undecided → High
summary: - Artful won't start with Wayland activated
+ Artful won't start with Wayland activated (AMD?)
Daniel van Vugt (vanvugt) wrote :

The dates in comments #7 and #10 make me suspect the Mesa upgrade that was released on 5 October.

Xavier Guillot (valeryan-24) wrote :

Yes, for me all worked fine until 6th October, on this Friday evening I did the 17.10 updates of the week, and on 7th morning the start process was frozen on the "Ubuntu" screen - I'm sure I didn't make the updates on the 5th, so it could be this Mesa upgrade.

Timo Aaltonen (tjaalton) wrote :

Did you have 4.13 kernel before the upgrade? If not sure, try mainline 4.12 build from

http://kernel.ubuntu.com/~kernel-ppa/mainline/

amano (jyaku) wrote :

Timo, i was on 4.13.0.12 when noticing the regression. And reverted back to 4.13.0.11, which didn't change anything. So I don't think that a kernel update broke my Wayland.

Xavier Guillot (valeryan-24) wrote :

As suggested in french forum, I looked at the previous version :

https://launchpad.net/ubuntu/+source/mesa/17.2.1-0ubuntu1/+build/13388627

Attached is the file with 'apt policy' results

Xavier Guillot (valeryan-24) wrote :
amano (jyaku) wrote :

[code]
amano@amano-desktop:~$ uname -r
4.12.13-041213-generic
[/code]

It took 3 tries to bring up GDM.
So confirmed that this isn't a kernel regression.

amano (jyaku) wrote :

amano@amano-desktop:~$ uname -r
4.12.13-041213-generic

It took 3 tries to bring up GDM.
So confirmed that this isn't a kernel regression.

Xavier Guillot (valeryan-24) wrote :

I tried to boot from grub on kernels :

4.13.0-12
4.13.0-11
4.12.0-13
4.12.0-12
4.11.0-13

Still have the boot bug.

I also tried to downgrade Mutter :

https://launchpad.net/ubuntu/+source/mutter/3.26.0+20170925~ea214fb-1ubuntu1/+build/13517498

sudo dpkg -i gir1.2-mutter-1_3.26.0+20170925~ea214fb-1ubuntu1_amd64.deb libmutter-1-0_3.26.0+20170925~ea214fb-1ubuntu1_amd64.deb mutter-common_3.26.0+20170925~ea214fb-1ubuntu1_all.deb mutter_3.26.0+20170925~ea214fb-1ubuntu1_amd64.deb

Same : freeze on start.

Here is the /var/log/apt/history.log from 02 to 06/10 (the one which made the bug appear, after it's update from 15/10 in chroot), I hope it helps...

Xavier Guillot (valeryan-24) wrote :

Tried also reverts on :
https://launchpad.net/ubuntu/+source/xserver-xorg-video-ati/1:7.9.0-1/+build/12843201
https://launchpad.net/ubuntu/+source/xorg-server/2:1.19.3-1ubuntu6/+build/13313736

Still boot bug...

Hope I did not miss an instruction which would eliminate the good direction to solve this (will verify the apt policy later) !

Attached an extract of the /var/log/syslog (before and after I tried the revert actions to understand bug).

Daniel van Vugt (vanvugt) wrote :

I don't really understand comment #17-#18 but it looks like nobody has successfully tested downgrading Mesa yet (per comment #13).

You may have to download and install the previous version manually:
https://launchpad.net/ubuntu/+source/mesa/17.2.1-0ubuntu1/+build/13388627

That's the version which was in 17.10 until 5/6 October.

Changed in mesa (Ubuntu):
status: New → Incomplete
frenchy82 (cartes) wrote :

I've made too the revert to mesa 17.2.1-0ubuntu1_amd64 but it didn't help

Daniel van Vugt (vanvugt) wrote :

Thanks. We can /probably/ exclude Mesa then.

Next I would suggest downgrading mutter which is used to render gdm3 (and because the 3.26.1 release happened at the time of the bug too) but comment #21 seems to suggest that's already been tried.

Still, we can't definitively exclude Mesa or Mutter fully because there's always a chance that some mistake was made during testing. And there's also a chance that different people are experiencing different bugs. Please keep experimenting...

Xavier Guillot (valeryan-24) wrote :

Daniel, sorry, I did not complete my post after #18 and apt policy result - we were discussing with didrocks and frenchy82 on the French forum with the details, I tried to resume here all steps in order other people and developers involved in bug also got the informations.

http://forum.ubuntu-fr.org/viewtopic.php?pid=21810017#p21810017

So I did (always in chroot mode) :
sudo dpkg -i libegl1-mesa_17.2.1-0ubuntu1_amd64.deb libgbm1_17.2.1-0ubuntu1_amd64.deb libgl1-mesa-dri_17.2.1-0ubuntu1_amd64.deb libgl1-mesa-glx_17.2.1-0ubuntu1_amd64.deb libglapi-mesa_17.2.1-0ubuntu1_amd64.deb libgles2-mesa_17.2.1-0ubuntu1_amd64.deb libwayland-egl1-mesa_17.2.1-0ubuntu1_amd64.deb libxatracker2_17.2.1-0ubuntu1_amd64.deb mesa-va-drivers_17.2.1-0ubuntu1_amd64.deb mesa-vdpau-drivers_17.2.1-0ubuntu1_amd64.deb

It downgraded the 10 packages installed in 17.2.1 version.

But when I rebooted normally, it was still frozen at Ubuntu screen and message 'Started User Manager for UID 121'

My graphic card : Gallium 0.4 on AMD CAPE VERDE (DRM 2.49.0 / 4.10.0-19-generic, LLVM 4.0.0)

After dpwngrading mesa, I tried downgrading mutter, xserver-xorg-video-ati, xorg-server, then booting on the grub to older kernels : nothing worked, I still have the bug on startup.

You're right, I don't know if I missed something on the instructions to come back on previous versions with the risk to eliminate the good direction to search, or if bug comes from something else...

I was afraid of that, but frenchy82 test seems to confirm downgrading mesa is not enough to solve the problem. I can continue to do some testings if you need.

frenchy82 (cartes) wrote :

i've tested to revert mesa AND mutter but didn't help

Daniel van Vugt (vanvugt) wrote :

A new idea: libdrm was also upgraded on 5 October:

  https://launchpad.net/ubuntu/+source/libdrm/2.4.83-1

That might cause this problem since it provides:

  libdrm-amdgpu1

So try downgrading to:

  https://launchpad.net/ubuntu/+source/libdrm/2.4.82-1/+build/13171669

Xavier Guillot (valeryan-24) wrote :

After having also downgraded libdrm (of course I did not reapply updates on my main system after other reverts), it still doesn't start and stays at Ubuntu screen (UID 121)...

Logs attached to help.

Xavier Guillot (valeryan-24) wrote :
Xavier Guillot (valeryan-24) wrote :

In /etc/gdm3/custom.conf, on [debug] section, I activated Enable=true, here is the complete startup log.

But following command didn't work in chroot (to get more infos from gdm) :

root@ubuntu:/# sudo journalctl -b -u gdm
No journal files were found.
-- No entries --

amano (jyaku) wrote :

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1723619 is (sadly) not my issue. It took again 4 tries to have GDM appearing :(

Having me regress at the same time as the many ATI users seems too much of an incident.

amano (jyaku) wrote :

amano@amano-desktop:~$ uname -r
4.14.0-rc5-lp1723619+revert

So the revert there in the patched 4.14 kernel doesn't affect me :(

Changed in gdm3 (Ubuntu):
importance: High → Critical
Xavier Guillot (valeryan-24) wrote :

My home is encrypted (ecryptFS) so gdm can't access to ~/.config/monitors.xml

There is not another one :
root@ubuntu:/# sudo updatedb
root@ubuntu:/# locate monitors.xml
root@ubuntu:/#

I added to /etc/environment :
export MUTTER_VERBOSE=1
export MUTTER_VERBOSE=1
export MUTTER_DEBUG=1
export MUTTER_USE_LOGFILE=/tmp/mutterlogs
export MUTTER_DEBUG_SM=1
export MUTTER_DEBUG_BUTTON_GRABS=1
export WAYLAND_DEBUG=1

Here is the Mutter log.

Xavier Guillot (valeryan-24) wrote :

And the last syslog...

Xavier Guillot (valeryan-24) wrote :

Tried to downgrade Gnome Shell :

sudo dpkg -i gnome-shell_3.26.0-0ubuntu2_amd64.deb gnome-shell-common_3.26.0-0ubuntu2_all.deb

root@ubuntu:/home/GShell# sudo dpkg -i gnome-shell_3.26.0-0ubuntu2_amd64.deb gnome-shell-common_3.26.0-0ubuntu2_all.deb
dpkg: avertissement: dégradation (« downgrade ») de gnome-shell depuis 3.26.1-0ubuntu3 vers 3.26.0-0ubuntu2
(Lecture de la base de données... 343326 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de gnome-shell_3.26.0-0ubuntu2_amd64.deb ...
Dépaquetage de gnome-shell (3.26.0-0ubuntu2) sur (3.26.1-0ubuntu3) ...
dpkg: avertissement: dégradation (« downgrade ») de gnome-shell-common depuis 3.26.1-0ubuntu3 vers 3.26.0-0ubuntu2
Préparation du dépaquetage de gnome-shell-common_3.26.0-0ubuntu2_all.deb ...
Dépaquetage de gnome-shell-common (3.26.0-0ubuntu2) sur (3.26.1-0ubuntu3) ...
Paramétrage de gnome-shell-common (3.26.0-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour gconf2 (3.2.6-4ubuntu1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.54.1-1ubuntu1) ...
Paramétrage de gnome-shell (3.26.0-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.26-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...

It works, I can login on the GS Ubuntu session !

amano (jyaku) wrote :

So with this gnome-shell downgrade you can get past Plymouth into GDM reliably? I will try at home as well...

Xavier Guillot (valeryan-24) wrote :

Yes, I donwgraded in chroot Gnome Shell to this version :
https://launchpad.net/ubuntu/+source/gnome-shell/3.26.0-0ubuntu2/+build/13517504

After it boots normally and I get the login screen, then the Ubuntu Gnome Shell session, all works.

Developers are testing commits: I tried the 2 here (reverse of Shell headless mode)
https://launchpad.net/~didrocks/+archive/ubuntu/ppa/+build/13591531

And it still goes until the end of the boot without freezing anymore

valeryan24@valeryan24-desktop:~/Bureau/GShell$ sudo dpkg -i gnome-shell_3.26.1-0ubuntu4~revertheadless1_amd64.deb gnome-shell-common_3.26.1-0ubuntu4~revertheadless1_all.deb
[sudo] Mot de passe de valeryan24 :
(Lecture de la base de données... 343326 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de gnome-shell_3.26.1-0ubuntu4~revertheadless1_amd64.deb ...
Dépaquetage de gnome-shell (3.26.1-0ubuntu4~revertheadless1) sur (3.26.0-0ubuntu2) ...
Préparation du dépaquetage de gnome-shell-common_3.26.1-0ubuntu4~revertheadless1_all.deb ...
Dépaquetage de gnome-shell-common (3.26.1-0ubuntu4~revertheadless1) sur (3.26.0-0ubuntu2) ...
Paramétrage de gnome-shell-common (3.26.1-0ubuntu4~revertheadless1) ...
Traitement des actions différées (« triggers ») pour gconf2 (3.2.6-4ubuntu1) ...
Traitement des actions différées (« triggers ») pour libglib2.0-0:amd64 (2.54.1-1ubuntu1) ...
Paramétrage de gnome-shell (3.26.1-0ubuntu4~revertheadless1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.26-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...

apt policy gnome-shell gnome-shell-common

valeryan24@valeryan24-desktop:~$ apt policy gnome-shell gnome-shell-common
gnome-shell:
  Installé : 3.26.1-0ubuntu4~revertheadless1
  Candidat : 3.26.1-0ubuntu4~revertheadless1
 Table de version :
 *** 3.26.1-0ubuntu4~revertheadless1 100
        100 /var/lib/dpkg/status
     3.26.1-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
     3.25.91-0ubuntu5~ppa1 500
        500 http://ppa.launchpad.net/ubuntu-desktop/transitions/ubuntu artful/main amd64 Packages
gnome-shell-common:
  Installé : 3.26.1-0ubuntu4~revertheadless1
  Candidat : 3.26.1-0ubuntu4~revertheadless1
 Table de version :
 *** 3.26.1-0ubuntu4~revertheadless1 100
        100 /var/lib/dpkg/status
     3.26.1-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu artful/main i386 Packages
     3.25.91-0ubuntu5~ppa1 500
        500 http://ppa.launchpad.net/ubuntu-desktop/transitions/ubuntu artful/main amd64 Packages
        500 http://ppa.launchpad.net/ubuntu-desktop/transitions/ubuntu artful/main i386 Packages

valeryan24@valeryan24-desktop:~$ sudo modetest
sudo: modetest : commande introuvable

Didier Roche (didrocks) on 2017-10-18
affects: gdm3 (Ubuntu) → gnome-shell (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.26.1-0ubuntu4

---------------
gnome-shell (3.26.1-0ubuntu4) artful; urgency=medium

  * revert_023b50e7a7002226d6176bede22930d96da074a9.patch,
    revert_5c37facc083078564faaeec4aa58084857c56ee1.patch,
    and comment git_layout-unset-when-headless.patch:
    - Revert 2 upstream commits and cherry-pick to remove headless mode
      which shadows Shell crashing and thus fallback to Xorg, resulting in
      some user configs not having any UI on startup. (LP: #1723577)

 -- Didier Roche <email address hidden> Wed, 18 Oct 2017 15:05:32 +0200

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
no longer affects: mesa (Ubuntu)
summary: - Artful won't start with Wayland activated (AMD?)
+ GNOME Shell silently goes headless on some AMD GPUs (no login screen
+ shown)
summary: - GNOME Shell silently goes headless on some AMD GPUs (no login screen
- shown)
+ No login screen (mutter silently goes headless) on some AMD GPUs
Didier Roche (didrocks) on 2017-10-19
Changed in gnome-shell (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Xavier Guillot (valeryan-24) wrote :

I confirm that upstream commits to Gnome Shell and Mutter also solve the bug, I can normally boot and login on Wayland session (see log Upstream-1710 for details) !

amano (jyaku) wrote :

The nvidia user (me) can happily confirm that this bug is fixed now :)

What a nastie: A mutter crash that leads to the startup of the X.org fallback session which can't be displayed due to a gnome-shell regression. Wow. No wonder that this was so hard to diagnose. And timely cropping up just before final freeze to keep the fun alive.

Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.