gnome-shell crashed with SIGTRAP in g_malloc0() from blur_pixels() from _st_create_shadow_pipeline() from _st_create_shadow_pipeline_from_actor() from st_icon_update_shadow_pipeline()

Bug #1723378 reported by errors.ubuntu.com bug bridge on 2017-10-13
178
This bug affects 18 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
High
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.26.1-0ubuntu2, the problem page at https://errors.ubuntu.com/problem/39ad471656564025f5de8136fcb05bccd9c3e8c7 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Changed in gnome-shell (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
summary: - /usr/bin/gnome-
- shell:5:g_malloc0:blur_pixels:_st_create_shadow_pipeline:_st_create_shadow_pipeline_from_actor:st_icon_update_shadow_pipeline
+ gnome-shell crashed with SIGTRAP in g_malloc0() from blur_pixels() from
+ _st_create_shadow_pipeline() from
+ _st_create_shadow_pipeline_from_actor() from
+ st_icon_update_shadow_pipeline()
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Similar upstream bug is also https://bugzilla.gnome.org/show_bug.cgi?id=788908 (could be the same root cause)

Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Confirmed
Revision history for this message
hackel (hackel) wrote :

I just want to point out that when following the apport bug reporting process, it initially pulls up a list of existing bugs by searching for the subject "gnome-shell crashed with signal 5 in g_malloc0()", and this bug does not show up in that list. In fact, the most recent bug in that list is from 2012. As a result, people (or at least me, until now) aren't finding this to report issues as a duplicate, and they are commenting on these really old, unrelated bug reports. It might be a good idea to close out all of those old bugs so as to elevate issues arising now that gnome-shell is the default.

I get hit with this bug multiple times a day, so I'm going to just stop reporting it as I'm sure there are plenty of reports here by now, but please let me know if there's anything I can do to assist with debugging this issue.

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

hackel, I agree Launchpad could be made more intelligent. If you like you can log an enhancement request here: https://bugs.launchpad.net/launchpad/+filebug

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Worth noting this crash is new in 3.26.1 ...

https://errors.ubuntu.com/problem/39ad471656564025f5de8136fcb05bccd9c3e8c7

There are no reports of it prior to 3.26.1

tags: added: regression-release
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Right... But only because the code path changed there... And it's *very likely* due to commit 7015bb2 (but event the apparently right 7f381dd could have something related), however the code there was just wrong anyway... So better to fix that uncommit something that could still crash in other cases.

Changed in gnome-shell:
status: Confirmed → Invalid
Changed in gnome-shell:
status: Invalid → Confirmed
Changed in gnome-shell:
status: Confirmed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.1-0ubuntu1

---------------
gnome-shell (3.28.1-0ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release
  * Drop obsolete patches:
    - 27-nm-libexec-path.patch
    - fix-wayland-vbox-crash.patch

  [ Marco Trevisan (Treviño) ]
  Cherry-pick patches applied to upstream git master:
  * ui-Theme-lookup-should-respect-XDG_DATA_DIRS.patch:
    - Renamed from ubuntu_theme_lookup_xdg.patch and cherry-picked from
      upstream
  * workspaceThumbnail-only-update-_porthole-if-the-overview-.patch:
    workspaceThumbnail-rebuild-thumbnails-if-workareas-size-c.patch:
    workspaceThumbnail-initialize-porthole-based-on-workArea.patch:
    - Cherry-picks from upstream, avoid unneeded computations in activities
  * popupMenu-Fix-wrong-call-to-clutter_actor_add_child.patch:
    - Cherry-pick from upstream
  * volume-Add-back-sound-feedback-on-scroll.patch:
    - Fix regression causing missing feedback on volume slider scroll

  Add patches proposed upstream:
  * shell-ignore-invalid-window-monitor-index.patch:
    - Fix crash on accessing on invalid monitor windows (LP: #1724439)
  * StIcon-only-compute-shadow-pipeline-when-the-texture-is-p.patch:
    - Don't try to compute shadows on not allocated icons (LP: #1723378)
  * js-fix-invalid-access-errors.patch:
    - Fix javascript errors (LP: #1747566)
  * workspace-fix-repositioned-windows-in-activities.patch:
    - Ensure windows thumbnails coordinates are correct (LP: #1653153)
  * st-texture-cache-Cancel-sliced-image-loading-on-target-ac.patch:
    - Fix possible crash on cache loading
  * st-texture-cache-Don-t-add-NULL-textures-to-cache.patch:
    - Fix crash when deleting NULL textures from cache (LP: #1754445)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 17 Apr 2018 14:40:17 -0400

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.