No VPN autoconnect

Bug #1718931 reported by John Skottis on 2017-09-22
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
NetworkManager
Incomplete
Critical
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Nominated for Bionic by Marco Trevisan (Treviño)
Bionic
Undecided
Unassigned

Bug Description

[ Impact ]

When setting up VPN to auto connect with wifi (done through nm-connection-editor) the wifi never manages to connect. However if I unselect the auto connect option while it is attempting a reconnection then it manages to connect to both (wifi and VPN). Doing the connection manually also poses no issues

[ QA ]

This is part of the upstream fix: https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

ProblemType: BugDistroRelease: Ubuntu 17.10
Package: network-manager 1.8.2-1ubuntu8
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 22 13:15:55 2017
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2017-09-09 (12 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170908)
IpRoute:
 default via 192.168.0.1 dev wlp6s0 proto static metric 600
 169.254.0.0/16 dev wlp6s0 scope link metric 1000
 192.168.0.0/24 dev wlp6s0 proto kernel scope link src 192.168.0.18 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=trueSourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlp6s0 wifi connected /org/freedesktop/NetworkManager/Devices/2 VM5055940 85b8f881-7ed9-477a-9c39-9afb5a40bda9 /org/freedesktop/NetworkManager/ActiveConnection/1
 lo loopback unmanaged /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.8.2 connected started full enabled enabled enabled enabled enabled

John Skottis (giannissc) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in network-manager (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
J. Snow (jon.snow) wrote :

I'm facing the same problem. In auto-mode the VPN does not manage to connect, while manual connecting to the wifi enables automatic connection on the VPN.

J. Snow (jon.snow) on 2017-10-22
no longer affects: network-manager
Nicholas Stommel (nstommel) wrote :

Yeah, I keep getting the "vpn-connection[...]: Failed to request VPN secrets #3: No agents were available for this request." error message in my syslog. I found, however, that THIS worked for me: All you have to do is go Dash->VPN->VPN Settings->connection_name_here->Identity->Password->"Store for all users" and bingo problem solved. If nm-connection-editor says that you can't save the connection (the save box is grayed out), then...just forget the network and set up the connection again (worked for me at least). Once you have checked said auto-connect box with nm-connection-editor and ensured that the VPN password is set to "Store for all users," both the primary connection AND the VPN will start successfully at the same time. See my post at https://askubuntu.com/questions/967408/how-to-automatically-connect-to-vpn-in-ubuntu-17-10/967415#967415

Nicholas Stommel (nstommel) wrote :

Literally just toggling that one option "Store password for all users" in the VPN settings fixes the problem entirely. Use "sudo service network-manager restart" and it connects flawlessly the first time. To avoid the error loop on bootup specifically, just uncheck the box "Make available to other users" on the primary connection.

Odd Tore (oddtore1) wrote :

Not working for me at all.

I have a PPTP VPN server at home running on a linux 12.04 server.

Connecting to this server works like a charm from Android phones/tablets, I-phone (IOS versions before they stopped supporting PPTP), and win10.

I use this primarily to get IP adress from my home country when needed.

Anyway, my first issue was after installing Ubuntu 17.10 on a PC.
Experienced all the above mentioned issues, except that whatever I try to do with "Store password for all users" does not help.

Ended up setting up the VPN connection from command-line using the following tutorial: https://help.my-private-network.co.uk/support/solutions/articles/8452-pptp-vpn-setup-on-linux-ubuntu-via-terminal-command-line

Now I actually get connected to my server using pon <mynetworkname>, but DNS does not work.

I can open webpages typing in ip-address directly, and when I run traceroute, traffic appears to be going through my home network.

In /etc/ppp/ the 2 nameservers I have configured on server appears in resolv.conf

Any idea before I go mad?

Apicultor (apicultor) wrote :

@oddtore1 12.04 is deprecated; have you considered upgrading?

Also, PPTP is insecure and should not be used; many modern OS have even dropped support for it as a result. I recommend IKEv2 or L2TP-over-IPSEC.

Nicholas Stommel (nstommel) wrote :

Okay, so...why isn't this a priority bugfix? I love gnome, don't get me wrong, but when I can't even autoconnect to my VPN like I did countless times in the past few years running Ubuntu on Unity without compromising the security of my system something is wrong. There needs to be an option - and a working one at that - for auto-connecting to a VPN through the Gnome NetworkManager GUI. The KDE folks fixed this ages ago with KWallet, I suspect this involves the Gnome-Keyring. This is a *very* annoying problem. Should I report the bug on the Gnome bugtracker? So frustrating when this is an extremely common problem with nobody actually looking into *why* it's happening or how to fix it. I'm afraid this one is beyond me.

Nicholas Stommel (nstommel) wrote :

Filed an upstream bug, at long last, in the Gnome bugtracker at https://bugzilla.gnome.org/show_bug.cgi?id=793977

Changed in network-manager:
importance: Unknown → Critical
status: Unknown → Confirmed
Changed in network-manager:
status: Confirmed → Incomplete
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Low → High
Nicholas Stommel (nstommel) wrote :

Well...it has been quite some time and this bug has received absolutely *zero* attention from the Gnome Shell Gitlab here https://gitlab.gnome.org/GNOME/gnome-shell/issues/123 escalated from the Gnome Bugzilla tracker after Gnome shell development moved to Gitlab. The issue is fully present in Ubuntu 18.04 AND in the newer version of the Gnome shell and NetworkManager in Fedora 28. Before v3.26.X, auto-connect worked fine through the NetworkManager in the Gnome environment. I'm afraid to report that months later, absolutely nothing has been done to address what should be a relatively high-priority bug in the Gnome Shell. If anyone has the capabilities to reach out farther than I already have, please do so. This critical bug has been sitting idle with no attention for months, and persists across newer versions of the Gnome shell, namely 3.28.X, seemingly independent of distribution.

Sebastien Bacher (seb128) wrote :

The issue was one in the gnome-shell agent and has been fixed in 3.28.3

affects: network-manager (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
tags: added: fixed-in-3.28.3
description: updated

Fixed in:

gnome-shell (3.28.3-0ubuntu1) cosmic; urgency=medium

  * debian/patches/30-remoteMenu-Prevent-the-shell-from-becoming-unrespons.patch,
    debian/patches/magnifier.js-Fix-zoom-juddering.patch,
    debian/patches/st-label-Unset-clutter-text-instance-on-disposal.patch,
    debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch,
    debian/patches/st-texture-cache-Save-cairo-surfaces-to-a-different-map.patch,
    debian/patches/ui-Theme-lookup-should-respect-XDG_DATA_DIRS.patch:
    - Drop patches applied on the 3.28 branch
  * debian/patches/js-fix-invalid-access-errors.patch:
    - Refreshed to reflect upstream changes

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released

Hello John, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.