Shell menus (panel, dock, window) font size does not match configured interface font size

Bug #1717453 reported by Daniel van Vugt on 2017-09-15
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

Shell menus (panel, dock, window) font size does not match configured interface font size.

Test case:
gnome-tweak-tool > Fonts > Interface = (something different)

Expected: Shell menus to use the same font size.
Observed: Shell menu fonts never change.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.25.91-0ubuntu5
ProcVersionSignature: Ubuntu 4.12.0-13.14-generic 4.12.10
Uname: Linux 4.12.0-13-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
Date: Fri Sep 15 15:17:15 2017
DisplayManager: gdm3
InstallationDate: Installed on 2017-05-03 (135 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170502)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Currently, the default font-face for the shell theme is set in the CSS for the theme with the current rule:

"""
/* default text style */
stage {
    font-family: cantarell, sans-serif;
    font-size: 11pt;
    color: white;
}
"""

However, if a font other than cantarell is chosen for the default font in tweak-tool, cantarell still persists in the shell because of the CSS override.

is there anyway to set the default sans-serif font for the shell renderer to be whatever is set as the default? Then the hard-coded cantarell could be removed from the default theme

That's chosen by font-config. I'm not sure how easy it is to hook up to the desktop-font GSetting, considering it has abilities like size and weight: things we typically want to control from the theme ourselves.

*** Bug 706016 has been marked as a duplicate of this bug. ***

*** Bug 706251 has been marked as a duplicate of this bug. ***

Hi! I'm willing to work on a fix for this and came up with two ideas:

It would be possible to just use sans-serif (set it Cantarell) and let that be changeable via the gnome-tweak-tool.

Another alternative would be to use a different alias like "gnome-shell-font-overwrite". This would be unset by default (so that the theme font / Cantarell is used), but could be set by gnome-tweak-tool.

What do you think?

For simplicity sake (and not adding another option), i'd initally choose #1, however i think #2 is the way it should be done.

in tweak tool, you can currently set the font face itself, the size, and the style/weighting. However sizes / styles for gnome shell are all done in the CSS, and we just want to set the font-face essentially here, so my +1 is for adding another item/setting for picking the gnome-shell font.

One other issue to think about here too is that if a user does set a font that does to override the font in the CSS, any change in the tweak tool will not apply to the gnome-shell theme. Maybe we could recognise this and disable this option if the theme sets something other than sans-serif?

Hm ... what is the long goal for GNOME Shell themes btw? Because right now it isn't possible to set a font from Gtk themes, but from Shell themes. And I think most people want to have the same font for Gtk and the Shell, so I would say it might be a good idea to ignore the font-family option in Shell themes completely and simplify the GNOME Tweak font settings to

 sans-serif <- GNOME Shell, Gtk Widgets, ...
 serif <- Default font for web sites
 monospace <- Terminal and editor font

*** Bug 781858 has been marked as a duplicate of this bug. ***

Daniel van Vugt (vanvugt) wrote :
Daniel van Vugt (vanvugt) wrote :

See also bug 1717456

tags: added: bionic cosmic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: artful gnome-17.10
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
tags: removed: cosmic
tags: added: desktop-lts-wishlist
Daniel van Vugt (vanvugt) wrote :

I haven't verified it myself yet, but it looks like this has been fixed upstream in gnome-shell 3.36 (!486).

tags: added: fixed-upstream
Changed in gnome-shell (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package gnome-shell - 3.35.91-1ubuntu2

---------------
gnome-shell (3.35.91-1ubuntu2) focal; urgency=medium

  * control: Fix package for Yaru Breaks. It's called `yaru-theme-gnome-shell`
    and not `yaru-theme`
  * control: Bump Breaks on appindicator and desktop-icons.
    These have been updated for GNOME 3.36

gnome-shell (3.35.91-1ubuntu1) focal; urgency=medium

  * Merge with Debian. Remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      - Show monitor scaled cursor when magnifier is enabled
    + Break gnome-shell-extension-appindicator (<< 30)
    + Break gnome-shell-extension-desktop-icons (<< 19.01.3+git20190814)
    + Break gnome-shell-extension-ubuntu-dock (<< 67ubuntu20.04.1)
    + Break yaru-theme (<< 20.04.2)
  * debian/control:
    - Bump breaks on gnome-shell-extension-ubuntu-dock (<< 67ubuntu20.04.1)
    - Bump breaks on gnome-shell-extension-dashtodock (<< 67+git20200225-1)
    - Bump breaks on yaru-theme...

Read more...

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Sadly this still doesn't work in 3.35.91-1ubuntu2

Changed in gnome-shell (Ubuntu):
status: Fix Released → Confirmed
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
no longer affects: gnome-shell
tags: added: focal
tags: removed: fixed-upstream
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.