Settings for external monitor are deleted after reboot, suspension, log out

Bug #1716341 reported by Jeremie Tamburini on 2017-09-11
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)
Artful
High
Marco Trevisan (Treviño)

Bug Description

New Gnome Settings on Ubuntu 17.10

Settings for external monitor are working but after reboot/suspension/log-out log-in, the system will not remember the setup.

Example:
1- open Gnome Settings and select "Devices → Displays"
2- set the external monitor as "Single Display" and click on "Apply"
3- log-out

After log-in the laptop monitor will be set as default instead of the external monitor.

tags: added: artful
summary: - Settings for external monitor are delete after reboot, suspension, log
+ Settings for external monitor are deleted after reboot, suspension, log
out
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Incomplete
Sebastien Bacher (seb128) wrote :

g-c-c does send the config changes correctly, the issue is rather with g-s-d or gnome-shell

tags: added: rls-aa-incoming
affects: gnome-control-center (Ubuntu) → gnome-shell (Ubuntu)
Will Cooke (willcooke) on 2017-09-27
Changed in gnome-shell (Ubuntu Artful):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: removed: rls-aa-incoming
Changed in gnome-control-center:
status: Incomplete → Confirmed
Changed in gnome-control-center:
status: Confirmed → Fix Released
tags: added: multimonitor
Daniel van Vugt (vanvugt) wrote :

Consider de-duplicating with bug 1292398?

Jonathan Kamens (jik) on 2017-10-24
tags: added: regression-release
Daniel van Vugt (vanvugt) wrote :

For gnome-shell I don't think this is "regression-release" because gnome-shell has not regressed any worse than previous gnome-shell releases. You can always go back to Unity if it was working better for you:

  sudo apt install unity-session

and select it on the login screen.

tags: removed: regression-release
Jonathan Kamens (jik) wrote :

I think this is regression-release because the default display manager in Ubuntu 17.04 was not broken in this way and the default display manager in Ubuntu 17.10 is.

But hey, what do I know, I'm just an end user.

Daniel van Vugt (vanvugt) wrote :

Absolutely it's a regression in the overall product, and one that we have developers working on.

However that tag is only appropriate if the bug covers components where the problem did not exist in a previous version of those components. And AFAIK this bug probably did exist in previous gnome-shell versions (?)

Technically you could add a generic "Ubuntu" task up top and then it would then qualify as regression-release for general "Ubuntu", but I've never seen anyone do that. A generic "Ubuntu" task usually just means no one has yet figured out what component the bug is in.

Sebastien Bacher (seb128) wrote :

the issue there was fixed in 3.26.1 before 17.10, if you still have problems please report a new reports with detailed steps and log

Changed in gnome-shell (Ubuntu Artful):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

bug #1726538 was recent and from 3.26.1, unduplicated it so it can sent upstream and used for the new issue

Calin (calinuswork) wrote :

Is not clear to me if this was fixed or not?

I have the same issue on a brand new 17.10 installation.

Dmitrii Shcherbakov (dmitriis) wrote :

Hmm, for my installation upgraded from 17.04 it got fixed - I no longer experience the issue.

Chris (toefel) wrote :

I still experience the issue as of today on 17.10 after updating.

gnome-control-center/artful-updates,now 1:3.26.1-0ubuntu5 amd64 [installed,automatic]

Dmitrii Shcherbakov (dmitriis) wrote :

Chris, out of curiosity, do you have a dual-monitor setup?

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1726538

For me it works fine with a laptop monitor disabled + single monitor as a primary.

I use two external monitors with my Lenovo Thinkpad t430s sitting in a Lenovo docking station. The external monitors are connected through DVI and DisplayPort to the docking station. I see the problem both when using Wayland and Xorg. The laptop lid is closed and the internal screen is not used when sitting in the dock. My seconday display is positioned to the left of the primary display when everything is correct. But those settings does not persist over reboots.

Daniel van Vugt (vanvugt) wrote :

This bug is closed. So regardless of whether that's right or wrong, please keep the discussion in a bug that is still open, like bug 1292398 or bug 1726538.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.