gnome-shell crashed with SIGSEGV in g_type_check_instance_cast() from shell_gtk_embed_window_created_cb() from g_closure_invoke() from signal_emit_unlocked_R()

Bug #1714745 reported by Anders Kaseorg on 2017-09-03
134
This bug affects 18 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Medium
gnome-shell (Ubuntu)
High
Unassigned

Bug Description

https://errors.ubuntu.com/problem/7accb2ea7fd305736eb23cca5905e4b690a16cae

---

gnome-shell crashed with SIGSEGV in g_type_check_instance_cast()

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.25.91-0ubuntu2
ProcVersionSignature: Ubuntu 4.12.0-12.13-generic 4.12.8
Uname: Linux 4.12.0-12-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME
Date: Sun Sep 3 02:41:44 2017
DisplayManager: gdm3
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2016-02-19 (562 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160218)
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7feb5dff7e26 <g_type_check_instance_cast+22>: mov (%rdi),%rdi
 PC (0x7feb5dff7e26) ok
 source "(%rdi)" (0x3fe0000000000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 g_type_check_instance_cast () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 () at /usr/lib/gnome-shell/libgnome-shell.so
 g_closure_invoke () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-shell crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: Upgraded to artful on 2017-05-02 (123 days ago)
UserGroups: adm audio bumblebee cdrom dip docker libvirt libvirtd lpadmin mock plugdev sambashare sbuild sudo wireshark

Anders Kaseorg (andersk) wrote :

StacktraceTop:
 g_type_check_instance_cast (type_instance=0x3fe0000000000000, iface_type=546832872304) at ../../../../gobject/gtype.c:4052
 shell_gtk_embed_window_created_cb (display=0x7f51fd4000, window=0x7f528d07d0, embed=0x7f528d7720) at ../src/shell-gtk-embed.c:67
 g_closure_invoke (closure=0x7f549b9990, return_value=0x0, n_param_values=2, param_values=0x7ffe9b1c97b0, invocation_hint=0x7ffe9b1c9730) at ../../../../gobject/gclosure.c:804
 signal_emit_unlocked_R (node=node@entry=0x7f51ce5660, detail=detail@entry=0, instance=instance@entry=0x7f51fd4000, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7ffe9b1c97b0) at ../../../../gobject/gsignal.c:3635
 g_signal_emit_valist (instance=0x7f51fd4000, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7ffe9b1c9980) at ../../../../gobject/gsignal.c:3391

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Anders Kaseorg (andersk) on 2017-09-03
information type: Private → Public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
description: updated
summary: - gnome-shell crashed with SIGSEGV in g_type_check_instance_cast()
+ gnome-shell crashed with SIGSEGV in g_type_check_instance_cast() from
+ shell_gtk_embed_window_created_cb() from g_closure_invoke() from
+ signal_emit_unlocked_R()
Anders Kaseorg (andersk) wrote :

This is happening to me very frequently (several times a day) on both Wayland and Xorg. On Wayland, it brings down the entire session.

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Julian Andres Klode (juliank) wrote :

This can also happen while the screen is locked, hence revealing any possibly sensitive information on the screen, if running in X (in Wayland it probably just crashes completely). Hence upgrading to importance to High.

Changed in gnome-shell (Ubuntu):
importance: Medium → High
Anders Kaseorg (andersk) wrote :

This might be triggered by a shell extension. I haven’t seen any crashes after turning them all off. I’ll see if I can bisect which one it is.

Changed in gnome-shell:
status: Confirmed → Fix Released
Anders Kaseorg (andersk) wrote :

It seems to be the TopIcons Plus extension that triggers this so often. I think that’s roughly consistent with the upstream bug report.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Where is the fix committed? Is that just on the assumption that 3.26.1 is on the way?

Anders Kaseorg (andersk) wrote :

I’m not sure. Since it’s been a week without any sign of an upload to artful-proposed, I’m changing this back to Confirmed.

I have a patched build of gnome-shell in my PPA if you need it now:
https://launchpad.net/~andersk/+archive/ubuntu/ppa/+packages
https://launchpadlibrarian.net/339202115/gnome-shell_3.26.0-0ubuntu2_3.26.0-0ubuntu2andersk1.diff.gz

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Confirmed
tags: added: patch patch-accepted-upstream
removed: wayland-session
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
Loren Pearson (originalflavor) wrote :

I am still having this issue when using 3.26.2-0ubuntu0.1

Daniel van Vugt (vanvugt) wrote :

Fix Released, apparently. Zero reports of this crash after 17.10.

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.