gnome-shell crashed with SIGSEGV in on_crtc_flipped() from g_closure_invoke() from invoke_flip_closure() from page_flip_handler() from drmHandleEvent()

Bug #1714330 reported by Nicolás Abel Carbone on 2017-08-31
300
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
gnome-shell (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
High
Unassigned

Bug Description

https://errors.ubuntu.com/problem/196617236bfd49c847a208a8eda38e2bd701ca99

---

Gnome shell crashes when trying to log in to the wayland ubuntu session. It works fine on Xorg.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.25.91-0ubuntu1
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME-Greeter:GNOME
Date: Thu Aug 31 11:39:23 2017
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2017-07-27 (35 days ago)
InstallationMedia: Ubuntu-GNOME 17.10 "Artful Aardvark" - Alpha amd64 (20170723)
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7fdee0bf9296: mov 0x1a0(%rax),%rax
 PC (0x7fdee0bf9296) ok
 source "0x1a0(%rax)" (0x000001a0) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
 g_closure_invoke () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
 drmHandleEvent () at /usr/lib/x86_64-linux-gnu/libdrm.so.2
 meta_monitor_manager_kms_wait_for_flip () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
Title: gnome-shell crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

StacktraceTop:
 on_crtc_flipped (closure=<optimized out>, view=0x2206144620) at backends/native/meta-renderer-native.c:456
 g_closure_invoke (closure=0x2208066830, return_value=0x0, n_param_values=1, param_values=0x7ffcc7338790, invocation_hint=0x0) at ../../../../gobject/gclosure.c:804
 invoke_flip_closure (flip_closure=0x2208066830) at backends/native/meta-monitor-manager-kms.c:1665
 page_flip_handler (fd=<optimized out>, frame=<optimized out>, sec=<optimized out>, usec=<optimized out>, data=0x2208066830) at backends/native/meta-monitor-manager-kms.c:1761
 drmHandleEvent (fd=8, evctx=evctx@entry=0x7ffcc7338c20) at ../xf86drmMode.c:930

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Looks like a regression in Gnome Shell 3.25

information type: Private → Public
summary: - gnome-shell crashed with SIGSEGV
+ gnome-shell crashed with SIGSEGV in on_crtc_flipped() from
+ g_closure_invoke() from invoke_flip_closure() from page_flip_handler()
+ from drmHandleEvent()
Daniel van Vugt (vanvugt) wrote :
Changed in mutter (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.25.91+20170902~ce515c5-1ubuntu1

---------------
mutter (3.25.91+20170902~ce515c5-1ubuntu1) artful; urgency=medium

  * Sync with Debian.
  * Ignore test failures on s390x

mutter (3.25.91+20170902~ce515c5-1) experimental; urgency=medium

  * New upstream git snapshot (LP: #1714330)
  * Drop git_fix-wayland-color-inversion.patch: Applied
  * debian/control.in:
    - Bump minimum libgudev-dev to >= 232
    - Drop Build-Depends on libgl1-mesa-dri
  * debian/rules:
    - Ignore test failures on Debian. See bug 874077.

mutter (3.25.91-2) experimental; urgency=medium

  * Build-Depend on libgl1-mesa-dri for build tests since
    Debian's mesa packages currently only recommends it

mutter (3.25.91-1) experimental; urgency=medium

  * New upstream release
  * Add skip-failing-tests-325.patch:
    - Skip one more test that started failing with 3.25
  * Add git_fix-wayland-color-inversion.patch:
    - Cherry-pick patch to fix wrong colors in clutter apps on Wayland
      (LP: #1712986)
  * Bump Standards-Version to 4.1.0

mutter (3.25.90-1) experimental; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release (LP: #1662805)
  * libmutter0 has been renamed upstream to libmutter-0-0
  * Rename gir1.2-mutter-3.0 to gir1.2-mutter-0
  * Rename libmutter-dev to libmutter-0-dev
  * debian/control.in:
    - Drop obsolete Conflicts/Replaces now that the library
      uses different file names
    - Loosen dependency on -common package
    - Don't recommend gnome-session | x-session-manager (LP: #1703685)
    - Build-depend on xauth and xfvb for build tests
    - Add Conflicts: libmutter-0-dev to libmutter-1-dev since
      both ship the same development header file names
  * debian/rules:
    - Build with --enable-egl-device (LP: #1666664)
      This enables experimental support for using NVIDIA proprietary
      drivers with GNOME on Wayland
    - Run build tests but don't make them fatal yet
  * Add skip-failing-tests.patch:
    - Don't run a few tests that have been reported as failing

  [ Simon McVittie ]
  * Add patch metadata
  * Correctly label debian/patches/git_revert_call_threaded_swap.patch
    as a revert, not as the change that is being reverted

  [ Andreas Henriksson ]
  * New upstream beta release, 3.25.90.
  * Bump versions of build-dependencies according to configure.ac changes.
  * Rename packages according to libmutter bumping soname, 0->1.

  [ Jeremy Bicha ]
  * Drop git_revert_call_threaded_swap.patch, no longer needed

 -- Jeremy Bicha <email address hidden> Sat, 02 Sep 2017 17:21:59 -0400

Changed in mutter (Ubuntu):
status: Confirmed → Fix Released

I am still having this bug even after updating mutter to the aforementioned version. A update to gnome-shell is also needed?

Daniel van Vugt (vanvugt) wrote :

Yeah that changelog sounds confused. It doesn't sound like it's really mentioning a crash fix in:
  * New upstream git snapshot (LP: #1714330)

description: updated
Daniel van Vugt (vanvugt) wrote :

That said, the error tracker is showing this crash has stopped after 3.25.91-0ubuntu2:
  https://errors.ubuntu.com/problem/196617236bfd49c847a208a8eda38e2bd701ca99

So if you're still experiencing problems then please log a new bug.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Julian Andres Klode (juliank) wrote :

AFAICT, the bug really is still happening, it just happens a lot less, see:

https://bugzilla.gnome.org/show_bug.cgi?id=787240

tags: added: bugpattern-needed
Daniel van Vugt (vanvugt) wrote :

Yes, I spoke too soon. The crash is still happening in today's gnome-shell 3.25.91-0ubuntu3:
  https://errors.ubuntu.com/problem/196617236bfd49c847a208a8eda38e2bd701ca99

Curiously no reports of it happening in 3.25.91+20170902~ce515c5* though.

Changed in mutter (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-shell (Ubuntu):
status: Invalid → Confirmed
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :
Changed in mutter (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Changed in mutter (Ubuntu):
importance: Undecided → High
tags: added: rls-aa-incoming
Changed in mutter (Ubuntu):
milestone: none → ubuntu-17.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.0-1

---------------
mutter (3.26.0-1) experimental; urgency=medium

  * Team upload
  * debian/watch: Only watch stable branch again
  * New upstream release, functionally identical to the previous
    snapshot

 -- Simon McVittie <email address hidden> Wed, 13 Sep 2017 09:22:55 +0100

Changed in mutter (Ubuntu):
status: Confirmed → Fix Released
Changed in mutter (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody

I still cannot login to ubuntu session using wayland. I have mutter 3.26.0-1. Is there a missing piece in the bug or should I report a new bug?
Thanks

Sorry, can't help. Just know a few click things.

在 Nicolás Abel Carbone <email address hidden>,2017年9月16日 上午12:21写道:

I still cannot login to ubuntu session using wayland. I have mutter 3.26.0-1. Is there a missing piece in the bug or should I report a new bug?
Thanks

--
You received this bug notification because you are subscribed to a
duplicate bug report (1716537).
https://bugs.launchpad.net/bugs/1714330

Title:
  gnome-shell crashed with SIGSEGV in on_crtc_flipped() from
  g_closure_invoke() from invoke_flip_closure() from page_flip_handler()
  from drmHandleEvent()

Status in Mutter:
  Confirmed
Status in gnome-shell package in Ubuntu:
  Invalid
Status in mutter package in Ubuntu:
  Fix Released

Bug description:
  https://errors.ubuntu.com/problem/196617236bfd49c847a208a8eda38e2bd701ca99

  ---

  Gnome shell crashes when trying to log in to the wayland ubuntu
  session. It works fine on Xorg.

  ProblemType: Crash
  DistroRelease: Ubuntu 17.10
  Package: gnome-shell 3.25.91-0ubuntu1
  ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
  Uname: Linux 4.12.0-11-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20.7-0ubuntu1
  Architecture: amd64
  CrashCounter: 1
  CurrentDesktop: GNOME-Greeter:GNOME
  Date: Thu Aug 31 11:39:23 2017
  DisplayManager: gdm3
  ExecutablePath: /usr/bin/gnome-shell
  GsettingsChanges:

  InstallationDate: Installed on 2017-07-27 (35 days ago)
  InstallationMedia: Ubuntu-GNOME 17.10 "Artful Aardvark" - Alpha amd64 (20170723)
  ProcCmdline: /usr/bin/gnome-shell
  SegvAnalysis:
   Segfault happened at: 0x7fdee0bf9296: mov 0x1a0(%rax),%rax
   PC (0x7fdee0bf9296) ok
   source "0x1a0(%rax)" (0x000001a0) not located in a known VMA region (needed readable region)!
   destination "%rax" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: gnome-shell
  StacktraceTop:
   () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
   g_closure_invoke () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
   () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
   drmHandleEvent () at /usr/lib/x86_64-linux-gnu/libdrm.so.2
   meta_monitor_manager_kms_wait_for_flip () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
  Title: gnome-shell crashed with SIGSEGV
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/mutter/+bug/1714330/+subscriptions

Daniel van Vugt (vanvugt) wrote :

Nicolás, everyone, please open new bugs if you have further issues.

This bug is fixed and closed.

Knarf (frankschindler) wrote :

Am 15.09.2017 um 18:08 schrieb Nicolás Abel Carbone:
> Is there a missing piece in the bug

It's a missing piece.

Changed in mutter:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.