gnome-shell errors out when gsettings-ubuntu-schemas is uninstalled

Bug #1712798 reported by Thierry B. on 2017-08-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Unassigned
Artful
High
Unassigned

Bug Description

[Impact]

People installing ubuntu-desktop without recommends have a segfault when selecting the ubuntu session (not the GNOME vanilla one) on start

[Test Case]
* update from the version in proposed
* ensure you don't have gsettings-ubuntu-schemas installed
* boot into the ubuntu session
-> you should have the Shell drawn, you won't have the option to set the sound above 100% though.

[Regression Potential]

The new code (listener callback) is now all protected by the same schema installed condition as when we first listened to it.

--------

Step to reproduce :

- Install from http://archive.ubuntu.com/ubuntu/dists/artful/main/installer-amd64/current/images/netboot/mini.iso 2017-08-16 07:48
- Select Command-line install
- Choose default option (wipe disk)
- sudo apt update
- sudo apt install ubuntu-desktop --no-install-recommends
- reboot
- upon login, the screen return immediately to the login screen

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gdm3 3.25.90.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
ApportVersion: 2.20.6-0ubuntu7
Architecture: amd64
Date: Thu Aug 24 13:08:38 2017
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gdm3
UpgradeStatus: No upgrade log present (probably fresh install)

Thierry B. (thierrybo2) wrote :
Thierry B. (thierrybo2) on 2017-09-23
description: updated
Thierry B. (thierrybo2) wrote :

After some trials and errors, I found the culprit. The is only ONE package missing to open the session normally :

gsettings-ubuntu-schemas

So the conclusion is : if it is needed to properly open an X session then it SHOULD be a true dependency from another package, not just a recommended package.

Currently in artful gsettings-ubuntu-schemas is a dependency of the following packages:

$ apt-cache rdepends gsettings-ubuntu-schemas
gsettings-ubuntu-schemas
Reverse Depends:
  unity
  unity-settings-daemon
  unity-control-center
  indicator-sound
  indicator-datetime
  gsettings-ubuntu-touch-schemas
  ubuntu-desktop

In this list no package is installed except ubuntu-desktop, and it is the only package in this list that set gsettings-ubuntu-schemas as a recommended packages.

So TMHO, gsettings-ubuntu-schemas SHOULD BE

Thierry B. (thierrybo2) wrote :

(contunued from the above message)

... a true ubuntu-desktop dependancy, not a recommended one.

I did not tested, but it could be the same for some of the other *-desktop flavors.

Sebastien Bacher (seb128) wrote :

The issue is with one of the gnome-shell ubuntu changes

+ let schema = source.lookup('com.ubuntu.sound', true);
+ if (schema) {
+ this._volumesettings = new Gio.Settings({ settings_schema: schema });
+ }
+
+ this._volumesettings.connect

or this._volumesettings is undefined if the schemas is not installed and the code errors out

summary: - login return to login screen if APT::Install-Recommends=false
+ gnome-shell errors out when gsettings-ubuntu-schemas is uninstalled
affects: gdm3 (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2017-10-26
description: updated
Jeremy Bicha (jbicha) on 2017-11-08
Changed in gnome-shell (Ubuntu):
status: New → Fix Committed
Changed in gnome-shell (Ubuntu Artful):
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.26.2-0ubuntu1

---------------
gnome-shell (3.26.2-0ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release (LP: #1731053)
  * debian/control.in:
    - Drop redundant Suggests on gir1.2-gdm-1.0
  * Drop patches applied in new release:
    - fix_reset_initial_focus.patch
    - git_layout-unset-when-headless.patch

  [ Didier Roche ]
  * Modify debian/patches/70_allow_sound_above_100.patch:
    - Fix a crasher when people log into the ubuntu session without installing
      gsettings-ubuntu-schemas (LP: #1712798)

 -- Jeremy Bicha <email address hidden> Wed, 08 Nov 2017 16:19:02 -0500

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released

Hello Thierry, or anyone else affected,

Accepted gnome-shell into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.26.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Artful:
I have reproduced the problem with gnome-shell 3.26.1-0ubuntu5 in artful-updates and have verified that the version of gnome-shell 3.26.2-0ubuntu0.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Thierry B. (thierrybo2) wrote :

Hi,

I can confirm that gnome-shell 3.26.2-0ubuntu0.1 solved the issue.

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.26.2-0ubuntu0.1

---------------
gnome-shell (3.26.2-0ubuntu0.1) artful; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release (LP: #1731053)
  * Drop patches applied in new release:
    - fix_reset_initial_focus.patch
    - git_layout-unset-when-headless.patch

  [ Didier Roche ]
  * Modify debian/patches/70_allow_sound_above_100.patch:
    - Fix a crasher when people log into the ubuntu session without installing
      gsettings-ubuntu-schemas (LP: #1712798)

 -- Jeremy Bicha <email address hidden> Wed, 08 Nov 2017 16:19:02 -0500

Changed in gnome-shell (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers