[enhancement] Replace the "Activities" label with the Ubuntu icon/logo/glyph

Bug #1707831 reported by Daniel van Vugt on 2017-08-01
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Wishlist
Unassigned
ubuntu-themes (Ubuntu)
Wishlist
Unassigned

Bug Description

I suggest replacing the "Activities" label with the Ubuntu icon/logo.

"Activities" sounds awkward and misleading. It would be more suitably vague, and more consistent with the existing Unity7 experience if the Gnome Shell "Activities" label was replaced by just the Ubuntu logo.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.24.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
Date: Tue Aug 1 11:28:08 2017
DisplayManager: gdm3
InstallationDate: Installed on 2017-05-03 (89 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170502)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

My initial thinking is that the Ubuntu logo alone in the top left corner might not be as obvious that it is a button that users should press?

A lot of official and unofficial documentation uses the term Activities Overview to describe what you get when you click that button. Removing the word Activities makes that documentation less understandable and useful.

https://help.gnome.org/users/gnome-help/stable/

By the way, GNOME by default severely limited the amount of branding opportunities they provided with GNOME 3. I think they reluctantly added a logo option to GDM and that's about it. Fedora has a patch (used in Ubuntu 17.10 too) to add a bit of branding to gnome-control-center's Details page.

If we end up using a dock by default (like Unity), then I think a logo button would be fine. Otherwise, I think adding the Ubuntu logo next to the Activities button is fine too.

Jesse (jessedubord) wrote :
Download full text (3.4 KiB)

I respect Jeremy's (and other Ubuntu devs') positions that the GNOME documentation refers to the "Activities" text button for the Overview, and I think that can be helpful to keep it that way IF the users are going to go to the GNOME documentation, and not search on Ubuntu's forums, social media, community website, Askubuntu.com, etc. I'd probably vote that they're going to go for the latter, searching anything with the word "Ubuntu" Online, first, since Ubuntu is the distro they're using. New users might not even realize that the desktop is developed - primarily - by a different organization, entirely. If that's the case, why would they search for anything other than "Ubuntu help".

Back in June '17 I ran a poll on the Ubuntu G+ community, asking if users preferred the Ubuntu logo in the top-left or the "Activities" text. 169 members voted, and 87% were in favor of using the Ubuntu logo, with only 13% in favor of keeping the "Activities" text (here's the poll so you can see the comments, too: https://plus.google.com/+JesseDuBordFilms/posts/LEjy6zxmNw3).

I'd personally be in favor of replacing the "Activities" text for the Ubuntu logo in the Ubuntu-modified GNOME shell.

Reasons being:
(1) Brand recognition. Will better allow users and surveyors to identify Ubuntu on a PC they're passing by in the airport, coffee shop, etc.
(2) WAY less ambiguous (I have a hard time trying to understand why they used "Activities" for the English word -- can't imagine how it translates in other languages). Plasma tried using "Activities" as well, which I think is equally ambiguous. At least if users see that it's a symbol, they could click on it, see it's behavior, and designate it whatever they want. I feel that makes it way easier for the user to adopt the desktop as their own if they can even define it better on their terms, you know?

I do think Jeremy is right, though, that some users might not instinctively feel it's a button. The Antergos guys did a good job of putting the background in Blue for the "Activities" text on their theme of the GNOME shell. Maybe doing something like having the background of the Activities button the Ubuntu orange with the three white people aligned in the center of the button? I personally think that would look really cool, IMHO.

(3) With the Ubuntu-modifications to the GNOME shell, anyways, would it really be a deal-breaker with the GNOME documentation for it to fit to be modified a little more to fit Ubuntu's needs? I think it's more than fair for a brand to be recognized, and - not saying this in any way as criticism - but I imagine even some of the Ubuntu changes might differ than the GNOME documentation for the vanilla shell? Would it then be such a big deal to have something a little different? Again, no criticism intended at all, just bringing it to the table.

(4) With Ubuntu already offering a vanilla shell experience with the simple install of a package (you guys rock for that, by the way), would it really be such a bad thing for Ubuntu to make "their version" of the shell their own? You're offering both, after all. Maybe even a disclaimer somewhere might be all you need that says, "The default desktop in this ve...

Read more...

Will Cooke (willcooke) on 2017-11-02
Changed in gnome-shell (Ubuntu):
status: Confirmed → Opinion
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid
Iain Lane (laney) wrote :

We just talked about this at a Desktop sprint.

Summary - we don't want to diverge from upstream on this feature. For the reasons Jeremy outlined - mainly that it's an important feature of Shell's branding. Since the bug was filed we've themed Shell and added extensions to the default Ubuntu session, so there is (IMO) sufficient branding to satisfy these concerns.

Changed in gnome-shell (Ubuntu):
status: Opinion → Won't Fix
Changed in ubuntu-themes (Ubuntu):
status: Invalid → Won't Fix
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers