Cannot resize gnome-terminal window in gnome wayland session with mouse

Bug #1704360 reported by LGB [Gábor Lénárt] on 2017-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Running gnome-shell + wayland on ubuntu 17.04 here. If I have a "legacy" (X11) application, like firefox or xterm (running with Xwayland, I guess) I can resize its window normally, ie mouse shape changes into resize-signaling shape near the window borders and I can do the job. However pure-wayland clients, like gnome-terminal it simply does not work, which is very annoying no need to say. I can do the resize with eg ALT+right click and select "resize" but it's kinda more work to do a very simple task (and also it seems there is only horizontal OR vertical resize, not the both what I used to if I move the mouse near to the corner of the window).

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: gnome-shell 3.24.2-0ubuntu0.1
ProcVersionSignature: Ubuntu 4.10.0-28.32-generic 4.10.17
Uname: Linux 4.10.0-28-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.4
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Jul 14 11:43:52 2017
DisplayManager: gdm3
InstallationDate: Installed on 2015-07-10 (734 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release i386 (20150422)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to zesty on 2017-06-20 (23 days ago)

LGB [Gábor Lénárt] (lgb) wrote :
Daniel van Vugt (vanvugt) wrote :

Let's make this bug about gnome-terminal for now. Although I can't seem to reproduce the problem in 17.10, which is good news.

The bad news is that "pure" wayland clients have no server-provided window decorations by design (try 'es2gears_wayland' or 'glmark2-es2-wayland'). I don't know much about the background of this decision but personally hope it will change in future. This might also explain why native Wayland clients don't have normal resize controls (confirmed also in the two aforementioned programs).

summary: - Cannot resize window in gnome wayland session with mouse
+ Cannot resize gnome-terminal window in gnome wayland session with mouse
Jeremy Bicha (jbicha) on 2017-07-17
tags: added: wayland
Jeremy Bicha (jbicha) wrote :

This has been fixed in Ubuntu 17.10 Alpha by updating the Ambiance and Radiance themes (LP: #1685272).

As a workaround until 17.10 is released, you could switch to a different theme like Adwaita or Numix.

Changed in gnome-shell (Ubuntu):
status: New → Fix Released
LGB [Gábor Lénárt] (lgb) wrote :

Nice to hear, that is fixed in 17.10 already. Well, I've just read many discussion on this topic. For example MPV issue: https://github.com/mpv-player/mpv/issues/139 windows has no border. It seems for me, projects like mpv waiting for some server side window decoration to be done, instead of implementing in client side for every possible application (and for being realistic, I feel it's a better option anyway, or well "more realistic"), thus the issue is "wontfix". Surely, gnome-terminal may be different being a gtk3 app, may be handled at gtk3 level for this issue? As far as I know at least, wayland makes it possible to provide 'server side decorations' more like the classic X11 window manager scenario. And the last comment on that issue is funny: "In two years, every compositor will be able to draw server-side decorations." (so "wontfix" ...). Ok, I was kinda off-topic now, sorry about that. Now I am more involved with gnome-terminal at least ... Thanks for the info, that 17.10 seems to solve this issue at least!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.