gnome-shell crashed with signal 5 in _XIOError()

Bug #1702364 reported by Chris on 2017-07-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

Nothing noticeable from a user perspective.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.24.2-0ubuntu7
ProcVersionSignature: Ubuntu 4.10.0-26.30-generic 4.10.17
Uname: Linux 4.10.0-26-generic x86_64
ApportVersion: 2.20.5-0ubuntu5
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME-Greeter:GNOME
Date: Mon Jul 3 14:47:56 2017
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2016-06-03 (396 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/false
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libmutter-0.so.0
 _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XGetWindowProperty () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: gnome-shell crashed with signal 5 in _XIOError()
UpgradeStatus: Upgraded to artful on 2017-06-17 (17 days ago)
UserGroups:

Chris (playdoh72) wrote :

StacktraceTop:
 x_io_error (display=<optimized out>) at wayland/meta-xwayland.c:411
 _XIOError (dpy=dpy@entry=0x5565c6477000) at ../../src/XlibInt.c:1469
 _XReply (dpy=dpy@entry=0x5565c6477000, rep=rep@entry=0x7ffe482faf50, extra=extra@entry=0, discard=discard@entry=0) at ../../src/xcb_io.c:704
 XGetWindowProperty (dpy=0x5565c6477000, w=w@entry=10485762, property=property@entry=425, offset=offset@entry=0, length=length@entry=9223372036854775807, delete=delete@entry=0, req_type=425, actual_type=0x7ffe482fb070, actual_format=0x7ffe482fb064, nitems=0x7ffe482fb078, bytesafter=0x7ffe482fb080, prop=0x7ffe482fb088) at ../../src/GetProp.c:69
 read_settings (x11_screen=0x5565c648c010, do_notify=do_notify@entry=1) at ././gdk/x11/xsettings-client.c:426

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1505409, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

information type: Private → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers