Gnome Shell elements (power menu, launcher etc) are the wrong colour when using Ambiance (wrong grey, and blue highlights)

Bug #1690966 reported by Daniel van Vugt on 2017-05-16
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Didier Roche

Bug Description

In artful, Gnome Shell elements (power menu, launcher etc) are the wrong colour when using Ambiance (wrong grey, and blue highlights)

tags: added: visual-quality
tags: added: artful
summary: - Gnome Shell popups (power menu, launcher etc) are the wrong colour (a
- blueish grey, not Ambiance grey)
+ Gnome Shell elements (power menu, launcher etc) are the wrong colour
+ when using Ambiance (wrong grey, and blue highlights)
description: updated
Jeremy Bicha (jbicha) wrote :

Some other themes ship a theme in /usr/share/themes/THEMENAME/gnome-shell/ GNOME does not really recommend that distros enable the user-theme extension by default so we should talk with GNOME to figure out the recommended way to set a distro's default gnome-shell theme.

Jeremy Bicha (jbicha) on 2017-05-16
tags: added: gnome-17.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → High
importance: High → Medium
Daniel van Vugt (vanvugt) wrote :

This bug could/should be the last bit of card: https://trello.com/c/dwFl5Rc9

If we don't have time to solve it then perhaps the community would be keen? (since so many people like theming anyway)

I would do that, but I was waiting for some word about what's the GNOME preferred way of theming the shell nowadays.

As per Jeremy comment.

Jeremy Bicha (jbicha) wrote :

Marco, if you want to work on GNOME Shell theming, I'd suggest that you talk with Florian about how he suggests Ubuntu handle this. Both Solus and Pop!_OS simply enable the user-themes extension by default so maybe that's what Ubuntu will need to do too, even if GNOME is hesitant to enable it by default for everyone.

We already did make one minor theming change (Ubuntu font instead of Cantarell) by patching gnome-shell's CSS directly but that doesn't feel like a good way of handling this.

Didier Roche (didrocks) wrote :

We have a better mode way of doing it, which is what upstream is using for GNOME classic. We are going to handle it during the London community sprint

Changed in gnome-shell (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Didier Roche (didrocks)
Changed in ubuntu-themes (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Also affects the dock menus now. They're using Adwaita grey instead of Ambiance grey. I think the dock itself is too, just more translucent.

Didier Roche (didrocks) wrote :

The dock is using the system theme (apart from the translucent), but menus are. Removing thus this one.

no longer affects: gnome-shell-extension-ubuntu-dock (Ubuntu)
no longer affects: ubuntu-themes (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.25.91-0ubuntu3

---------------
gnome-shell (3.25.91-0ubuntu3) artful; urgency=medium

  * Ship new ubuntu css theme enabled in the ubuntu session.
    We don't generate is from a regexp list or patch as it has complex
    data structure (removal of some parts of stenzas, same source color
    mapping to different destination colors depending as corresponding
    to different elements).
    Right now, we prefer to do a 3-way merge of the theme and look working
    upstream for better theming support.
    Some summary of the changes are:
    - use ubuntu colors for panel, and most graphical elements (dialog box,
      sliders, menu items, buttons highlights).
    - remove rounded corners as they don't play well with nautilus showing up
      desktop and non black panel theme.
    - change blue grey scheme by orange grey (LP: #1690966)
    - change gdm assets and background. Theme it aubergine instead of
      a wallpaper as it matches the boot sequence, and can't be easily changed
      by the user.
    - ensure lock screen matches gdm and shell theming.
    Make the theme maintainable still overriding on purpose some properties
    instead of changing them in context.
  * Theme new assets on build (close and toggle buttons)
  * Add upstream high contrast theme to ubuntu mode. This will default to
    adwaita with upstream colors for accessibility.
  * debian/patches/50_add_ubuntu_desktop_detect.patch:
    - add caching for desktop detection to avoid querying the current desktop
      env variable as iterate through the list each time. For the time of the
      Shell process, we can expect this env variable to stay stable.
  * debian/patches/ubuntu_background_login.patch:
    - Change default background color as we modified the default GDM color
      for our ubuntu session. Change it as well here, still applying the
      background noise loading.
      This screen is appearing for a slip second when the Shell is loading.
  * debian/rules:
    - Use ninja to generate translations. Thanks Jeremy.

 -- Didier Roche <email address hidden> Mon, 04 Sep 2017 09:24:21 +0200

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Olivier Febwin (febcrash) wrote :

I propose to themed PS1 on Gnome Terminal (see attachment)

Olivier Febwin (febcrash) wrote :

PS1='${debian_chroot:+($debian_chroot)}\[\033[38;5;208;48m\]\u@\h\[\033[38;5;7;48m\]:\[\033[38;5;129;48m\]\w\[\033[38;5;202;48m\]\$\[\033[00m\] '

Daniel van Vugt (vanvugt) wrote :

That would appear to be consistent, but consistency might be a bad thing here. I feel we're going too far with the strong purple and brighter orange than previous releases. Maybe we should tone it back a bit instead.

I feel Ubuntu orange on Ambiance grey is nice and modern. I'd like to see more of that than the purple.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers