Update gnome-shell to 3.24.2

Bug #1690182 reported by Jeremy Bicha on 2017-05-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

Impact
------
3.24.2 is a new bugfix release in the stable 3.24 series.

https://git.gnome.org/browse/gnome-shell/tree/NEWS?h=gnome-3-24
https://git.gnome.org/browse/gnome-shell/log?h=gnome-3-24

Test Case
---------
In Ubuntu GNOME, install the update then reboot.

Try both the GNOME and GNOME on Wayland sessions.

Regression Potential
--------------------
The biggest risk is that something in the update GNOME Shell to no longer work. If GNOME Shell is broken, it could break gdm which is very bad for Ubuntu GNOME users.

Other Info
----------
The gnome-shell 3.24.1 update got stuck in zesty's phased-updates. I have forwarded several of those error reports to GNOME but they probably are still not fixed yet. At least one Weather issue is fixed, but it looks like some things will need to be fixed in libgweather.

(GNOME Shell 3.24 offers weather info in the clock panel if the gnome-weather app is installed, which it is in a default Ubuntu GNOME 17.04.)

Phased Updates is supported only by update-manager so people who install updates a different way will have gnome-shell 3.24.1

Jeremy Bicha (jbicha) on 2017-05-11
Changed in gnome-shell (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.24.2-0ubuntu1

---------------
gnome-shell (3.24.2-0ubuntu1) artful; urgency=medium

  * New upstream release (LP: #1690182)
  * debian/control.in:
    - Restore iio-sensor-proxy to Recommends since it was already in main
    - Recommend gnome-user-guide again too

 -- Jeremy Bicha <email address hidden> Fri, 28 Apr 2017 13:29:39 -0400

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-05-13
Changed in gnome-shell (Ubuntu Zesty):
status: Triaged → In Progress

Hello Jeremy, or anyone else affected,

Accepted gnome-shell into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.24.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I am using Ubuntu GNOME 17.04 as my primary OS. I installed gnome-shell 3.24.2-0ubuntu0.1 and verified that gnome-shell worked fine in both the GNOME and GNOME on Wayland sessions after restarting.

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-zesty
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.24.2-0ubuntu0.1

---------------
gnome-shell (3.24.2-0ubuntu0.1) zesty; urgency=medium

  * New upstream release (LP: #1690182)
  * Extend ubuntu-lightdm-user-switching.patch to allow
    locking screen using LightDM (LP: #1684205)
  * Allow lightdm to be an alternate recommends for gdm3 to avoid debconf
    question if a display manager is already installed (LP: #1690938)
  * Depend on caribou, needed for the Screen Keyboard (LP: #1589240)

 -- Jeremy Bicha <email address hidden> Mon, 15 May 2017 18:36:22 -0400

Changed in gnome-shell (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers