gnome-shell crashed with SIGSEGV in foreach_city() from foreach_city() from foreach_city() from foreach_city() from foreach_city()

Bug #1688208 reported by errors.ubuntu.com bug bridge on 2017-05-04
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libgweather
Confirmed
High
gnome-shell (Ubuntu)
Medium
Unassigned
libgweather (Ubuntu)
High
Unassigned
Zesty
High
Unassigned

Bug Description

Impact
======
Memory corruption in libgweather caused gnome-shell to crash. This is particularly bad for GNOME on Wayland as a gnome-shell crash will causes the user to lose their sessions.

(GNOME Shell 3.24 introduced a new weather feature in the clock menu.)

This particular error has been reported over 1000 times to errors.ubuntu.com from Ubuntu GNOME 17.04 and was also a Fedora 26 blocker bug.

Test Case
=========
The number of crashes reported on errors.ubuntu.com for gnome-shell should be significantly lower once this new version of libgweather rolls out.

Because e.u.com links this issue with gnome-shell, this is difficult to verify except that if you run gnome-shell, it shouldn't crash so often especially when first logging in.

Regression Potential
====================
The main new commit here had already been cherry-picked by Fedora and in Ubuntu 17.10 Alpha. Considering the previous

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.24.1-0ubuntu3, the problem page at https://errors.ubuntu.com/problem/39b6625ed47999dab38b064b2d91bde1e11dec62 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

Jeremy Bicha (jbicha) on 2017-05-10
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jeremy Bicha (jbicha) on 2017-05-10
affects: gnome-shell → libgweather
Changed in libgweather (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in libgweather:
importance: Unknown → High
status: Unknown → Confirmed
summary: - /usr/bin/gnome-
- shell:11:foreach_city:foreach_city:foreach_city:foreach_city:foreach_city
+ gnome-shell crashed with SIGSEGV in foreach_city() from foreach_city()
+ from foreach_city() from foreach_city() from foreach_city()
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgweather - 3.24.0-0ubuntu3

---------------
libgweather (3.24.0-0ubuntu3) artful; urgency=medium

  * debian/patches/git_guard-against-segfault.patch
    - Backport git patch to fix (LP: #1616651) and hopefully (LP: #1688208)

 -- Tim Lunn <email address hidden> Tue, 23 May 2017 17:18:03 +1000

Changed in libgweather (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu):
status: Triaged → Invalid
Jeremy Bicha (jbicha) on 2017-05-25
no longer affects: gnome-shell (Ubuntu Zesty)
Changed in libgweather (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → Medium
Jeremy Bicha (jbicha) on 2017-05-31
Changed in libgweather (Ubuntu Zesty):
importance: Medium → High
Changed in libgweather (Ubuntu):
importance: Medium → High
Jeremy Bicha (jbicha) on 2017-06-03
Changed in libgweather (Ubuntu Zesty):
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2017-06-06
description: updated

Hello errors.ubuntu.com, or anyone else affected,

Accepted libgweather into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libgweather/3.24.1-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libgweather (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Jeremy Bicha (jbicha) wrote :

This very common crash has not been reported to errors.ubuntu.com in several weeks on artful. I verified that I could not reproduce the crash at LP: #1695567 any more after updating libgweather to 3.24.1-0ubuntu0.1 on Ubuntu GNOME 17.04.

tags: added: verification-done-zesty
removed: verification-needed
Brian Murray (brian-murray) wrote :

I also utilized a database query for the bucket associated with this crash to check the dependencies for the libgweather version of crashes reported in June of 2017. This is the result:

1030 examined.
{u'3.24.0-0ubuntu2': 1029}

So the new version does seem to fix the linked crash.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgweather - 3.24.1-0ubuntu0.1

---------------
libgweather (3.24.1-0ubuntu0.1) zesty; urgency=medium

  * New upstream bugfix release
    - Fix memory corruption that crashes gnome-shell
      (LP: #1695567) (LP: #1688208) Thanks Tim Lunn for triaging!
  * Drop git_guard-against-segfault.patch, applied in new release

 -- Jeremy Bicha <email address hidden> Mon, 05 Jun 2017 23:06:59 -0400

Changed in libgweather (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libgweather has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.