"libinput bug: timer offset negative" keeps coming up in syslog

Bug #1588009 reported by Wise Melon on 2016-06-01
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
libinput
Invalid
Medium
gnome-shell (Ubuntu)
Low
Unassigned
libinput (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Low
Unassigned

Bug Description

I have just recently looked in my syslog and discovered that the following message shows up a lot daily so I thought I should report it:

/usr/lib/gdm3/gdm-x-session[1707]: (EE) libinput bug: timer offset negative

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libinput10 1.2.3-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jun 1 18:39:08 2016
InstallationDate: Installed on 2016-05-15 (17 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: libinput
UpgradeStatus: Upgraded to xenial on 2016-05-28 (4 days ago)

I have just recently looked in my syslog and discovered that the following message shows up a lot daily so I thought I should report it:

/usr/lib/gdm3/gdm-x-session[1707]: (EE) libinput bug: timer offset negative

I am running Ubuntu GNOME 16.04 with GNOME 3.20, more information (logs and other system information etc) can be found in my LaunchPad bug report that I made through apport: https://bugs.launchpad.net/ubuntu-gnome/+bug/1588009

is this reproducible? the most common cause of this is a slow compositor/X server busy with rendering. libinput does timer setups based on event timestamps from the kernel and relies on the caller to keep calling libinput_dispatch() often enough, if that isn't the case then a 150ms timer may be set for an event from 500ms ago - resulting in an offset of -350ms from the current time.

Unless you can reproduce this reliably with a specific interaction there is not much we can do here.

any updates here?

Closing after almost a month of no updates

I've been getting a lot of this since switching to using Gnome on Wayland (from X). My system freezes completely, and I need to hard restart. Looking at /var/log/messages, I see a lot of these errors just before the freeze, plus:

org.gnome.Shell.desktop[2961]: libinput error: kernel bug: Touch jump detected and discarded.
debian-x1yoga org.gnome.Shell.desktop[2961]: See https://wayland.freedesktop.org/libinput/doc/1.4.0/touchpad_jumping_cursor.html for details

I'd be happy to help if you let me know how.

The jumping touch is unrelated and can be ignored for this bug.

But comment #1 still stands, this is almost always a slow compositor.

I have the same issue and would like to help with consistent steps to reproduce the bug. Please let me know what information I can share.

Changed in libinput:
importance: Unknown → Medium
status: Unknown → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libinput (Ubuntu):
status: New → Confirmed

I can confirm I have this on Arch Kernel 4.15.14-1-ARCH Gnome 3.28 on Wayland on Thinkpad X1 Carbon 2017 model. Libinput version is 1.10.3

Here some sample logs:

libinput error: client bug: timer event17 debounce short: offset negative (-42ms)
libinput error: client bug: timer event15 trackpoint: offset negative (-1720ms)

tags: added: cosmic
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
knb (knb) wrote :

Here : https://bugs.freedesktop.org/show_bug.cgi?id=96312 some people said this is caused by a "slow compositor" . In my case, it seems to me, these log entries are probably caused by a Xorg process running with 100% cpu blocking the UI for ~ 1 minute. This happens after animations played (e.g. progressbars), window resizing, scrolling, when I have many GUI apps open. I am still investigating.

My system: nvidia driver, 2 old GPUs, 18.04 with gdm3+Xorg

Same problem here. I'm using Ubuntu 18.10 LiveCD and from time to time my Ubuntu just freezes and when it happens my pendrive LED blinks like crazy. It's hard to recover from it, but yesterday I did. The log it at the post below.

Here's my post about it: https://unix.stackexchange.com/questions/483898/my-shell-script-to-periodically-free-some-memory-up-with-ubuntu-18-10-livecd-wit#_=_

Hi,
@Nils Kaiser I have KDE, but I have same problem on Arch Linux (4.19.12-arch1-1-ARCH)

Changed in libinput:
status: Invalid → Confirmed

Please see https://wayland.freedesktop.org/libinput/doc/latest/faqs.html#what-causes-the-timer-offset-negative-warning, this is almost never a libinput bug.

fwiw, libinput has moved to gitlab, any future issues should be filed at https://gitlab.freedesktop.org/libinput/libinput

Changed in libinput:
status: Confirmed → Invalid

Same problem on Arch
Kernel 4.20.6-arch1-1-ARCH
xorg-server 1.20.3-1
KDE Plasma: 5.14.5
Qt: 5.12.1
KDE Frameworks: 5.54.0
64-bit
Intel® Core™ i7-2620M CPU @ 2.70GHz
with integrated graphics on HP EliteBook 2560p

Daniel van Vugt (vanvugt) wrote :

Per the documentation [1], this is a bug in mutter/gnome-shell. Not a bug in libinput.

[1] https://wayland.freedesktop.org/libinput/doc/latest/faqs.html#what-causes-the-timer-offset-negative-warning

Changed in libinput (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
Changed in mutter (Ubuntu):
importance: Undecided → Low
tags: added: performance
jnns (jnns) wrote :

I'm affected by this as well. I can't really interact with my system anymore because input and scrolling is interrupted every few seconds. /var/log/syslog keeps filling up with messages like:

> libinput error: client bug: timer event7 tap: offset negative (-495ms)

htop reports gnome-shell using 100% CPU very often as well. I'm using a Thinkpad X1 Carbon 2018 with
- gnome-shell 3.30.2-0ubuntu1.18.10.1
- libinput-bin 1.12.1-1
- mutter 3.30.2-1~ubuntu18.10.4

tags: removed: cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.