Activities: characters are not displayed in the order that they are typed

Bug #1557089 reported by shinyblue on 2016-03-14
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Medium
gnome-shell (Ubuntu)
High
Unassigned

Bug Description

Click Activities. Run finger from Q to T. You should get qwert but instead I get qwtre

It also affects more normal use, e.g. I can't type term (for terminal), it comes out "temr". It seems to work if you type really slowly.

I also noticed weird keyboard behaviour in gnome software and photos bot on the search fields. Press a single key and it comes out twice. Both apps then because unusable after I'd pressed backspace which seemed to go on forever.

Keyboard works fine in other contexts and I never had these issues in 14.04's version of Gnome.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-shell 3.18.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
Uname: Linux 4.4.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Mar 14 17:50:44 2016
DisplayManager:

InstallationDate: Installed on 2016-03-14 (0 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160225.1)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

shinyblue (shinyblue) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2016-03-14
summary: - Activities: characters are not in typed order
+ Activities: characters are not in displayed in the order that they are
+ typed

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1557089

tags: added: iso-testing
Paul White (paulw2u) on 2016-03-14
summary: - Activities: characters are not in displayed in the order that they are
+ Activities: characters are not displayed in the order that they are
typed
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
shinyblue (shinyblue) wrote :

I have not encountered this bug for a week or two now, so from my POV, it can be closed, assumed fixed by some update since the first beta iso that I installed back then.

Tim Lunn (darkxst) on 2016-05-12
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-shell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.