Sticky / garbled menus in Ubuntu GNOME Vivid w/Intel i945 gpu

Bug #1413062 reported by Erick Brunzell on 2015-01-21
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-shell (Ubuntu)
Critical
Unassigned

Bug Description

Just testing Ubuntu GNOME Vivid 20150120.1 i386 and after passing the mouse over the menu items in the launcher they stay "highlighted". Also when you open the menu from the launcher and click on the "scroll" buttons to the right the new menu items just overlay the old. A picture is worth a thousand words so I'm attaching a screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: gnome-shell 3.14.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.18.0-9.10-generic 3.18.2
Uname: Linux 3.18.0-9-generic i686
ApportVersion: 2.15.1-0ubuntu2
Architecture: i386
CurrentDesktop: GNOME
Date: Tue Jan 20 21:58:06 2015
DisplayManager: gdm
GsettingsChanges: b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2015-01-21 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Alpha i386 (20150120.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Here's a URL to the hardware I'm testing on:

http://paste.ubuntu.com/9795681/

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1413062

tags: added: iso-testing
summary: - Sticky / garbled menus in Ubuntu GNOME Vivid
+ Sticky / garbled menus in Ubuntu GNOME Vivid w/Intel i945 gpu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → Critical
Erick Brunzell (lbsolost) wrote :

BTW I'm not just ignoring Tim Lunn's request to report this upstream but I've been AFK a great deal and I'd like to know a little more before doing so.

Another user on the forums with almost identical hardware (Atom 330 instead of 230 but still i945 graphics) reports having the same issue, but it's OK in Debian testing:

http://ubuntuforums.org/showthread.php?t=2262551&p=13215642#post13215642

On my end I've tried updating X via Xorg-edgers and also tried the 3.19.0-031900rc5-generic mainline kernel to no avail.

Erick Brunzell (lbsolost) wrote :

I get the same results in Utopic if I install GNOME 3.14 via the GNOME3 and GNOME3 Staging PPA's. It also doesn't matter if I use gdm or lightdm with either greeter.

John Przybytek (jprzybytek) wrote :

Getting the sticky menu issue as well

Screenshot:
http://comra.ca/lo300/Screenshot2002-01-01.png

Hardware:
http://paste.ubuntu.com/9960847/

Changed in ubuntu-gnome:
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

This appears to be fixed with the latest gnome-shell and mutter that Tim Lunn uploaded on the 24th.

Erick Brunzell (lbsolost) wrote :

This bug was fixed in the package gnome-shell - 3.14.4-0ubuntu1

---------------
gnome-shell (3.14.4-0ubuntu1) vivid; urgency=medium

  * New upstream bugfix release
  * debian/patches/50-compute-weeknumber-with-gdatetime.patch: Dropped,
    included in new release
 -- Tim Lunn <email address hidden> Tue, 24 Mar 2015 08:41:59 +1100

Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers