Booting the Ubuntu GNOME live DE from the advanced boot menu results in a largely unusable DE

Bug #1284496 reported by Erick Brunzell on 2014-02-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Unassigned

Bug Description

I've not been able to cross-test this against any other flavor ATM, but if you boot Ubuntu GNOME 20140225 i386 and enter the advanced boot menu, and then select Try Ubuntu you get what appears to be a wrong resolution, but the resoltion is correct.

It appears that some notification is trying to appear as indicated by the "half gear" in the lower left corner of the screen, please see attached screenshot (I hope).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: casper 1.337
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CasperVersion: 1.337
CurrentDesktop: GNOME
Date: Tue Feb 25 07:01:45 2014
LiveMediaBuild: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha i386 (20140225)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.casper.conf: 2014-02-25T06:57:01.899566

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

BTW I edited nothing in the boot parameters. I just hit enter, selected the default English language, and then selected Try.

If you reboot and wait until the standard try vs install screen appears everything works fine.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1284496

tags: added: iso-testing
Tim Lunn (darkxst) wrote :

I can confirm that the gnome-shell live session is completely broken, pretty much all widget calculations seem off, when the "half" gear is showing. I have no idea where that is coming from, its surely not GNOME.

strangely it also appears on the "Try Ubuntu" screen, however doesn't seem to break anything there, although there do appear to be some top panel icons missing. No idea if that is related though.

Changed in casper (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Tim Lunn (darkxst) wrote :

^ "pretty much all widget size/position calculations"

Erick Brunzell (lbsolost) wrote :

Tim did you look at the attached /modified.conffile..etc.casper.conf.txt?

It seemed odd that when I filed this bug report apport said I'd modified "casper" but I'd made no mods, just selected the default English language and then selected "Try" from the menu.

Going a bit off-topic, but the cross-testing problems I'd mentioned via PM are due to a faulty DVD drive so I'm headed out to the brick and mortar store to get a replacement ASAP.

But that faulty drive was not in play during this test.

amjjawad  (amjjawad) wrote :

And I thought it was my VM that is acting funny and crazy - http://ubuntuforums.org/showthread.php?t=2207876

@Tim
Are we sure this is not GNOME but something else?
You're right, it doesn't seem it is breaking anything but the live session looks so odd but usable a bit. However, I'm not sure if this is related?

http://ubuntuforums.org/showthread.php?t=2207879

Please advise!

Thank you :)

tags: added: amd64
Tim Lunn (darkxst) wrote :

Looks like this is fallout from the HiDPI changes in gnome-shell 3.10.4.

Scaling Factor in the live session is set to 0

Hopefully the following patch will fix it.

https://git.gnome.org/browse/gnome-shell/commit/?id=29addc499ca0f8dc5bf9cf6d18eaaa01a5c2b985

Tim Lunn (darkxst) wrote :

This should be fixed on 20140226

affects: casper (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
amjjawad  (amjjawad) wrote :

I confirm that both i386 and amd64 are working fine right now and everything is back to normal. Tim is the best :D

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers