Should depend on gnome-session

Bug #1284417 reported by Doug McMahon on 2014-02-25
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]
Installing 'gnome-shell' fails to install 'gnome-session' so no GNOME session is offered at login which could lead a user to install unneeded packages such as the metapackage 'gnome' in search of a solution.

[Test Case]
Install and update Ubuntu Trusty, then install the package 'gnome-shell'. Log out and you'll find that no GNOME session is available for login. Install 'gnome-session', log out again and you'll then find that GNOME is available as a login option.

[Regression Potential]
None, gnome-session provides the session files for a
gnome-shell session, therefore it must be installed to use gnome-shell.
This dep was just missied up until now, since the ubuntu-gnome meta
package pulls it in anyway.

*****************************************************
It appears that gnome-session is no longer on default install. In that case if a user installs gnome-shell they'll not get a log in for it.
(may also need dep on gnome-control-center??

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: gnome-session (not installed)
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 24 21:55:01 2014
InstallationDate: Installed on 2014-02-22 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140222)SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

I guess you wanted to report that bug against gnome-shell? It doesn't make sense for gnome-session to depends on itself right? ;-)

affects: gnome-session (Ubuntu) → gnome-shell (Ubuntu)
Tim Lunn (darkxst) on 2014-02-25
Changed in gnome-shell (Ubuntu):
status: New → Fix Committed
Doug McMahon (mc3man) wrote :

Yeah, sorry about that, was thinking gnome-shell but typing gnome-session...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.10.4-0ubuntu3

---------------
gnome-shell (3.10.4-0ubuntu3) trusty; urgency=medium

  * debian/patches/git_shell_global_fix_scale_factor.patch: git patch
    to fix invalid scale_factor setting breaking the live sessions.
    (LP: #1284496)
 -- Tim Lunn <email address hidden> Wed, 26 Feb 2014 10:01:32 +1100

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

Clearly not fixed, what does debian/patches/git_shell_global_fix_scale_factor.patch: git patch have to do with this??

Changed in gnome-shell (Ubuntu):
status: Fix Released → New
status: New → Confirmed
Tim Lunn (darkxst) wrote :

It was fixed in:
http://launchpadlibrarian.net/167529933/gnome-shell_3.10.4-0ubuntu1_3.10.4-0ubuntu2.diff.gz

However I don't know why launchpad janitor provided the incorrect changelog in this bug

Doug McMahon (mc3man) wrote :

Tim -
gs has a build depend on gnome-session but not an install depend so it's not installed when users install gs in a Ubuntu 14.04 install
(granted those wanting to use gs would be better off using Ubuntu-Gnome but still..

Ex. on new 14.04 release install -
Commit Log for Fri May 2 11:06:41 2014

Installed the following packages:
gdm (3.10.0.1-0ubuntu3)
gir1.2-accountsservice-1.0 (0.6.35-0ubuntu7)
gir1.2-caribou-1.0 (0.4.13-0ubuntu1)
gir1.2-clutter-1.0 (1.16.4-0ubuntu2)
gir1.2-cogl-1.0 (1.16.2-1)
gir1.2-coglpango-1.0 (1.16.2-1)
gir1.2-gck-1 (3.10.1-1)
gir1.2-gcr-3 (3.10.1-1)
gir1.2-gdesktopenums-3.0 (3.10.1-0ubuntu1)
gir1.2-gdm-1.0 (3.10.0.1-0ubuntu3)
gir1.2-gkbd-3.0 (3.6.0-0ubuntu2)
gir1.2-gnomedesktop-3.0 (3.8.4-0ubuntu3)
gir1.2-json-1.0 (0.16.2-1ubuntu1)
gir1.2-mutter-3.0 (3.10.4-0ubuntu2)
gir1.2-nmgtk-1.0 (0.9.8.8-0ubuntu4)
gir1.2-polkit-1.0 (0.105-4ubuntu2)
gir1.2-telepathyglib-0.12 (0.22.1-1ubuntu2)
gir1.2-telepathylogger-0.2 (0.8.0-3)
gir1.2-upowerglib-1.0 (0.9.23-2ubuntu1)
gir1.2-xkl-1.0 (5.4-0ubuntu1)
gjs (1.39.91-0ubuntu1)
gnome-control-center (1:3.6.3-0ubuntu56)
gnome-control-center-data (1:3.6.3-0ubuntu56)
gnome-icon-theme-full (3.10.0-0ubuntu2)
gnome-settings-daemon (3.8.6.1-0ubuntu11)
gnome-shell (3.10.4-0ubuntu5)
gnome-shell-common (3.10.4-0ubuntu5)
gnome-themes-standard (3.10.0-1ubuntu2)
gnome-themes-standard-data (3.10.0-1ubuntu2)
gtk2-engines-pixbuf (2.24.23-0ubuntu1)
libcaribou-common (0.4.13-0ubuntu1)
libcaribou0 (0.4.13-0ubuntu1)
libgdm1 (3.10.0.1-0ubuntu3)
libgjs0e (1.39.91-0ubuntu1)
libgoa-backend-1.0-1 (3.10.3-0ubuntu1)
libmozjs-24-0 (24.2.0-1)
libmutter0c (3.10.4-0ubuntu2)
libxcb-xf86dri0 (1.10-2ubuntu1)
mutter-common (3.10.4-0ubuntu2)
xserver-xephyr (2:1.15.1-0ubuntu2)

Doug McMahon (mc3man) wrote :

removing gnome-session from Build-Depends: & adding to gnome-shell's package Depends: seems to work out better

Tim Lunn (darkxst) wrote :

Doug, uploaded fix to Utopic, can you add the SRU paperwork to the OP and then I will upload it too trusty-proposed also! thanks ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.10.4-0ubuntu8

---------------
gnome-shell (3.10.4-0ubuntu8) utopic; urgency=medium

  * debian/control.in: Depend on gnome-session (rather than build-depend)
    (LP: #1284417)
 -- Tim Lunn <email address hidden> Sat, 03 May 2014 21:09:48 +1000

Changed in gnome-shell (Ubuntu Utopic):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu Trusty):
status: New → Confirmed
Tim Lunn (darkxst) on 2014-05-09
Changed in ubuntu-gnome:
milestone: none → trusty.1
Erick Brunzell (lbsolost) wrote :

Doug, I typed up a proposed change to the bug description so Tim can get this uploaded to trusty-proposed. Would you please have a look and if you approve either paste it into the top of your bug description or give me permission to do so.

Thanks in advance.

Tim Lunn (darkxst) on 2014-06-24
Changed in ubuntu-gnome:
status: New → Triaged
Tim Lunn (darkxst) on 2014-06-25
Changed in gnome-shell (Ubuntu Trusty):
status: Confirmed → In Progress
Tim Lunn (darkxst) on 2014-06-25
description: updated
Changed in ubuntu-gnome:
status: Triaged → Fix Committed

Hello Doug, or anyone else affected,

Accepted gnome-shell into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.10.4-0ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
M.Hanny Sabbagh (hannysabbagh) wrote :

Hello.

I have just tested the fix and it works here on Ubuntu 14.04 after enabling the proposed repository.
gnome-shell version: 3.10.4-0ubuntu5.2.

Thanks.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.10.4-0ubuntu5.2

---------------
gnome-shell (3.10.4-0ubuntu5.2) trusty; urgency=medium

  * debian/control.in: Depend on gnome-session to ensure we have the
    session files for GNOME (LP: #1284417)
 -- Tim Lunn <email address hidden> Thu, 26 Jun 2014 09:28:32 +1000

Changed in gnome-shell (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-gnome:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers