gnome-shell crashed with SIGSEGV in ?? from dconf_gdbus_method_call_done() from g_simple_async_result_complete()

Bug #1283299 reported by KML on 2014-02-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Invalid
Critical
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

Turned on the system and ran a system update (havn't run a system update in 1-2 weeks).

After it downloaded, and started to install, the screen turned black, only with the cursor blinking. Couldn't get screen back by moving mouse or pressing buttons.
Waited till i could see the updates had finished (by looking at my HD activity indicator), and tried going back and forth tty's, still no screen (cursor frozen this time). Restarted gdm from other tty, screen flashed, but froze again. Rebooted machine, and everything started up fine.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gnome-shell 3.10.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Feb 22 00:42:33 2014
DisplayManager: gdm
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2014-02-07 (14 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140206)
ProcCmdline: gnome-shell --mode=gdm
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
SegvAnalysis:
 Segfault happened at: 0x1040500: push %rax
 PC (0x01040500) in non-executable VMA region: 0x00e9a000-0x01ba7000 rw-p [heap]
 source "%rax" ok
 destination "(%rsp)" (0x7f8b8a4caa48) ok
 Stack memory exhausted (SP below stack segment)
SegvReason: executing writable VMA [heap]
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: gnome-shell crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

KML (zemoh) wrote :

StacktraceTop:
 ?? ()
 dconf_gdbus_method_call_done (source=<optimized out>, result=0x7f8b7c0072a0, user_data=0x1b675f0) at dconf-gdbus-thread.c:231
 g_simple_async_result_complete (simple=0x7f8b7c0072a0) at /build/buildd/glib2.0-2.39.90/./gio/gsimpleasyncresult.c:763
 g_dbus_connection_call_done (source=<optimized out>, result=<optimized out>, user_data=0x13d0930) at /build/buildd/glib2.0-2.39.90/./gio/gdbusconnection.c:5498
 g_simple_async_result_complete (simple=0x7f8b7c007230) at /build/buildd/glib2.0-2.39.90/./gio/gsimpleasyncresult.c:763

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
KML (zemoh) on 2014-03-13
description: updated
information type: Private → Public
Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → New
Changed in gnome-shell:
status: New → Invalid
summary: - Video crashed (went to black screen and cursor) in the middle of
- software update.
+ gnome-shell crashed with SIGSEGV in ?? from
+ dconf_gdbus_method_call_done() from g_simple_async_result_complete()
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu GNOME 14.04 (trusty) reached end-of-life on April 28, 2017

https://wiki.ubuntu.com/TrustyTahr/ReleaseNotes/UbuntuGNOME#Support
https://lists.ubuntu.com/archives/ubuntu-gnome/2017-March/004211.html

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Paul White (paulw2u) wrote :

Bug did not expire due to bugwatch
Upstream issue is a duplicate of #724929 which
was closed "RESOLVED FIXED" on 2014-02-22
No reply from reporter so closing as fixed

Changed in gnome-shell (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.