Ubuntu

Gnome Shell non-recoverable crash when opening Nautilus more than once.

Reported by JaSauders on 2013-04-03
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-shell
Fix Released
Critical
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu GNOME 13.04 64 bit
Gnome3 PPA enabled
apt-get update && apt-get upgrade && apt-get dist-upgrade this morning
Gnome Shell 3.8.0.1

If I have no windows open and I open Nautilus, it crashes the user interface. In my experience, Gnome Shell always recovers from this on the first time and re-launches itself without issue. If I open Nautilus a second time with no other windows open, it crashes the user interface again. This time it doesn't restart Gnome Shell and I'm left with a borderless Nautilus window with a black background. The super key and hot cornering to the upper left does nothing.

I duplicated this on two systems.

2010 Macbook Pro, both with Nouveau driver and Nvidia 313 driver.
Toshiba Z835 ultrabook with integrated graphics from Intel i5 CPU.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-shell 3.8.0.1-0ubuntu1~raring1 [origin: LP-PPA-gnome3-team-gnome3]
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
CrashDB: ubuntu
Date: Wed Apr 3 14:21:47 2013
DisplayManager: gdm
GsettingsChanges:
 b'org.gnome.desktop.interface' b'clock-format' b"'12h'"
 b'org.gnome.desktop.interface' b'clock-show-date' b'true'
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'icon-theme' b"'F-Dark-Color'"
InstallationDate: Installed on 2013-04-01 (2 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha amd64 (20130331)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

JaSauders (jasauders) wrote :
JaSauders (jasauders) wrote :

I was advised to run a command in the CTRL ALT F1 menu, then switch back to the GUI and cause the system to crash. Here was the command I was instructed run:

export $(strings /proc/$(pidof gnome-session)/environ | grep DBUS) && DISPLAY=:0.0 gnome-shell --replace >gnome-shell.log 2>&1

And here is the output:

http://paste.ubuntu.com/5677306/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Stinger (e-mindahl) wrote :

I have exactly the same bug as JaSaunders.
I opened a new bug with all information from apport attached.
Have a look at
 https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1164766

Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Incomplete
Stinger (e-mindahl) wrote :

I can replicate this with GNOME Shell 3.8.0.1 from the Gnome3 ppa. Just crashed it three times in a row using the steps below.

1.login to a fresh Gnome session with no other apps open
2.open three instances of nautilus/files ( done with 'new window' every time )
3.Now close all three windows
4.Open nautilus/files again, Gnome-Shell will crash and recover again
5.When GS has recovered, close the nautilus/files window, GS will crash permanently but you are still able to use nautilus without window borders
6.To shut your PC down you can use Ctrl-Alt-F1 to get the command line, login and do 'sudo poweroff'

It's the same type of crash over and over again.

Stinger (e-mindahl) wrote :

Re #5 above

Edit to 5. Should have been:
"5. When GS has recovered, close the nautilus/files window and open it again, GS will crash permanently but you are still able to use nautilus without window borders"

Sorry

Changed in gnome-shell:
status: Incomplete → Confirmed
Changed in gnome-shell:
status: Confirmed → Invalid
Changed in gnome-shell:
status: Invalid → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.8.3-1ubuntu3

---------------
gnome-shell (3.8.3-1ubuntu3) saucy; urgency=low

  * debian/patches/git-dont-crash-for-unstaged-widgets.patch:
    - Git patch to fix GNOME Shell crashing when, for instance,
      Nautilus is ran with not other apps running (LP: #1164086)
  * debian/control.in: drop obsolete gconf dependency
 -- Jeremy Bicha <email address hidden> Sun, 14 Jul 2013 12:31:49 -0400

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-shell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.