~50px pointer barrier in gnome shell at bottom of primary monitor

Bug #1132308 reported by Britt Yazel on 2013-02-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Medium
gnome-shell (Ubuntu)
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

[Impact]
There is a pointer barrier at the bottom right hand side of the primary monitor, that was designed to make it easier to hit the hot corner. However in 3.6 this hot corner no longer exists (tray is activated by dwell on bottom on screen) so having this barrier no
longer makes sense.

On a Multiple Monitor setup, this barrier blocks mouse movement through the bottom 50px on right hand edge of primary monitor.

[Test Case]
- Setup a second monitor to the right.
- Try to move mouse through the affected area, it will block.

[Regression Potential]
Low, This is a backport of an upstream patch that landed very early in the 3.7 cycle. It just removes the barrier.

=== Original Report ===
There is a ~50px pointer barrier at the bottom of the primary screen in gnome shell where the messaging tray is, though it is persistant whether or not the tray is showing. This makes it so a cursor cannot pan from one screen to another with dual monitors in the lower region of the screen.

ProblemType: BugDistroRelease: Ubuntu 13.04
Package: gnome-shell 3.6.3.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 23 17:01:48 2013
DisplayManager: gdm
GsettingsChanges:
 b'org.gnome.desktop.interface' b'clock-format' b"'12h'"
 b'org.gnome.desktop.interface' b'clock-show-date' b'true'
 b'org.gnome.desktop.interface' b'font-name' b"'Ubuntu 10'"
 b'org.gnome.desktop.interface' b'monospace-font-name' b"'Ubuntu Mono 11'"
InstallationDate: Installed on 2012-11-24 (91 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Release amd64(20121023)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: gnome-shell
UpgradeStatus: Upgraded to raring on 2013-02-21 (2 days ago)

Britt Yazel (bwyazel) wrote :
Tim (darkxst) wrote :

This should have been removed, since the hot-corner no longer exists in 3.6. However looks like the upstream patch only landed in 3.7. I will backport this when I get a chance.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3.1-0ubuntu2

---------------
gnome-shell (3.6.3.1-0ubuntu2) raring; urgency=low

  * debian/patches:
    - git_remove_messagetray_barrier.patch:
      Remove barrier at the bottom of the screen (causes problems
      when moving the cursor between multiple screens) (LP: #1132308)
 -- Tim Lunn <email address hidden> Sun, 24 Feb 2013 13:30:51 +1100

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2013-02-26
Changed in gnome-shell (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Low
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
Tim (darkxst) on 2013-02-26
description: updated

Hello Britt, or anyone else affected,

Accepted gnome-shell into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.6.3.1-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

summary: - ~50px pointer barrier in gnome shell at bottom of primary monitor in
- raring
+ ~50px pointer barrier in gnome shell at bottom of primary monitor
Changed in gnome-shell (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3.1-0ubuntu0.1

---------------
gnome-shell (3.6.3.1-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release. (LP: #1128804)
    - Fixes disappearing messagetray (LP: #1067265)
    - recorder: Set frame duration to fix broken video headers
    - Block cancellation of unlock dialog during drags
    - Honor lock-delay GSettings key
  * debian/patches/git_remove_messagetray_barrier.patch:
    - Remove barrier at the bottom of the screen (causes problems
      when moving the cursor between multiple screens) (LP: #1132308)
 -- Tim Lunn <email address hidden> Tue, 26 Feb 2013 23:50:34 +1100

Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.