Ubuntu

Gnome-Shell activities shows black background

Reported by Britt Yazel on 2013-02-23
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-shell
Confirmed
Low
fglrx-installer (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
libcairo (Ubuntu)
Undecided
Unassigned

Bug Description

The Gnome-Shell activities view shows a solid black background while using fglrx in raring. I have found that this solid black background is only when you have "file manager handle the desktop" enabled. If you turn off the file manager handling the desktop, you can then see the background image in the activities view.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-shell 3.6.3.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Fri Feb 22 23:04:29 2013
DisplayManager: gdm
GsettingsChanges:
 b'org.gnome.desktop.interface' b'clock-format' b"'12h'"
 b'org.gnome.desktop.interface' b'clock-show-date' b'true'
 b'org.gnome.desktop.interface' b'font-name' b"'Ubuntu 10'"
 b'org.gnome.desktop.interface' b'monospace-font-name' b"'Ubuntu Mono 11'"
InstallationDate: Installed on 2012-11-24 (91 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Release amd64(20121023)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to raring on 2013-02-21 (1 days ago)

cairo produces a black background (overriding the gnome wallpaper) in the Activities overview in gnome-shell using the proprietary AMD Catalyst fglrx driver.

System information:
Arch Linux, kernel 3.6.4-1
X.Org X Server 1.13.0
cairo 1.12.6-2
gnome-shell 3.6.1
GPU AMD Radeon HD 6450 running catalyst-utils 12.9-0.1

Workarounds:
- Rolling back to cairo 1.12.2-3 fixes the problem using the AMD Catalyst driver.
- Bug can not be reproduced using cairo 1.12.6-2 with the open-source ati driver (1:6.14.6-2).

I experience exactly the same behavior, but with open-source Intel drivers.
I haven't tried to downgrade cairo, though.

I have to add that this occurs only when I tell the file manager to "handle the desktop" using gnome-tweak-tool.

cairo 1.12.8
gnome-shell 3.6.2

Oh if was nautilus:

commit 724c6dfa9521e887682029add879c2fcdd518b14
Author: Chris Wilson <email address hidden>
Date: Fri Nov 2 16:54:46 2012 +0000

    xlib/shm: Need IncludeInferiors when creating the source fallback

    Reported-by: Benjamin Otte <email address hidden>
    Signed-off-by: Chris Wilson <email address hidden>

Britt Yazel (bwyazel) wrote :
Britt Yazel (bwyazel) wrote :

https://bugs.freedesktop.org/show_bug.cgi?id=56657

This is the upstream bug report for this issue. It appears to be a incompatibily issue with the newer versions of Cairo (1.12.2+) and fglrx.

I do not know if newer version of fglrx fix this cairo issue, as there is still the Radeon 12.10 driver set in the repos on both Ubuntu 12.10 and 13.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in libcairo (Ubuntu):
status: New → Confirmed

The problem is still there on my system with cairo 1.12.14-0ubuntu1 on Ubuntu 13.04, and the fix mentioned by Chris is already included.

In which case, your attention should turn towards Catalyst.

To make clear, the above commit is the trigger or fix?

It was a fix for a very similar issue with -intel.

Thanks for the confirmation. So it should be a different problem for Catalyst.

The issue also can be reproduced on Radeon driver (open-source ati driver 1:7.1.0 ) on my environment.
other system information:
gnome-shell 3.6.3.1
cairo 1.12.14
Xserver 1.13.2

Changed in gnome-shell:
importance: Unknown → Low
status: Unknown → Fix Released

Hello, excuse me for the trivial question but I'm a new arrival, how can I use this fix?
(In reply to comment #2)
> Oh if was nautilus:
>
> commit 724c6dfa9521e887682029add879c2fcdd518b14
> Author: Chris Wilson <email address hidden>
> Date: Fri Nov 2 16:54:46 2012 +0000
>
> xlib/shm: Need IncludeInferiors when creating the source fallback
>
> Reported-by: Benjamin Otte <email address hidden>
> Signed-off-by: Chris Wilson <email address hidden>

still no background in overview in Ubuntu 13.04 with GS 3.6

Jarosław Guza (jarekj83-4) wrote :

with ATI drivers

Same problem, open source intel drivers.
So not fixed (or reintroduced).

summary: - Gnome-Shell activities shows black background with fglrx in raring
+ Gnome-Shell activities shows black background

Changed the title accordingly. If in tweak tools you deselect "file manager handle desktop", you than have the background black all the time (not only in overview).

Blaster (holst-niels) wrote :

Latest open source intel drivers: still there.

Problem still present in Ubuntu 13.04 with last catalyst driver.

Changed in gnome-shell:
status: Fix Released → Confirmed
Grzegorz G. (grzesiek1e5) wrote :

Happened to me after using Intel Graphic Drivers Installer 1.0.2, Ubuntu 13.04.

@Romano Giannetti: If in tweak tools you deselect "file manager handle desktop", you then have the background black until you select a different background. After changing background everything should be OK if Nautilus doesn't handle the desktop.

For me bug is sgone on Ubuntu 13.10 with catalyst 13.11.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.