Update mutter/gnome-shell to 3.6.3

Bug #1128804 reported by Tim Lunn on 2013-02-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Quantal
Medium
Jeremy Bicha
mutter (Ubuntu)
Medium
Unassigned
Quantal
Medium
Jeremy Bicha

Bug Description

There has recently been a 3.6.3 release of mutter and gnome-shell which fixes a few very annoying bugs.

[Impact]

Gnome Shell 3.6.3
====
* recorder: Set frame duration to fix broken video headers [Adel; #688487]
* Block cancellation of unlock dialog during drags [Giovanni; #686800]
* Honor lock-delay GSettings key [Giovanni, Matthias; #690766, #691170]
* Fix reentrancy problem causing the tray to disappear [Giovanni; #683986]

Mutter 3.6.3
====
* Fix maximized windows jumping between monitors [Alban; #556696]
* Fix windows turning black when redirected again [Adel; #693042]

[Test Case]

* Make sure that gnome-shell still works.
* This should fall under the GNOME MRE.

[Regression Potential]

Related branches

Tim Lunn (darkxst) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu Quantal):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu Quantal):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-02-19
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
Changed in mutter (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Changed in gnome-shell (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu Quantal):
importance: Undecided → Medium
Changed in mutter (Ubuntu):
importance: Undecided → Medium
Changed in mutter (Ubuntu Quantal):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.6.3-0ubuntu1

---------------
mutter (3.6.3-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1128804)
 -- Tim Lunn <email address hidden> Mon, 18 Feb 2013 17:44:22 +1100

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3-0ubuntu1

---------------
gnome-shell (3.6.3-0ubuntu1) raring; urgency=low

  * New upstream release. (LP: #1128804)
    - Fixes disappearing messagetray (LP: #1067265)
  * debian/patches:
     git_messagetray_hideNotification.patch,
     git_messagetray_opacity_fix.patch,
     git_messagetray_remove_tweens.patch:
       - Dropped, applied in new version
     calendar-remove-strict-check.patch:
       - Added, fixes build failures due to changes in
         deprecation checks for glib symbols
  * debian/control.in:
    - Bump standards version -> 3.9.4, no changes required.
 -- Tim Lunn <email address hidden> Mon, 18 Feb 2013 00:55:02 -0800

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Tim Lunn (darkxst) wrote :
description: updated
Jeremy Bicha (jbicha) on 2013-02-24
Changed in mutter (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in gnome-shell (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
Jeremy Bicha (jbicha) on 2013-02-26
Changed in mutter (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha) wrote :

Thanks Tim! Uploaded to the quantal SRU queue.

Changed in gnome-shell (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Jeremy Bicha (jbicha)

Hello Tim, or anyone else affected,

Accepted mutter into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mutter/3.6.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mutter (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-shell (Ubuntu Quantal):
status: In Progress → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Hello Tim, or anyone else affected,

Accepted gnome-shell into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.6.3.1-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Tim Lunn (darkxst) wrote :

Tested with mutter and gnome-shell from -proposed. All seems to be working well with no obvious regressions.

Message tray bug is fixed as far as I can tell (LP: #1067265).

I can't test barrier fix, since they don't work in a VM. (LP: #1132308), however this fix is unlikely to cause any regressions atleast.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.6.3-0ubuntu0.1

---------------
mutter (3.6.3-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream bugfix release (LP: #1128804)
    - Fix maximized windows jumping between monitors
    - Fix windows turning black when redirected again
 -- Tim Lunn <email address hidden> Tue, 26 Feb 2013 16:38:04 +1100

Changed in mutter (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3.1-0ubuntu0.1

---------------
gnome-shell (3.6.3.1-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release. (LP: #1128804)
    - Fixes disappearing messagetray (LP: #1067265)
    - recorder: Set frame duration to fix broken video headers
    - Block cancellation of unlock dialog during drags
    - Honor lock-delay GSettings key
  * debian/patches/git_remove_messagetray_barrier.patch:
    - Remove barrier at the bottom of the screen (causes problems
      when moving the cursor between multiple screens) (LP: #1132308)
 -- Tim Lunn <email address hidden> Tue, 26 Feb 2013 23:50:34 +1100

Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers