Notifications are being displayed off-screen with gnome-shell l_3.6.2-0ubuntu3 due to git_messagetray_remove_tweens.patch

Bug #1088759 reported by Doug McMahon
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Medium
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Had no issue with _3.6.2-0ubuntu2, with the latest _3.6.2-0ubuntu3 notifications are off-screen, just small part of close button visible
Attached is screenshot when inserting a usb flash drive

Reverting to _3.6.2-0ubuntu2 screenshot 2 shows full notification

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-shell 3.6.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.7.0-5.13-generic 3.7.0-rc8
Uname: Linux 3.7.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.7-0ubuntu1
Architecture: amd64
Date: Mon Dec 10 22:27:15 2012
DisplayManager: lightdm
GsettingsChanges:

InstallationDate: Installed on 2012-12-10 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121206)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Doug McMahon (mc3man) wrote :
Revision history for this message
Doug McMahon (mc3man) wrote :
Revision history for this message
Doug McMahon (mc3man) wrote :

Reverting back to (3.6.1-3ubuntu2

Revision history for this message
Doug McMahon (mc3man) wrote :

If I upgrade to _3.6.2-0ubuntu3 & remove this line then notifactions are fine again
@@ -2052,7 +2052,6 @@
         params.onCompleteParams = [statevar, value, onComplete, onCompleteScope, onCompleteParams];

         // Remove other tweens that could mess with the state machine
- Tweener.removeTweens(actor);
         Tweener.addTween(actor, params);

         let valuing = (value == State.SHOWN) ? State.SHOWING : State.HIDING;

(3.6.2-0ubuntu3 is also causing the shell to freeze on quiting windows, removing the above line also solves that

summary: - Notifications are being displayed off-screen with gnome-shell 3.6.2
+ Notifications are being displayed off-screen with gnome-shell
+ l_3.6.2-0ubuntu2 due to git_messagetray_remove_tweens.patch
summary: Notifications are being displayed off-screen with gnome-shell
- l_3.6.2-0ubuntu2 due to git_messagetray_remove_tweens.patch
+ l_3.6.2-0ubuntu3 due to git_messagetray_remove_tweens.patch
description: updated
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Revision history for this message
Tim Lunn (darkxst) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "gnome-shell-messagetray-fix-lp1088759.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.2-0ubuntu4

---------------
gnome-shell (3.6.2-0ubuntu4) raring; urgency=low

  * Upstream bugfix for disappearing notifications (LP: #1088759)
    debian/patches/git_messagetray_fix_expansion.patch
 -- Tim Lunn <email address hidden> Mon, 17 Dec 2012 07:55:47 +1100

Changed in gnome-shell (Ubuntu):
status: New → Fix Released
Changed in gnome-shell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.