Ubuntu

gnome-shell (3.6) notification bar disappears

Reported by Jonas Frei on 2012-10-16
154
This bug affects 30 people
Affects Status Importance Assigned to Milestone
gnome-shell
Fix Released
Medium
gnome-shell (Arch Linux)
New
Undecided
Unassigned
gnome-shell (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

[Impact]
- The Messagetray will intermittently disappear at which point it becomes impossible to access any successive notifications.
- This is caused by incoming notifications and seems particularly bad for people using empathy.
- This is a high impact bug, since once the tray is gone it requires a restart of gnome-shell to get it back.

[Test Case]
- Start chatting with a couple of people via empathy
- Pretty soon the messagetray should crash and disappear.

[Regression Potential]
None, We originally cherry picked the required patches into raring some time again, so this has been well tested on raring and no regressions have been noted.

=== Original Bug Report ===

Sometimes the notification bar of gnome-shell (3.6) disappears. If this happens, moving the mouse to the bottom does nothing. Also, when showing the activities, there is no notification bar at the bottom. I have to restart gnome-shell to bring it back. I cannot reproduce this, it just happens from time to time (several times a day).

Jonas Frei (freijon) on 2012-10-16
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Dr Belka (wmasters15) wrote :

This bug effects me in the exact same way that the OP describes.

Tim (darkxst) wrote :

I have linked an upstream bug that I believe may fix this issue. However so I can confirm, Could someone affected by this post their session logs (~/.xsession-errors or ~/.cache/gdm/session.log) after reproducing the issue.

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gnome-shell:
status: Fix Released → Confirmed
Matteo Dell'Amico (della) wrote :

I get the same error, also I get it quite frequently. Here's an excerpt from my .xsession-errors. It starts like this, and then the errors multiply...

(gnome-shell:4706): Clutter-WARNING **: Actor '<unnamed>[<StBin>:0x3ab7010]' should not be mapped if parent '<notification-container>[<StWidget>:0x37a0fd0]'is not visible
    JS ERROR: !!! Error calling onComplete
    JS ERROR: !!! message = '"this._notification is null"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/messageTray.js"'
    JS ERROR: !!! lineNumber = '2249'
    JS ERROR: !!! stack = '"()@/usr/share/gnome-shell/js/ui/messageTray.js:2249
wrapper()@/usr/share/gjs-1.0/lang.js:204
("_notificationState",2,wrapper,[object Object],(void 0))@/usr/share/gnome-shell/js/ui/messageTray.js:2075
wrapper("_notificationState",2,wrapper,[object Object],(void 0))@/usr/share/gjs-1.0/lang.js:204
("_notificationState",2,wrapper,[object Object],(void 0))@/usr/share/gnome-shell/js/ui/tweener.js:109
_callOnFunction((function () {oldHandler.apply(eventScope, oldParams);handler(target);}),"onComplete",[object Object],[object _private_St_Widget],[object Array])@/usr/share/gjs-1.0/tweener/tweener.js:202
_updateTweenByIndex(0)@/usr/share/gjs-1.0/tweener/tweener.js:332
_updateTweens()@/usr/share/gjs-1.0/tweener/tweener.js:344
_onEnterFrame([object Object])@/usr/share/gjs-1.0/tweener/tweener.js:359
_emit("prepare-frame")@/usr/share/gjs-1.0/signals.js:124
(418)@/usr/share/gnome-shell/js/ui/tweener.js:249
wrapper(418)@/usr/share/gjs-1.0/lang.js:204
([object _private_Clutter_Timeline],418)@/usr/share/gnome-shell/js/ui/tweener.js:224
"'
    JS ERROR: !!! Exception was: TypeError: this._notification is null
    JS ERROR: !!! message = '"this._notification is null"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/messageTray.js"'
    JS ERROR: !!! lineNumber = '2289'
    JS ERROR: !!! stack = '"()@/usr/share/gnome-shell/js/ui/messageTray.js:2289
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gnome-shell/js/ui/messageTray.js:1982
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gnome-shell/js/ui/messageTray.js:1937
wrapper()@/usr/share/gjs-1.0/lang.js:204
"'
    JS ERROR: !!! Exception in callback for signal: showing
    JS ERROR: !!! message = '"this._notification is null"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/messageTray.js"'
    JS ERROR: !!! lineNumber = '2289'
    JS ERROR: !!! stack = '"()@/usr/share/gnome-shell/js/ui/messageTray.js:2289
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gnome-shell/js/ui/messageTray.js:1982
wrapper()@/usr/share/gjs-1.0/lang.js:204
([object Object])@/usr/share/gnome-shell/js/ui/messageTray.js:1507
_emit("showing")@/usr/share/gjs-1.0/signals.js:124
()@/usr/share/gnome-shell/js/ui/overview.js:632
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gnome-shell/js/ui/overview.js:564
wrapper()@/usr/share/gjs-1.0/lang.js:204

Matteo Dell'Amico (della) wrote :

Another thing, looks like this is actually triggered by some messages arriving. I got it crashing often when I was chatting simultaneously with several people.

Jeremy Bicha (jbicha) on 2012-11-26
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu Quantal):
importance: Undecided → Medium
status: New → Triaged
Tim (darkxst) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.2-0ubuntu3

---------------
gnome-shell (3.6.2-0ubuntu3) raring; urgency=low

  * Upstream bugfix for disappearing message tray (LP: #1067265)
      debian/patches/git_messagetray_remove_tweens.patch
      debian/patches/git_messagetray_opacity_fix.patch
 -- Tim Lunn <email address hidden> Tue, 27 Nov 2012 08:27:57 +1100

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2012-11-27
Changed in gnome-shell (Ubuntu):
status: Fix Released → Triaged

The attachment "dediff fix for raring" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Pau Iranzo (paugnu) wrote :

Any idea when this new package gnome-shell 3.6.2 will be delivered?

Tim (darkxst) wrote :

Pau, It is currently available in quantal-proposed, and should be copied over to quantal-updates any day now

yurividal (yurividal-l) wrote :

It also affects me. I agree with the fact that it SEEMS to be triggered by Messaging, although I am not 100% sure. This is a very annoying bug, and only Atl+F2;r solves it. After updating to 3.6.2 problem STILL persists, and is seen while using Messaging Features. The tray freezes, closes, and an Empathy Chat Window opens. After this, the notification bar disapears untill restart of gnome-shell. (Ubuntu 12.10 gnome-shell 3.6.2)

yurividal (yurividal-l) on 2012-12-07
Changed in gnome-shell (Ubuntu):
status: Triaged → Confirmed
Jeremy Bicha (jbicha) wrote :

yuividal, we've not identified a fix for this bug yet.

Uveges Valentin (iuv-vali) wrote :

This bug is caused by empathy and the extension that empathy is using to communicate to Gnome-shell tray. I am using pidgin at this moment and i do not have any issues. I miss empathy's integrated messaging system.

ricardofunke (ricardo-funke) wrote :

I'm affected by this bug too. My logs attached.

Ulisse (ulipo) wrote :

I can confirm the issue being related to something empathy does, in particular I noticed it happening when resuming from suspend:
- I get some automated messages from nickserv and channel bots, the icons indicates two messages per channel
- if I right click on the icon and select "remove", another "ping" sound is played, the second message pops up from the tray and the tray disappear.

Sometimes I had an even stranger behaviour: by doing the above actions while in overview mode, notification area moved up to about 1/4 of the screen, like if the pop up animation was triggered again while the bar was already visible.

I'm using Ubuntu 12.10 with -proposed repository enabled.

Rajesh KSV (rajeshksv37-h) wrote :

Its happening too often and its very inconvenient. Sometimes even restarting gnome shell isn't working. Sometimes, even after restarting gnome shell, for every notification a small popup box appears (just like zenity boxes). Sometimes unity type notifications appears(this is very rare though). I am using Ubuntu 12.10 - Gnome shell 3.6.2 . I have to logout and login to make it work normally.

Please fix it.

Thanks!

Thane Brimhall (thane) wrote :

For reference, I've seen this bug with empathy AND with Gajim if this extension is installed: https://extensions.gnome.org/extension/565/gajim-im-integration/

The extension does basically the same thing as the empathy extension, I assume.

Changed in gnome-shell:
status: Confirmed → Fix Released
Tim (darkxst) wrote :

This pulls in another upstream patch for this bug.

fabio (trickfun) wrote :

I'm affected by this bug too. My logs attached.

Didier Roche (didrocks) wrote :

Sponsoring to raring Tim's work. Thanks for backporting the patch :)

Tim (darkxst) wrote :

Looks like there will be a gnome-shell 3.6.3 release soon, addressing this issue and a few others. Once that happens, I will see to it, that it gets SRU'ed to Quantal.

Rajesh KSV (rajeshksv37-h) wrote :

Its completely broken in my case. It crashes atleast 2-3 times a day making it virtually useless and missing my chats as well. Please fix it in 3.6

Thanks...

Ron Alon (ro2342) wrote :

It's fixed by GNOME team (https://mail.gnome.org/archives/gnome-announce-list/2013-February/msg00012.html) but Canonical doesn't put it on their repositories.

We just have to wait.

Tim (darkxst) wrote :

Updates are in progress, but it will take a while to get them into Quantal.

In the meanwhile i have uploaded an updated gnome-shell for quantal to my ppa

https://launchpad.net/~darkxst/+archive/ppa

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3-0ubuntu1

---------------
gnome-shell (3.6.3-0ubuntu1) raring; urgency=low

  * New upstream release. (LP: #1128804)
    - Fixes disappearing messagetray (LP: #1067265)
  * debian/patches:
     git_messagetray_hideNotification.patch,
     git_messagetray_opacity_fix.patch,
     git_messagetray_remove_tweens.patch:
       - Dropped, applied in new version
     calendar-remove-strict-check.patch:
       - Added, fixes build failures due to changes in
         deprecation checks for glib symbols
  * debian/control.in:
    - Bump standards version -> 3.9.4, no changes required.
 -- Tim Lunn <email address hidden> Mon, 18 Feb 2013 00:55:02 -0800

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Rajesh KSV (rajeshksv37-h) wrote :

Wow! Finally! Thanks :) You saved my day :)

I have added https://launchpad.net/~darkxst/+archive/ppa but I am not able to install gnome shell 3.6.3 It downloaded but updates have been kept back, may be a dependancy problem ?

Ron Alon (ro2342) wrote :

Oh, its released to Raring - dev version

But not to Quantal - the stable version.

:-)

Tim (darkxst) wrote :

Ron, Quantal version is on my ppa. SRU is in progess for Quantal, but it will take a while before it lands.

Ron Alon (ro2342) wrote :

Oh! I'm sorry, Tim! Thank you! :)

Jeremy Bicha (jbicha) on 2013-02-26
Changed in gnome-shell (Ubuntu Quantal):
status: Triaged → In Progress
Tim (darkxst) on 2013-02-26
description: updated
Gareth (gmccumskey) wrote :

Has this been backported yet? Currently suffering from the same bug myself and not necessarily keen to install yet another PPA...

Tim (darkxst) wrote :

Yes, but has been sitting in the SRU queue for around 6 weeks, not much more we can do other than wait....

Hello Jonas, or anyone else affected,

Accepted gnome-shell into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.6.3.1-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Tim (darkxst) wrote :

I gave this a quick test and was unable to reproduce the disappearing message tray.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3.1-0ubuntu0.1

---------------
gnome-shell (3.6.3.1-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release. (LP: #1128804)
    - Fixes disappearing messagetray (LP: #1067265)
    - recorder: Set frame duration to fix broken video headers
    - Block cancellation of unlock dialog during drags
    - Honor lock-delay GSettings key
  * debian/patches/git_remove_messagetray_barrier.patch:
    - Remove barrier at the bottom of the screen (causes problems
      when moving the cursor between multiple screens) (LP: #1132308)
 -- Tim Lunn <email address hidden> Tue, 26 Feb 2013 23:50:34 +1100

Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.