When running lightDM user locking doesnt work

Bug #1064354 reported by Everaldo Canuto
92
This bug affects 22 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
High
gnome-shell (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

[IMPACT]
 * When running gnome-shell from lightDM, it is not possible to Lock screen or suspend from the user/system Menu.

 * This is due to gnome-screensaver no longer auto-starting when running a non-fallback
   gnome-shell session. We need to explicitly start gnome-screensaver in this case.

[TESTCASE]
 1. From lightDM log into a gnome-shell Session
 2. From user Menu try to Lock or Suspend. It wont work.
 3. using keyboard lock screen with ctrl+alt+L, this forces gnome-screensaver to start.
 4. again try and lock or suspend and it will work.

[Regression Potential]
 None. We are just forcing gnome-screensaver to start for the shell-on-lightdm use case.

== Original Bug Report ==
When running lightDM, the "Lock" option under the gnome-shell User Menu, does not work. Clicking on this does nothing but if you try to lock screen using keyboard (ctrl+alt+L) the it works and also all subsequent clicks on "Lock" option start to work.

ProblemType: BugDistroRelease: Ubuntu 12.10
Package: gnome-shell 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Tue Oct 9 09:16:02 2012
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120902)
NonfreeKernelModules: wl
Package: gnome-shell 3.6.0-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5SourcePackage: gnome-shell
Tags: quantal
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Everaldo Canuto (ecanuto) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
affects: lightdm (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Confirmed → New
description: updated
Tim Lunn (darkxst)
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Tim Lunn (darkxst) wrote :

We need to explicitly load gnome-screensaver when initializing screenshield Fallback, since it doesnt get auto-started when running gnome-shell.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

See also bug 1042907 and Robert Ancell's comments there.

Tim Lunn (darkxst)
description: updated
Revision history for this message
Tim Lunn (darkxst) wrote :
Changed in gnome-shell:
importance: Unknown → High
status: Unknown → Fix Released
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Sponsored and uploaded (this patch has already been accepted into gnome-shell's 3.6 branch). Awaiting SRU approval.

Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Everaldo Canuto (ecanuto) wrote :

Just test it and it is fixed on Quantal-proposed (3.6.1-0ubuntu1.1): universe/gnome

Changed in gnome-shell (Ubuntu):
status: In Progress → Confirmed
tags: added: verification-done
Tim Lunn (darkxst)
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Steve Langasek (vorlon) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.1-0ubuntu1.1

---------------
gnome-shell (3.6.1-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches/ubuntu_screensaver_fallback.patch
    - Explicitly start gnome-screensaver when screenshield loads
      in fallback mode. (LP: #1064354)
 -- Tim Lunn <email address hidden> Fri, 19 Oct 2012 11:46:59 +1100

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Francisco Cribari (cribari) wrote :

I am running Ubuntu 13.04 and gnome-shell 3.6.3.1-0ubuntu6. The problem remains.

Revision history for this message
Tim Lunn (darkxst) wrote :

Francisco, this particular bug has already been fixed, so you are probably experiencing a different bug. Unless you can reproduce the behaviour exactly as listed in the testcase in the first post, please file a new bug using 'ubuntu-bug gnome-shell'.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.