When running lightDM user switching doesnt work

Bug #1064269 reported by Tim Lunn on 2012-10-09
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Invalid
Medium
gnome-shell (Ubuntu)
Medium
Barry Warsaw
Quantal
Undecided
Unassigned
lightdm (Debian)
Fix Released
Unknown

Bug Description

[Impact]
Can't "switch user" from inside GNOME Shell when using lightdm. This is broken high-visibility functionality.

[Test Case]
* Log into GNOME Shell
* Click on the User Menu
* Select Switch User

Nothing happens, but the expectation is that lightdm would appear.

[Regression Potential]
Light. We already had this patch in before during quantal, but then it got accidentally dropped.

[Original Report]
ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-shell 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Tue Oct 9 20:27:57 2012
GsettingsChanges:

InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121002)
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → New

The attachment "gnome-shell-lightdm.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry) wrote :

I can confirm that without this patch, switching users in gnome shell does nothing. With the patch, I always get back to the greeter. So I think this patch is probably reasonable. I don't know the specific APIs involved, so I can't review whether the changes are correct or appropriate.

Also, final freeze is now in effect, so it is not appropriate to upload this to the main archive. I will upload it to quantal-proposed as per https://wiki.ubuntu.com/FinalFreeze so that it can be tested and either cherry picked into the release or SRUd after the release as determined by the release team.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
milestone: none → quantal-updates
Robert Ancell (robert-ancell) wrote :

I've reviewed this patch and it looks correct and appropriate.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.0-0ubuntu3

---------------
gnome-shell (3.6.0-0ubuntu3) quantal-proposed; urgency=low

  * debian/patches/ubuntu-lightdm-user-switching.patch
    - Fix user switching when running lightdm. LP: #1064269
 -- Tim Lunn <email address hidden> Tue, 09 Oct 2012 20:42:33 +1100

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Tim Lunn (darkxst) wrote :

patch was accidently dropped in gnome-shell 3.6.1, so this is broken again for now.

Changed in gnome-shell (Ubuntu):
status: Fix Released → Confirmed
Michael Terry (mterry) on 2012-11-08
Changed in gnome-shell (Ubuntu Quantal):
milestone: none → quantal-updates
Changed in gnome-shell (Ubuntu):
milestone: quantal-updates → none
Michael Terry (mterry) wrote :

jbicha re-enabled the patch for raring (in raring-proposed), and I just uploaded to quantal-proposed for an SRU. So I'll un-subscribe ubuntu-sponsors.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.1-3ubuntu2

---------------
gnome-shell (3.6.1-3ubuntu2) raring; urgency=low

  * Rebuild against new mutter
 -- Jeremy Bicha <email address hidden> Thu, 08 Nov 2012 10:47:35 -0500

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released

Hello Tim, or anyone else affected,

Accepted gnome-shell into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.6.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Quantal):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Tim, or anyone else affected,

Accepted gnome-shell into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-shell/3.6.2-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Tim Lunn (darkxst) wrote :

I can confirm that user switching now works again when running lightdm.

tags: added: verification-done
removed: verification-needed
Tim Lunn (darkxst) wrote :

^ tested under quantal with the gnome-shell pacakge from -proposed.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.2-0ubuntu0.2

---------------
gnome-shell (3.6.2-0ubuntu0.2) quantal-proposed; urgency=low

  * debian/control.in:
    - Really bump mutter and build-depend on gtk-doc-tools

gnome-shell (3.6.2-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release. (LP: #1078155)
    - Fixes disable-user-list option (LP: #1072838)
    - Many other bugfixes
  * debian/control.in
    - Bump minimum mutter
    - Build-depend on gtk-doc-tools to generate updated man page
  * debian/patches/ubuntu_screensaver_fallback.patch:
    - Dropped, applied in new version
  * debian/patches/ubuntu_lock_on_suspend.patch
    - Refreshed
  * debian/patches/ubuntu-lightdm-user-switching.patch:
    - Restored. Accidentally dropped earlier but it just needed to
      be refreshed (LP: #1064269)
  * debian/patches/git-set-ally-wm-theme.patch:
    - Git patch to set/reset HighContrast window theme too
 -- Jeremy Bicha <email address hidden> Mon, 26 Nov 2012 23:39:00 -0500

Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → Fix Released
gerstrong (gerstrong) wrote :

The bug is back in Ubuntu 13.04 with gnome 3.8 using the official gnome-ppa:

I have been logging that message as follows:

    JS ERROR: !!! Exception in callback for signal: activate
    JS ERROR: !!! message = '"Unable to create transient display: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.DisplayManager was not provided by any .service files"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
    JS ERROR: !!! lineNumber = '870'
    JS ERROR: !!! stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/userMenu.js:870
1 wrapper()@/usr/share/gjs-1.0/lang.js:213
2 _emit("name" = undefined, "handlers" = undefined, "i" = undefined, "length" = undefined, "arg_array" = undefined, "arguments" = undefined)@/usr/share/gjs-1.0/signals.js:124
3 anonymous()@/usr/share/gnome-shell/js/ui/popupMenu.js:114
4 wrapper()@/usr/share/gjs-1.0/lang.js:213
5 anonymous()@/usr/share/gnome-shell/js/ui/popupMenu.js:87
6 wrapper()@/usr/share/gjs-1.0/lang.js:213
"'

gerstrong (gerstrong) wrote :

okay, I was checking that old debdiff and created a new one for those who use gnome-shell 3.8 and raring. I think only LightDM is affected.

Tim Lunn (darkxst) wrote :

gerstrong, if you fix up the patch in the packaging (probably just needs a simple rebase and to be re-enabled), I can upload it to the ppa for you.

gerstrong (gerstrong) wrote :

here it goes. I don't know much about debdiff, but hopefully this helps you. Tell me, if further changes are required.

gerstrong (gerstrong) wrote :

or do you prefer that I upload the gnome-shell-common with the patch applied?

Tim Lunn (darkxst) wrote :

gerstrong,
   There are basically three things you need to do:
- re-enable the patch by editing the 'series' file
- rebase the patch in debian/patches (as is, we don't wont to comment out the gdm stuff, since that will break things for gdm users), you can use quilt to help doing this.
- create a changelog entry using 'dch -i'

Build the package and then test, once that is done you can create debdiff against the old source package.

gerstrong (gerstrong) wrote :

Okay, I created a ppa with dch -i and quilt. I'm not very experienced with this. I still need to learn about packaging but here it goes...

gerstrong (gerstrong) wrote :

here goes the debdiff. I think not that important but tells and package. hope it helps anyway

Tim Lunn (darkxst) wrote :

gerstrong, you need to make a debdiff of the source packages (.dsc files) and attach that.

gerstrong (gerstrong) wrote :

Like this one?

gerstrong (gerstrong) wrote :

It hasn't been integrated into the updates so far. Too bad, I consider it critical fro Gnome Users

eugene (e-o-popov) wrote :

It seems that this bug is fixed now. At least with both gnome3 and gnome3-staging ppa enabled.

Changed in lightdm (Debian):
status: Unknown → Fix Released
Changed in gnome-shell:
status: New → Invalid
Mathieu Parent (math-parent) wrote :

I've rported it upstream, with a proposed patch: https://bugzilla.gnome.org/show_bug.cgi?id=745940

Tim Lunn (darkxst) wrote :

Hi Mathieu,
  that would be a duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=685794, see comment #6. upstream don't want to take alternate code-paths for this. What really needs to happen is for org.freedesktop.DisplayManager to become an actual standard (since it isnt at the moment, despite the name)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.