Ubuntu

gnome-shell crashed with signal 5 in st_widget_get_theme_node()

Reported by Domen Vrankar on 2012-10-08
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

I opened AltovaXMLSpy in wine, went to activities menu where I was chatting over empathy notification window and then I switched to skype window (I'm not certain whether I clicked on it or alt tabbed to it). At that moment I wasn't able to click on any opened window and after aproximately 10 seconds gnome-shell restarted and this crash raport popped up.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gnome-shell 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Mon Oct 8 21:10:21 2012
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/bin/gnome-shell
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 st_widget_get_theme_node () from /usr/lib/gnome-shell/libgnome-shell.so
 ?? () from /usr/lib/gnome-shell/libgnome-shell.so
 clutter_actor_get_preferred_width () from /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
 _st_actor_get_preferred_width () from /usr/lib/gnome-shell/libgnome-shell.so
 ?? () from /usr/lib/gnome-shell/libgnome-shell.so
Title: gnome-shell crashed with signal 5 in st_widget_get_theme_node()
UpgradeStatus: Upgraded to quantal on 2012-09-06 (32 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Domen Vrankar (domen-vrankar) wrote :

StacktraceTop:
 st_widget_get_theme_node (widget=0xca1bca8) at st/st-widget.c:573
 st_box_layout_get_preferred_width (actor=0xca1bca8, for_height=-1, min_width_p=0xbfea0418, natural_width_p=0xbfea041c) at st/st-box-layout.c:351
 clutter_actor_get_preferred_width (self=self@entry=0xca1bca8, for_height=-1, min_width_p=min_width_p@entry=0xbfea04c4, natural_width_p=natural_width_p@entry=0xbfea04c8) at ./clutter-actor.c:9234
 _st_actor_get_preferred_width (actor=actor@entry=0xca1bca8, for_height=<optimized out>, for_height@entry=<error reading variable: Could not find type for DW_OP_GNU_const_type>, y_fill=y_fill@entry=0, min_width_p=min_width_p@entry=0xbfea04c4, natural_width_p=natural_width_p@entry=0xbfea04c8) at st/st-private.c:61
 get_content_preferred_width (self=0x9e3c578, for_height=-1, min_width_p=min_width_p@entry=0xbfea0548, natural_width_p=natural_width_p@entry=0xbfea054c) at st/st-box-layout.c:315

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Jeremy Bicha (jbicha) on 2013-03-11
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Tim (darkxst) wrote :

are you using extensions which have css stylesheets? there was a crash that is fixed in 3.8 but may need backporting to 3.6

https://git.gnome.org/browse/gnome-shell/commit/?id=655dce6a4b2d5ad02a3e108b6fbc118f4a3ae2d2

Yes most of the extensions that I'm using have their own css files:
https://extensions.gnome.org/extension/17/dock/
https://extensions.gnome.org/extension/442/drop-down-terminal/
https://extensions.gnome.org/extension/559/quit-from-dash/
https://extensions.gnome.org/extension/474/stopwatch/
https://extensions.gnome.org/extension/162/todo-list/

I'm not certain when the crashes started but looking at the date of the
commit that has introduced the css bug I'd say that it is quite possible
that this is the reason.

2013/4/13 Tim <email address hidden>

> are you using extensions which have css stylesheets? there was a crash
> that is fixed in 3.8 but may need backporting to 3.6
>
> https://git.gnome.org/browse/gnome-
> shell/commit/?id=655dce6a4b2d5ad02a3e108b6fbc118f4a3ae2d2
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1064022
>
> Title:
> gnome-shell crashed with signal 5 in st_widget_get_theme_node()
>
> Status in “gnome-shell” package in Ubuntu:
> Confirmed
>
> Bug description:
> I opened AltovaXMLSpy in wine, went to activities menu where I was
> chatting over empathy notification window and then I switched to skype
> window (I'm not certain whether I clicked on it or alt tabbed to it).
> At that moment I wasn't able to click on any opened window and after
> aproximately 10 seconds gnome-shell restarted and this crash raport
> popped up.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.10
> Package: gnome-shell 3.6.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
> Uname: Linux 3.5.0-17-generic i686
> ApportVersion: 2.6.1-0ubuntu1
> Architecture: i386
> CrashCounter: 1
> Date: Mon Oct 8 21:10:21 2012
> ExecutablePath: /usr/bin/gnome-shell
> GsettingsChanges:
>
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386
> (20111012)
> ProcCmdline: /usr/bin/gnome-shell
> Signal: 5
> SourcePackage: gnome-shell
> StacktraceTop:
> st_widget_get_theme_node () from /usr/lib/gnome-shell/libgnome-shell.so
> ?? () from /usr/lib/gnome-shell/libgnome-shell.so
> clutter_actor_get_preferred_width () from
> /usr/lib/i386-linux-gnu/libclutter-1.0.so.0
> _st_actor_get_preferred_width () from
> /usr/lib/gnome-shell/libgnome-shell.so
> ?? () from /usr/lib/gnome-shell/libgnome-shell.so
> Title: gnome-shell crashed with signal 5 in st_widget_get_theme_node()
> UpgradeStatus: Upgraded to quantal on 2012-09-06 (32 days ago)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1064022/+subscriptions
>

Tim (darkxst) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.3.1-0ubuntu6

---------------
gnome-shell (3.6.3.1-0ubuntu6) raring; urgency=low

  * debian/patches:
      - git_fix_theme_node_crash.patch, git_add_stylesheets_signal.patch
          Fixes crash that occurs when extensions have custom
          stylesheets (LP: #1064022)
 -- Tim Lunn <email address hidden> Mon, 22 Apr 2013 08:38:14 +1000

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers