Does not start if gdm is not installed

Bug #1054288 reported by Dylan McCall on 2012-09-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Unassigned

Bug Description

Since a recent update in Quantal, I am unable to start gnome-shell. This appears to be because gdm is not installed:

% gnome-shell --replace
    JS ERROR: !!! Exception was: Error: Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found
    JS ERROR: !!! message = '"Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
    JS ERROR: !!! lineNumber = '4'
    JS ERROR: !!! stack = '"@/usr/share/gnome-shell/js/ui/userMenu.js:4
"'
    JS ERROR: !!! Exception was: Error: Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found
    JS ERROR: !!! message = '"Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
    JS ERROR: !!! lineNumber = '4'
    JS ERROR: !!! stack = '"@/usr/share/gnome-shell/js/ui/userMenu.js:4
"'
    JS ERROR: !!! Exception was: Error: Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found
    JS ERROR: !!! message = '"Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
    JS ERROR: !!! lineNumber = '4'
    JS ERROR: !!! stack = '"@/usr/share/gnome-shell/js/ui/userMenu.js:4
"'
    JS ERROR: !!! Exception was: Error: Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found
    JS ERROR: !!! message = '"Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/userMenu.js"'
    JS ERROR: !!! lineNumber = '4'
    JS ERROR: !!! stack = '"@/usr/share/gnome-shell/js/ui/userMenu.js:4
"'
Window manager warning: Log level 32: Execution of main.js threw exception: Error: Requiring Gdm, version none: Typelib file for namespace 'Gdm' (any version) not found

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-shell 3.5.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Fri Sep 21 12:00:17 2012
GsettingsChanges:
 b'org.gnome.desktop.interface' b'cursor-theme' b"'Adwaita'"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'gtk-theme' b"'Adwaita'"
 b'org.gnome.desktop.interface' b'icon-theme' b"'gnome'"
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110906)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to quantal on 2012-08-26 (25 days ago)

Dylan McCall (dylanmccall) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Andrea Rota (hotzeplotz) wrote :

this affects me as well and i can confirm that it is solved (for me) by installing gdm, which i had removed yesterday: if i remember correctly, after my latest dist-upgrade within quantal, apt-get did alert me that the gdm package was not used anymore and could be removed through apt-get autoremove, which i did.

i have been using lightdm as my DM since before upgrading to quantal from precise.

Jeremy Bicha (jbicha) on 2012-09-22
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.5.92-0ubuntu2

---------------
gnome-shell (3.5.92-0ubuntu2) quantal; urgency=low

  * debian/control.in:
    - Restore gdm dependency accidently dropped in last upload (LP: #1054288)
 -- Jeremy Bicha <email address hidden> Fri, 21 Sep 2012 16:07:06 -0400

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers