Ubuntu

Keyboard layout doesn't show in GNOME Shell session

Reported by Anton Sudak on 2012-09-04
606
This bug affects 128 people
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
gnome-shell (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

Keyboard layout doesn't show in GNOME Shell session, using two layouts.
Ubuntu 12.10.

Extender (msveshnikov) on 2012-09-05
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what Ubuntu version do you use? gnome-shell has its own indicator so reassigning there

affects: gnome-settings-daemon (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Anton Sudak (anton-sudak) wrote :

Oh, i forgot to specify version. I'm using 12.10.

description: updated
Extender (msveshnikov) on 2012-09-06
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
Jeremy Bicha (jbicha) wrote :

In my error log (~/.cache/gdm/session.log if running gdm or ~/.xsession-errors if running lightdm), I get this error:

JS LOG: IBus version is too old

Specifically, it's looking for ibus_bus_new_async which is part of ibus 1.5, but Ubuntu 12.10 will only be shipping 1.4. I'm afraid this likely won't be fixable for Ubuntu 12.10.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) on 2012-09-29
Changed in ibus (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Žygimantas Beručka (zygis) wrote :

I'd like to object against tagging it's importance as 'Low.' Changing layouts, you know, it's some UX basics that should 'just work' in the 21st century. I use at least 4 layouts (the current limit on Ubuntu) daily, switching between them back and forth, and needless to say this is _very_ inconvenient for me and many other users, I believe. As is the option to wait another 7 months (!) at the very least until this is resolved.

I understand that it's late in the cycle, but it's not a LTS release after all, so something should be done about that.

Jeremy Bicha (jbicha) wrote :

I spent a considerable amount of my weekend working on packaging ibus in my PPA. It's far too late for this to land in Quantal and here's a few notes:

1. It needs gnome-control-center (System Settings) and gnome-settings-daemon to be updated. gnome-settings-daemon is critical infrastructure to the Unity and GNOME desktops and really ought to have more wide-spread testing.
2. The keyboard and ibus "indicator" system menus need to be rewritten
3. As most of the Ubuntu core developers are from Europe or the Americas, it's difficult on such short notice to verify that the new ibus works correctly for all the input methods currently supported in Quantal.
4. Ubuntu's extensive modifications to the Appearance panel of System Settings need to be rewritten, preferably as a separate panel. For now, if you want to change your theme, use gnome-tweak-tool.
5. For several reasons (one being I have to rebuild nux against the new ibus every time there is a new nux release or else Unity won't start), the PPA is not designed for Unity users.
6. The Ubuntu help will be outdated as it refers to System Settings 3.4, not 3.6.
7. As I don't use any of these input methods & will likely upgrade to the Alpha of Ubuntu 13.04 soon after 12.10's release , there's no guarantee that I will continue to support the PPA
8. I haven't finished rebuilding all the ibus modules; let me know if there's a particular one you need.

There are benefits to the new ibus; it looks like the 4 layout limit no longer applies.

https://launchpad.net/~jbicha/+archive/ibus

Yotam Benshalom (benshalom) wrote :

I can confirm that the PPA brings the layout indicator back.

However, it brings a new problem. Now it is much more difficult to set a keyboard shortcut for changing layouts.
In the Typing section of the keyboard shortcuts I am not able to set the "next engine" to be a combination of shifts and/or alts (it will just not record them), and if I choose the Menu key it is set but does not work (it is intercapted as "right-click key" and is not recognised as a shortcut). This section is willing to accept only combinations containing letters - but letters are the very things that change when the layout changes!

The only reliable way I found to change layouts with the keyboard was to assign one of the F# keys as a shortcut. This works no matter what is the current keyboard layout.

Jeremy Bicha (jbicha) wrote :

Yotam, please see https://bugzilla.gnome.org/681685 especially comment 59.

Yotam Benshalom (benshalom) wrote :

Thank you very much, Jeremy!

Jeremy Bicha (jbicha) wrote :

Yotam, the new gnome-tweak-tool (3.6.0-0ubuntu1) is now in Quantal. Check the typing panel.

Yotam Benshalom (benshalom) wrote :

Thank you, but its interface is quite unclear. Where exactly can I set there the layout switching key?

Sorry, yes, gnome-tweak-tool's user interface is a bit broken since it
is auto-generated from the gsettings schemas.

I believe the option you want is the bottom one in the Typing panel.

Yotam Benshalom (benshalom) wrote :

Thank you Jeremy, it works.

Now there are only two usability issues which block me (and other non-Latin Gnome users) from using the ppa regularly:

1. Cannot change layout in overview mode: https://bugzilla.gnome.org/show_bug.cgi?id=643111
2. LibreOffice would not recognise shortcuts under non-Latin layouts: https://bugs.freedesktop.org/show_bug.cgi?id=55585

There is also one problem which was fixed upstream, and I hope it can be uploaded to your ppa:

1. Cannot use Menu key as a shortcut for changing the keyboard layout: https://bugzilla.gnome.org/show_bug.cgi?id=685286 (when this is uploaded, I hope it also comes with UI which allows us to set this shortcut)

mabawsa (mabawsa) wrote :

I tried the Jeremy's ppa on Beta 2 Ubuntu 12.10 (gnome shell) and it doesn't seem to work anymore. The daemon throws no error on the terminal but I cannot see the indicator now can I type in Japanese.

Any ideas?

I am about to lose my mind. How do I get this back now, or at least what is the keyboard shortcut to do so? I am unable to work without switching layouts, I don't understand why this simple icon is gone :( please help

changed the description, applies to any layouts

description: updated
cyberIQ (oktayahmed) wrote :

I upgradet to 12.10 and the problem repeated!!!

After EVERY NEW UPGRADE for the last few years, I am having this problem!!!

WHY IT'S SO COMPLICATED TO SOLVED A RIDICULOUS PROBLEM of keyboard layout icon?

I am heavy on Writer, so CANNOT WORK without keyboard indicator. What should I do? Go back to Windows/Word?

If Ubuntu lost us, the heavy users, they will get nothing with kids and games. This is not game. THIS IS SERIOUS!!! We are using Ubuntu for serious work.

That's why this problem (who occurs for YEARS) should be priority and not be ranked as LOW...

Adam Lofts (adam-lofts) wrote :

I installed the ppa above. It deleted my selected keyboard layouts in the system settings but after re-adding them I now have the keyboard menu in gnome-shell. Suggest integrating the ppa into the gnome3 ppa so gnome-shell works by default. Thanks for the help Jeremy.

1 comments hidden view all 103 comments
Dialekti Valsamou (dialecti) wrote :

Installing the ppa did provide the keyboard layout indicator, but I find that the options for the key to switch layouts are poor. I used to have CapsLock as a layout switcher (and Shift CapsLock for CapsLock), but the current alternatives are only a subset of the previous ones.

Thank you Jeremy!

konstantine (arianos) wrote :

I don't know if I should report this here or as a different bug, but when you are in overview mode of gnome shell you cannot change the language layout. The same problem exists when you type in the textfield of the chat notification or when you insert a command through Alt+F2. Sometimes, this is really annoying (especially when you use the chat notification)

yes but there a lot of things you cannot do if no window is active (such as overview mode), that includes volume control ;)

konstantine (arianos) wrote :

@sebastian but it used to work in gnome 3.4. Volume control is not such a problem, because you can just leave overview mode and adjust it. But, what if you search for a program or file whose name contains both latin and greek characters and what if you chat with someone and you want to combine greek and english words (something really usual in my case ;) ?

TomsT (ttomst) wrote :

It looks like there isn't much enthusiasm to really fix this issue without walking on razors edge between upgrading and braking packages; so maybe someone with required skills can just create (if it is possible) an extension at extensions.gnome.org with an layout indicator allowing to change keyboard layouts or, at least, to be able to see witch layout the user is using, making it easier to shortcut-switch between them and writing passwords with the right layout?

MatatTHC (matatthc) wrote :

I am also affected by the bug. Any permanent workaround or solution would be much appreciated.

Regarding the gnome-tweak-tool : what is the exact name of the option in the typing panel. I can not locate anything that seems helpful.

Thanks in advance.

konstantine (arianos) wrote :

@matatthc it's the last one: "Modifiers-only input source switcher shortcut"

Pavlo Bohmat (bohm) wrote :

After upgrading to 12.10 there is no indicator keyboard layout! In Lightdm two indicators en and en+ru+ua! In unity nothing! Need use: setxkbmap "us,ru,ua" ",winkeys,winkeys" "grp:menu_toggle,grp_led:scroll"

Pretty annoying bug for those we are switching between languages all the time like me (Spanish/English)... any trick of how to avoid it would be welcomed.

Right now, the quickest (really slow) way to change it for me is:

Space+enter (I use Synapse)
Type Keyboard Layout
Go to the Layouts tab
Move Spanish to the top of the list at the left

... mmmm, not really quick....

anyone knows how to do it quicker while the bug is still in process to be fixed?

Thanks,

Hipo

shaneonabike (shanebill) wrote :

I'm also confused as to why this is of low priority. I am a bit nervous to install the PPA... and it indicates that it isn't stable. Have people had much success cause I'm willing to try that. Could we not just deploy a solution for this release that will also make it into 13.x

It seems weird they would have removed this feature - it's basically removing accessibility for people of different languages.

Thanks for your efforts and work!

1 comments hidden view all 103 comments

this bug really needs to get fixed, it's ridiculous. How about that gnome shell extension idea? can someone do that?

Jeremy Bicha (jbicha) wrote :

Ok, I was mistaken about this needing ibus 1.4.99 (unless you use ibus input methods in which case this is still broken). For everyone else, this is fixed with gnome-control-center 3.6 which has been uploaded to raring for Ubuntu 13.04.

no longer affects: ibus (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Jeremy Bicha (jbicha) wrote :

And uploaded to the GNOME3 PPA, which is the best we'll be able to do for Ubuntu 12.10.

Changed in gnome-shell (Ubuntu Quantal):
status: Triaged → Fix Committed
Dylan McCall (dylanmccall) wrote :

Seems the gnome-settings-daemon update has created some serious breakage for some systems. (Well, all of mine, and two other people who have taken the time to post on Ubuntu Forums). Wish I could spare the time to get details for you, but I can't right now. Hope it works out, though. I was excited to see Control Center 3.6 :)

http://ubuntuforums.org/showthread.php?t=2087857

Žygimantas Beručka (zygis) wrote :

I don't use Jeremy's ibus PPA, only GNOME3 PPA. But after the yesterday's update I was unable to start neither GNOME nor Unity, all the apps would segfault leaving such messages in dmesg:

[ 47.716480] nm-applet[2399]: segfault at 30 ip 00007f22bc896526 sp 00007fff1ea24670 error 4 in libgdk-3.so.0.600.0[7f22bc845000+7c000]
[ 49.374176] nautilus[2396]: segfault at 30 ip 00007fd4ab396526 sp 00007fff4dac6480 error 4 in libgdk-3.so.0.600.0[7fd4ab345000+7c000]
[ 56.726832] gnome-shell-cal[2478]: segfault at 30 ip 00007fa8fb61b526 sp 00007fff917aef90 error 4 in libgdk-3.so.0.600.0[7fa8fb5ca000+7c000]

Since it complains something about libgdk, I thought maybe it has something to do with the gnome-themes-standard package. And once I downgraded this package to 3.6.0.2, I was able to load both GNOME and all apps would work fine.

I wonder if it has something to do with that relocation of gtk engine files in the package for Raring and backporting this to Quantal with these files moved to /usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/theming-engines/ and /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/. By the way, why does this updated package have a Gtk2 theme engine file and 3.6.0.2 doesn't?

Jeremy Bicha (jbicha) wrote :

Hi, I'm really sorry about that rather serious bug in the GNOME3 PPA. It is fixed now so you should be able to check for updates and apply them.

I opened https://bugzilla.gnome.org/689027 to track the underlying theme and segfaulting problem.

Žygimantas Beručka (zygis) wrote :

Okay, thanks! You fixed those segfaults with this upload.

However, I just found another source of segfaults related to these recently updated packages. I lost the ability to adjust screen brightness using my laptop's Fn+ScreenBrightnessUp/Down keys. Instead, it causes gnome-settings-daemon to crash. I get dmesg filled with messages like this:

[13929.207758] gnome-settings-[9069]: segfault at 61 ip 00007fbec1744585 sp 00007fff2f822ea0 error 4 in libmedia-keys.so[7fbec1739000+25000]

Žygimantas Beručka (zygis) wrote :

And when running gnome-settings-daemon from a terminal, I get this on triggering that keyboard shortcut:

 (gnome-settings-daemon:9651): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `GsdMediaKeysManager'

Julien Olivier (julo) wrote :

Hi,

I've reported it already here:
https://bugzilla.gnome.org/show_bug.cgi?id=689036

Feel free to add your comments / backtrace.

Le lundi 26 novembre 2012 à 00:24 +0000, Žygimantas Beručka a écrit :
> Okay, thanks! You fixed those segfaults with this upload.
>
> However, I just found another source of segfaults related to these
> recently updated packages. I lost the ability to adjust screen
> brightness using my laptop's Fn+ScreenBrightnessUp/Down keys. Instead,
> it causes gnome-settings-daemon to crash. I get dmesg filled with
> messages like this:
>
> [13929.207758] gnome-settings-[9069]: segfault at 61 ip 00007fbec1744585
> sp 00007fff2f822ea0 error 4 in libmedia-keys.so[7fbec1739000+25000]
>

ok so in 12.10, the only way to get it fixed is use the gnome3 ppa? regular updates wont do? is that PPA gonna break anything in my ubuntu system?

Changed in baltix:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
Arkady L. Shane (atigro) on 2012-11-30
Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2012-12-02
Changed in gnome-shell (Ubuntu Quantal):
status: Fix Released → Fix Committed
23 comments hidden view all 103 comments
Karen Zagorski (karenzag) wrote :

> OK, hope that my comments on GNOME didn't offend you.
Of course, no ))))

>Are you aware of the fact that vanilla GNOME 3.6 enforce global keyboard layout?
>Do you care about it?

OMG.. I just noticed... That is totally crazy... Why?O_O

>But Apps are removing features.
Yep. That is bad.
>Do you like vanilla Nautilus 3.6?
Did't use it for long, just for 1 day... What's lost?
>Probably also the Totem issue you feel strong about.
Yep, fortunately smplayer has that function too.

I like the concept of gnome shell, the new design, the idea. But not the way some crazy people destroy it. I mean if they just let the gnome shell be what it is now with just fixing bugs, not removing functions and making crazy changes-it is good

>Alt+`
>Hold "Super" key to show shortcut cheat sheet overlay.
That it discomfort. I prefer doing it just with mouse, because I, and loooots of people like me, have bad eyes and my laptop is usually a bit far from me, because eyeglasses make me tired. So i must reach laptop each time i switch screens or do it long way. Usually desktop environment gives priority of comfort to mouse, and keyboard shortcuts are just helping. Thats why it's not improved terminal, its desktop.

>You set it to auto-hide mode?
Yep. I know, there is a way to change sensitivity of how "far" I must push the mouse. But i.most ppl don't. Not for human beings ii.I tackled sensitivity whole day. No real profit. There is just something buggy in the mechanism, like it reacts with random sensitivity...

>Have you used Unity Lens?
Well... Improved search. A stuff people use not often. Well, I don't. I know where are my files :)
Amazon is not such a problem for me. It can be disabled, plus... Well we have webcameras in the streets, satellites, analisers that monitor our calls and report if you say something like "terrorism kill bomb". amazon doesn't bother me :)))

http://dougneubauer.com/mhcctest/ testfile:)

harontas (harontasgh) wrote :

Hello.i am a linux user since ubuntu 8.04.Linux has evolved till now to a new level which "user friendly" is not a dream any more..From installing distro or a program through soft center to using the distro as a whole is so easy that a kid can learn how to do it.And linux is the only Os that can let you choose among desktop environments according to your liking or hardware.As i used linux i learned that there is no thing that cannot be done.If something e.x. a device cannot be installed on windows in linux it will play or out of the box or with a little configuration which is mosty a copy paste for someone who doesnt know technical stuff.By evolving to a better Os with new things there will always be bugs affecting users but we are in 2012 already that bugs aren't tha t much as the earlier years and if major ones appear the technical team should be able to collect info and solve them with their knowledge.Finally i have learned there is always more than one way to achieve the same thing in Linux.So i dont understand why it is so hard to solve issues with ibus which i read is very buggy many years now and finally if it cant work replace it with another software that does the same thing or it is more flexible.i know linux is a free Os and such things are acceptable some times but if things are working and working better than other Os that are proprietary it is a pitty to leave so many users dissapointe.Not only for ibus but generally(features,bugs,support).I hope everything goes ok as i realy like ubuntu and gnome shell is becoming my favorite as i use it.I wish i knew programing to aid the team in their hard work.

harontas (harontasgh) wrote :

No responce...MERRY XMASS TO EVERYONE!

Meng Zhuo (mengzhuo1203) wrote :

2012/12/10 harontas <email address hidden>

> Hello.i am a linux user since ubuntu 8.04.Linux has evolved till now to
> a new level which "user friendly" is not a dream any more..From
> installing distro or a program through soft center to using the distro
> as a whole is so easy that a kid can learn how to do it.And linux is the
> only Os that can let you choose among desktop environments according to
> your liking or hardware.As i used linux i learned that there is no thing
> that cannot be done.If something e.x. a device cannot be installed on
> windows in linux it will play or out of the box or with a little
> configuration which is mosty a copy paste for someone who doesnt know
> technical stuff.By evolving to a better Os with new things there will
> always be bugs affecting users but we are in 2012 already that bugs
> aren't tha t much as the earlier years and if major ones appear the
> technical team should be able to collect info and solve them with their
> knowledge.Finally i have learned there is always more than one way to
> achieve the same thing in Linux.So i dont understand why it is so hard
> to solve issues with ibus which i read is very buggy many years now and
> finally if it cant work replace it with another software that does the
> same thing or it is more flexible.i know linux is a free Os and such
> things are acceptable some times but if things are working and working
> better than other Os that are proprietary it is a pitty to leave so many
> users dissapointe.Not only for ibus but
> generally(features,bugs,support).I hope everything goes ok as i realy
> like ubuntu and gnome shell is becoming my favorite as i use it.I wish i
> knew programing to aid the team in their hard work.
>

Help that guy named Fujiwarat on git repos who is the main coder for IBus
interface of Gnome-shell.
I don't understand why everyone just grumpy about the new features and do
nothing about it. Instead of arguing on this Ubuntu Gnome mail-list
,sending mails to the gnome-shell list or coders behind, even voting for
the Roadmap of newer version can makes much more differences on the issues
that we discussed.

>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1059341).
> https://bugs.launchpad.net/bugs/1045914
>
> Title:
> Keyboard layout doesn't show in GNOME Shell session
>
> Status in “gnome-shell” package in Ubuntu:
> Fix Released
> Status in “gnome-shell” source package in Quantal:
> Fix Committed
> Status in Baltix GNU/Linux:
> Confirmed
>
> Bug description:
> Keyboard layout doesn't show in GNOME Shell session, using two layouts.
> Ubuntu 12.10.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1045914/+subscriptions
>

riderplus (entropy) wrote :

I can confirm the bug on Ubuntu 12,10 Gnome 3 DE with everything updated from the Gnome 3 PPA repo. The keyboard layout indicator does not show up in the top panel. I repeat, I have just added the right Gnome 3 PPA and installed the updates, the keyboard layout indicator is still missing.
.

riderplus (entropy) wrote :

To make it even worse, in Gnome 3.7.3 when I try to go to Layout Options it crashes and prompts me with crash report.

Xiaojun Ma (damage3025) wrote :

On Thu, Dec 27, 2012 at 6:06 AM, Meng Zhuo <email address hidden> wrote:
> Help that guy named Fujiwarat on git repos who is the main coder for IBus
> interface of Gnome-shell.

Fujiwarat is definitely the main author of ibus-gjs and now the active
maintainer of IBus core and ibus-anthy. However, I'm not sure about
the state of GNOME 3.6 keyboard plugin. I also have no idea why it
seems quite difficult to port ibus-gjs git master to 3.6. (I tried but
failed, no good experience to share)

> I don't understand why everyone just grumpy about the new features and do
> nothing about it. Instead of arguing on this Ubuntu Gnome mail-list
> ,sending mails to the gnome-shell list or coders behind, even voting for
> the Roadmap of newer version can makes much more differences on the issues
> that we discussed.

I definitely use d-d-l, but it sucks.
The developers generally don't listen and I seriously don't think
there was/is/will be public vote for GNOME roadmap.
I value contribution but contributing to a open source close mind
project seems to be a total waste of time; switching to a sane project
like E17, MATE (the list is just my personal view) is definitely a
better option.
I used to hate GNOME rants. But now I feel ranting is actually a
positive action to keep uninformed people away from junks.

So, it seems under 12.10 with Gnome 3 PPA the Input Sources are not ported completely. This is how the look in the normal Gnome 3.6:
http://blogs.gnome.org/mclasen/2012/09/21/input-sources-in-gnome/
And in 12.10 w/ the Gnome 3 PPA that's not the case, hence the bug.
Jeremy, it does need fixing.

Yordan Tsolov (mazzzterz) wrote :

For the problem is still not fixes as well.

riderplus (entropy) wrote :

NO fix for this bug so far, even using GNOME 3 ppa does not fix it! Why does it take so freaking long? It's not a kernel bug, why in the world does it take so long to fix it?

riderplus (entropy) wrote :

Upgrading to 13.04, then adding the ppa:gnome3-team/gnome3-staging to the repo list, updating and upgrading again made the Keyboard Layout Indicator reappear. Thank you for the fix!

Xiaojun Ma (damage3025) wrote :

> Upgrading to 13.04, then adding the ppa:gnome3-team/gnome3-staging to
> the repo list, updating and upgrading again made the Keyboard Layout
> Indicator reappear. Thank you for the fix!

Yo yo, yet another story of Ubuntu fixes bugs in next release.

riderplus (entropy) wrote :

Actually the bug persists. Now when I click on the Keyboard Layout Indicator and try to switch to a different language, gnome shell crashes and there's nothing I can do about it. If I try to switch the language by using the shortcut chosen (Alt+CapsLock), the language does not change. It's even worse than before.

riderplus (entropy) wrote :

After several restarts I can switch the Layouts from the Indicator. But there is no valid Layout for "Romanian Standard", "Romanian Cedilla", "Russian"...the Arabian Layout is ok. I will post a different bug on launchpad.

riderplus (entropy) wrote :

I posted a bug here https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1096901 and here https://bugzilla.gnome.org/show_bug.cgi?id=691290
Please solve these issues once and for all, it's so freaking annoying.

riderplus (entropy) wrote :

The "Romanian" Layout is the same with "Romanian (standard)", "Romanian(cedilla)" and all the others. Can someone fix this? They should have different keyboard layouts.

riderplus (entropy) wrote :

Why is it so hard to make the Layouts back as they were before? Now there is no difference between the Romanian Keyboard Layouts (only their names differ, the Layout is the same for all of the seven). Can someone check and fix this bug? I need Romanian (standard), I'm used to writing in Romanian (standard), not in Romanian, where I have to place diacritics by using the Alt key and it's really a pain in the arse. Thank you.

riderplus (entropy) wrote :

I made a clean install of Ubuntu 13.04, then installed gnome-shell and gdm, added GNOME3 team PPA and upgraded. The Keyboard Layout Indicator is still absent.

Changed in gnome-shell (Ubuntu):
importance: Low → Medium

now it sais fix committed. when?

harontas (harontasgh) wrote :

@Sebastian Haselbeck (sebastianhaselbeck)

Unfortunately "fix commited" means that a solution is found but it will apply only at next release which means raring ringtail.so i think patience for now is the only thing we can do for now.

sgon00 (sgon00) wrote :

Just fresh install ubuntu gnome remix 12.10 and add ppa:gnome3-team/gnome3 and then upgrade gnome-control-center, gnome-settings-daemon, nautilus etc... The problem still exists. I can not see the indicator!!! what the hell !? PS: I am using ibus.

Jeremy Bicha (jbicha) wrote :

As I said twice already (comments 44 and 49), I can no longer duplicate this bug and there are too many comments on this bug for someone to easy triage. Please open a new bug for your specific issue with clear steps for how to reproduce your problem from a clean install and user account.

Robotron (robotron) wrote :

As a temporary workaround you can install gkrellm-xkb, run gkrellm and turnoff all monitors except xkb.

Anton Anikin (anton-anikin) wrote :

I have the same problem with 13.04 Alpha (raring)

Žygimantas Beručka (zygis) wrote :

I can confirm that. The issue is still present in 13.04.

2013/3/17 Anton Anikin <email address hidden>

> I have the same problem with 13.04 Alpha (raring)
>
>

shan (holinuhi) wrote :

yes very same here in 13.04 with gnome fallback otherwise everything good but no keyboard layout indicator

so used the clever trick from Robotron with install gkrellm-xkb, run gkrellm and turnoff all monitors except xkb.

and to make it permanent added it to to startup apps Excellent advice!

Jacob Dekel (jacob-mvsdasd) wrote :

FWIW , this bug makes the distribution useless for me. 13.04 will be the second ubuntu release in a row that I will not be using due to this bug.

burdandrei (burdandrei) wrote :

Checked Gnome 3.8 on Ubuntu 13.04 - still no layout indicator.

Žygimantas Beručka (zygis) wrote :

It seems that no one cares about this bug despite it being reported many
times, see, e.g.:

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1096901
https://bugs.launchpad.net/ubuntu/+bug/1096862
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1154486
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1115855

Jeremy said something mystic above about not being able to track this bug
due to too many comments or some other reason. Therefore I decided to make
a new bug report for this and yet I immediatelly realized it is not
necessary, as you can see: it's been reported OVER AND OVER AGAIN. I have
no clue what else is there left for one to do.

Therefore I would like to suggest you to click those bugs and mark that you
are affected by them/it too, since probably no one reads the comments here
anyway. Maybe then someone would pay a slightest attention to this.

My 0.02 c.

bAjDa (angrybee) on 2013-04-28
Changed in gnome-shell (Ubuntu Quantal):
status: Fix Committed → New
status: New → Incomplete
status: Incomplete → Confirmed
Mattia Donato (mattia-donato) wrote :

I confirm the bug and a fresh UbuntuGnome 13.04 has this problem.
I think should be considered "High importance" not "medium" as now!!
We are in 2013 in a globalized world and it's impossible to work without a switcher or something that tell which layout you are using!

greplnx (greplnx) wrote :

Just set org.gnome.desktop.input-soures.sources to [('xkb','us'),('xkb','<lng1>'),('xkb','<lng...'>)]

Reason: open up /usr/share/gnome-shell/ui/panel.js, realize that

const PANEL_ITEM_IMPLEMENTATIONS['keyboard'] = imports.ui.status.keyboard.InputSourceIndicator;

Check /usr/share/gnome-shell/ui/status/keyboard.js and find

const DESKTOP_INPUT_SOURCES_SCHEMA = 'org.gnome.desktop.input-sources';

const InputSourceIndicator = new Lang.Class({
//...
// see where and how DESKTOP_INPUT_SOURCES_SCHEMA is used
//...
)};

greplnx (greplnx) wrote :

As a follow-up: the '<lng1>' pattern/tag is used here as a placeholder for the desired xkb layout.

sgon00 (sgon00) wrote :

By following greplnx (greplnx) tip, I did the following:

    gsettings set org.gnome.desktop.input-sources sources "[('xkb','us'),('xkb','cn')]"
    gsettings set org.gnome.desktop.input-sources show-all-sources true

I am using ibus and switch between English and Chinese inputs.

After doing the above setup, I can see "en" and "zh" layout in gnome 3.6 top-right panel, whichi is good!

But the problem is the "Keyboard Layout" is not integrated with my ibus input method.
When I change "en" to "zh" from top panel, nothing happens, I am still using English input method. OR
when I use "control+space" change English input method to Chinese input method, the top panel layout still shows "en".

Thanks.

Ubuntu 13.04 Gnome 3 / Gnome 3 Classic
the same issue.

2 sgon00
I can confirm that labels appeared after gsettings set org.gnome.desktop.input-sources sources "[('xkb','us'),('xkb','ru')]", however they are not binded to active keyboard layout.

PLEASE fix this. It shouldn't be so hard, damn it !
I have this issue both in Ubuntu 12.10 AND in Linux Mint 15 with gnome-shell.

Žygimantas Beručka (zygis) wrote :

Try better asking for it here https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1096901 I believe no one gives a damn about this bug – see its „Fix Released“ (the fix that never happened) status.

No idea what else there is to do, Ubuntu developers do not investigate into this matter.

This has been finally fixed in Saucy (13.10) ! I've been using it for a few days !

Žygimantas Beručka (zygis) wrote :

I can confirm – it's fixed in Saucy! Thanks!

My solution, on a 13.04 system: use the standard language settings (not the tweaks typing thing) and then add the extension "AppIndicator support". Open configuration and choose "panel" for keyboard. Now you have the keyboard status indicator in the gnome panel. Voilà. Ou est voilá? :-)
HTH

Displaying first 40 and last 40 comments. View all 103 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.