gnome-shell-calendar-server crashed with signal 5 in source_registry_object_manager_thread()

Bug #1044408 reported by David Ross Curtis-Bird
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Debian)
Fix Released
Unknown
gnome-shell (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

[Impact]
If a user has uninstalled everything evolution (or added gnome-shell to a minimal command line Ubuntu install), gnome-shell will refuse to start. In .cache/gdm/session.log or .xsession-errors, this is printed:

(gnome-shell-calendar-server): ShellCalendarServer-ERROR **: calendar_sources_init: Error calling StartServiceByName for org.gnome.evolution.dataserver.Sources0: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program /usr/lib/evolution/evolution-source-registry: Success

[Test Case]
1. sudo apt-get uninstall evolution-data-server (unless this will remove gnome-shell)
2. Log out, and try to log into GNOME Shell

[Regression Potential]
None

[Workaround]
Make sure evolution-data-server is installed; it is not Evolution and is needed for gnome-shell to start.

Original Bug Report
===================
crash occurred upon reboot after I updated the system.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gnome-shell 3.5.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.5.1-0ubuntu4
Architecture: i386
Date: Fri Aug 31 09:09:53 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/gnome-shell/gnome-shell-calendar-server
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcCmdline: /usr/lib/gnome-shell/gnome-shell-calendar-server
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 source_registry_object_manager_thread (data=0x9804090) at e-source-registry.c:734
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 start_thread () from /lib/i386-linux-gnu/libpthread.so.0
 clone () from /lib/i386-linux-gnu/libc.so.6
Title: gnome-shell-calendar-server crashed with signal 5 in source_registry_object_manager_thread()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin netdev plugdev sambashare sudo

Revision history for this message
David Ross Curtis-Bird (darcbird-m) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 source_registry_object_manager_thread (data=0x9804090) at e-source-registry.c:734
 g_thread_proxy (data=0x988d580) at /build/buildd/glib2.0-2.33.10/./glib/gthread.c:801
 start_thread (arg=0xb3bffb40) at pthread_create.c:308
 clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Jeremy Bicha (jbicha)
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Goran Sterjov (goran-sterjov-deactivatedaccount) wrote :

I got the same error after an update and fixed it by re-installing libebackend with `sudo apt-get install --reinstall libebackend-1.2-5`.
For some reason it had been deleted (probably from autoremove or an update). Hopefully this helps.

Jeremy Bicha (jbicha)
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell (Ubuntu Quantal):
importance: Undecided → Medium
status: New → Triaged
Jeremy Bicha (jbicha)
description: updated
Changed in gnome-shell (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.6.1-3ubuntu2

---------------
gnome-shell (3.6.1-3ubuntu2) raring; urgency=low

  * Rebuild against new mutter
 -- Jeremy Bicha <email address hidden> Thu, 08 Nov 2012 10:47:35 -0500

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Sergio Costas (rastersoft-gmail) wrote :

Yesterday I did a dist-upgrade in my Ubuntu 12.10, and apt removed evolution-data-server. Today, when I tried to enter my session, gnome-shell didn't start. Launching it manually showed an error when launching the calendar. I reinstalled manually evolution-data-server and everything worked fine again.

Please, be sure to add evolution-data-server in the dependencies of gnome-shell, to avoid these problems.

Revision history for this message
Sergio Costas (rastersoft-gmail) wrote :

I'm not sure if I should launch a new bug report, since this one seems marked as "fix released"...

Revision history for this message
Jeremy Bicha (jbicha) wrote :

No, there's no need to open a new bug report. This bug is marked "fix released" for the current development release, 13.04 "Raring" but still open and "triaged" for Ubuntu 12.10 "Quantal".

Revision history for this message
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in gnome-shell (Ubuntu Quantal):
status: Triaged → Won't Fix
Revision history for this message
funicorn (funicorn) wrote :

It's Nov 2017 and gnome 3.26 now. The bug is reborn. Where did the 'fix' go? Why can't these bugs be quarantined since the fixes were done? The same bugs were fixed once and brought back always on the same project, over and over again. It seems the whole community are trying so hard to maintain all the packages as well as all the bugs, in the same time. When we talk about teamwork today, do we keep in mind teamwork begins from remembering history in a decent way?

$sudo apt-get remove evolution-data-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  caribou fonts-cantarell gir1.2-accountsservice-1.0 gir1.2-caribou-1.0
  gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gck-1
  gir1.2-gcr-3 gir1.2-gdm-1.0 gir1.2-geoclue-2.0 gir1.2-gmenu-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gweather-3.0 gir1.2-ibus-1.0
  gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nm-1.0 gir1.2-nmgtk-1.0
  gir1.2-rsvg-2.0 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2
  gir1.2-upowerglib-1.0 gjs libcaribou-common libcaribou0 libebook-1.2-19
  libgdm1 libgjs0g libmozjs-52-0 libtelepathy-logger3 switcheroo-control
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  chrome-gnome-shell evolution-data-server gdm3 gnome-session
  gnome-session-wayland gnome-shell gnome-shell-extension-top-icons-plus
  gnome-shell-extensions ubuntu-session
0 upgraded, 0 newly installed, 9 to remove and 0 not upgraded.
After this operation, 13.3 MB disk space will be freed.
Do you want to continue? [Y/n]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.