Gnome-Shell won't start - GnomeBluetoothApplet.KillswitchState is undefined

Bug #1034751 reported by Taylor "Ripps" LeMasurier-Wren on 2012-08-09
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Unassigned

Bug Description

Starting today, I've become unable to log into my the Gnome3 session. Upon starting I get nothing but my wallpaper, no windows, no desktop.... nothing. When I stared a recovery session I tried to manually start gnome-shell and this is what I got:

ripps@ripps-desktop:~$ gnome-shell --replace

(gnome-terminal:31422): Gdk-CRITICAL **: gdk_error_trap_pop_internal: assertion `trap != NULL' failed
      JS LOG: Error: Requiring IBus, version none: Typelib file for namespace 'IBus' (any version) not found
    JS ERROR: !!! Exception was: TypeError: GnomeBluetoothApplet.KillswitchState is undefined
    JS ERROR: !!! message = '"GnomeBluetoothApplet.KillswitchState is undefined"'
    JS ERROR: !!! fileName = '"/usr/share/gnome-shell/js/ui/status/bluetooth.js"'
    JS ERROR: !!! lineNumber = '97'
    JS ERROR: !!! stack = '"()@/usr/share/gnome-shell/js/ui/status/bluetooth.js:97
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gnome-shell/js/ui/status/bluetooth.js:56
wrapper()@/usr/share/gjs-1.0/lang.js:204
()@/usr/share/gjs-1.0/lang.js:145
()@/usr/share/gjs-1.0/lang.js:239
()@/usr/share/gnome-shell/js/ui/panel.js:1099
wrapper()@/usr/share/gjs-1.0/lang.js:204
start()@/usr/share/gnome-shell/js/ui/main.js:216
@<main>:1
"'
Window manager warning: Log level 32: Execution of main.js threw exception: TypeError: GnomeBluetoothApplet.KillswitchState is undefined

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-shell 3.5.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 9 00:34:14 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to quantal on 2012-01-05 (216 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Michael Flaig (mflaig) wrote :

Happened after upgrade of gnome-bluetooth and related packages

Looking at the diff between 3.5.4 and 3.5.5
There have been Name changes from GnomeBluetoothApplet to GnomeBluetooth

Workaround:
Replacing /usr/share/gnome-shell/js/ui/status/bluetooth.js with the bluetooth.js from the gnome-shell 3.5.5 tar.gz.

Gnome-shell starts but if bluetooth status works right i can't tell, yet.

Robert Bruce Park (robru) wrote :

I had to work around this by downgrading gnome-bluetooth package to 3.5.4 for now.

I did what mflaig suggested and I downloaded the bluetooth.js from the gnome-shell repo via the web tree. Seems to work now. Should have waited until the rest of the gnome_3.5.5 packages were ready before letting this one through.

Michele (mastermitsch) wrote :

@Michael Flaig

Thx, gnome-shell works now. Replace this file help.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.5.4-0ubuntu2

---------------
gnome-shell (3.5.4-0ubuntu2) quantal; urgency=low

  * debian/control.in:
    - updated gnome-bluetooth requirement
  * debian/patches/git_new_bluetooth.patch:
    - update code for the new gnome-bluetooth (lp: #1034751)
 -- Sebastien Bacher <email address hidden> Thu, 09 Aug 2012 11:20:42 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers