Can't Disable Custom Keyboard Setting

Bug #1010558 reported by Jun Inoue
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

I can't disable the default key binding for <Control><Alt>t ("Launch Terminal") from gnome-control-center. (Note: I use Ubuntu's Japanese edition, and I merely traslated the menu items into English. They might be worded slightly differently on actual English-edition systems.)

Steps to reproduce:
0. mutter-common should be installed for these steps to exhibit the bug.
1. Type "gnome-control-center" on the command line.
2. Click on "Keyboard" -> "Shortcuts" -> "Custom Shortcuts".
    There should be a binding for "Launch Terminal". I wanted to disable this binding.
3. Click on the "Launch Terminal" line, and dismiss the dialog it pops up.
4. Now click on the "-" button. The binding will disappear from the list.
5. Close the control center and hit Ctrl-Alt-t in the app of your choice (I used emacs).

Expected behavior: terminal should no longer start; the currently focused application should get the keys. gnome-control-center should no longer show the binding that I deleted.

Actual behavior: terminal starts; the application doesn't see the keys. If you start gnome-control-center again, you will find that the "Launch Terminal" shortcut has magically resurrected itself.

It is possible to change the keys bound to "Launch Terminal", and it is possible to change the action taken when this shortcut is fired. Those changes stick. But removal of the binding is always silently undone.

Possible cause: I don't know enough about gconf to say for sure, but it seems like settings introduced in /usr/share/gconf/defaults/* are treated as "permanent". This particular problem with "Launch Terminal" is caused by the setting in /usr/share/gconf/defaults/10_mutter-common. It does not seem to matter whether you use mutter or not; that file hijacks the settings just by being there.

Workaround: Uninstall mutter-common. Or, set "Launch Terminal" to a key that you'll never press, like Ctrl+Alt+Shift+F12.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Fri Jun 8 17:58:54 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64+mac (20111012)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to precise on 2012-05-17 (22 days ago)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3
 deja-dup 22.0-0ubuntu2
 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu2

Revision history for this message
Jun Inoue (jun-lambda) wrote :
affects: gnome-control-center (Ubuntu) → gnome-shell (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Jun, thanks for reporting this. I don't think this is fixable for Ubuntu 12.04 but it's fixed now in Ubuntu 12.10 Alpha "Quantal Quetzal."

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers