Cant go back to primary monitor when app indicator menu is open

Bug #1859260 reported by Sidney Lins on 2020-01-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dash to dock
New
Unknown
gnome-shell-extension-ubuntu-dock (Ubuntu)
Low
Unassigned

Bug Description

This bugs happens if you:

1. Open app indicator menu (top right);
2. Move your cursor to the right monitor;

Now you can't go back. The only way is pressing ESC to close app indicator menu so that you can go back to the first monitor.

This only happens when ubuntu-dock autohide is on.

Maybe it can be useful: https://github.com/micheleg/dash-to-dock/issues/743

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-shell-extension-ubuntu-dock 67ubuntu19.10.1
ProcVersionSignature: Ubuntu 5.4.0-9.12-generic 5.4.3
Uname: Linux 5.4.0-9-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu15
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 11 00:01:41 2020
InstallationDate: Installed on 2019-12-31 (11 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191230)
PackageArchitecture: all
SourcePackage: gnome-shell-extension-ubuntu-dock
UpgradeStatus: No upgrade log present (probably fresh install)

Sidney Lins (sdlins) wrote :
Daniel van Vugt (vanvugt) wrote :

The indicator menu is not related to the 'ubuntu-dock' extension so I'll move this...

affects: gnome-shell-extension-ubuntu-dock (Ubuntu) → gnome-shell (Ubuntu)
tags: added: multimonitor
Sidney Lins (sdlins) wrote :

Ok vanvugt, thank you. I thought it was related because disabling "autohide" the problem goes away.

Daniel van Vugt (vanvugt) wrote :

Hmm, maybe?... Can you reproduce the issue with any other Gnome Shell popovers?

Sidney Lins (sdlins) wrote :

Yes, I tested and I can reproduce the issue if I open any popovers, for example: keyboard language, calendar or activities.

Daniel van Vugt (vanvugt) wrote :

Thanks for testing that. Please report the bug to upstream at:
https://gitlab.gnome.org/GNOME/gnome-shell/issues

Changed in gnome-shell:
status: Unknown → New
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
status: New → Triaged
affects: gnome-shell (Ubuntu) → gnome-shell-extension-dashtodock (Ubuntu)
Changed in dash-to-dock:
status: Unknown → New
Changed in gnome-shell:
status: New → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

I think the reporter meant the ubuntu-dock.

affects: gnome-shell-extension-dashtodock (Ubuntu) → gnome-shell-extension-ubuntu-dock (Ubuntu)
no longer affects: gnome-shell
tags: added: fixed-upstream
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.