Dock doesn't show badge count, if new notifications arrived when screen locked

Bug #1756837 reported by Eugene Romanenko
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-ubuntu-dock (Ubuntu)
Fix Released
High
Marco Trevisan (Treviño)

Bug Description

Gnome Shell disables extensions on screen lock.
If, for example, new mail will arrived in Thunderbird during screen locked, no badges will be shown on unlock.
Also, lock/unlock screen while badges displayed will clear them.

So, in current implementation, badges looks very unreliable to rely on them, and looks more a mess than a feature.

Solution may be adding a user space daemon, which interact with applications even when dock extension is disabled, and provide badges information for dock.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell-extension-ubuntu-dock 0.9
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 19 12:11:45 2018
PackageArchitecture: all
SourcePackage: gnome-shell-extension-ubuntu-dock
UpgradeStatus: Upgraded to bionic on 2017-10-24 (145 days ago)

Revision history for this message
Eugene Romanenko (eros2) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Undecided → Medium
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Medium → High
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-ubuntu-dock - 67ubuntu20.04.3

---------------
gnome-shell-extension-ubuntu-dock (67ubuntu20.04.3) focal; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * docking: Don't use non-existent Utils.DisplayWrapper.getWorkspaceManager()
  * dash: Use clutter alignment to ensure we properly arrange the dash
  * metadata: Set extension compatible with shell 3.36 only
  * dash: Sync some more to the upstream cleanups
  * docking: Properly replace default dash in all modes (LP: #1795703,
    LP: #1865865)
  * docking: Delay hide requests if we're currently showing
  * docking: Don't sync overview's iconSize anymore
  * docking: Reset old dash changes if something changes it (LP: #1795703)
  * docking: Cleanup the docks destruction code
  * docking: Use parent vfunc results to get slider container sizes
  * docking: Add mainDock property to DockManager and use it
  * docking: Don't pass allDocks to every child
  * docking: Ignore key-repeat
  * fileManager1API: Use a cancellable to stop proxy creation on destruction
  * dash: Cleanup preferred width/height vfuncs reusing upstream code
  * dash: Get content box from the themeNode
  * dash: Some code cleanups to match Upstream code better
  * appIcons: Redirect events from the showAppIcon toggleButton to the parent
  * general: Don't use Gtk enum definitions for St widgets
  * docking: Apply the height/width dash constraint after adding to main uiGroup
  * docking: Delay toggling to group multiple requests
  * docking: Consider theming when computing the sliderContainer space
  * docking: Reimplement Clutter.BindConstraint to bind to Maximum size only
  * docking: Replace the dashSpacer instance in default controls
  * docking: Make sure we don't send the overview offscreen in extended mode
    (LP: #1834967)
  * launcherAPI: Actually keep track of the unity bus ID and replace it
    (LP: #1756837)

  [ Michele Gaio ]
  * Fix bug with xscreensaver.

  [ Jordan Christiansen ]
  * Update the screenshot to Gnome 3.34

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 18 Mar 2020 03:22:28 +0100

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Eugene Romanenko (eros2) wrote :

It' is really fixed? Just tested on Ubuntu 20.04 RC, package gnome-shell-extension-ubuntu-dock 67ubuntu20.04.5 and doesn't see any difference. Badges still disappear after screen lock.

Tested with Telegram.
Thunderbird since version 68 (not sure exactly) does not use badges anymore.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers