FFe/UIFe dock transparency and slight behavior changes

Bug #1717509 reported by Didier Roche on 2017-09-15
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-ubuntu-dock (Ubuntu)
Undecided
Unassigned

Bug Description

GNOME 3.26 is now released and feature a dynamic transparency.

It means that when no window is next to the top panel, a small gradient is present. As soon as any window touches it, the top panel become opaques.

This doesn't play visually well with our ubuntu dock, which features a fixed transparency: https://didrocks.fr/images/artful-shell-transition/new-theme-main-view.png

As I explained on https://didrocks.fr/2017/09/04/ubuntu-gnome-shell-in-artful-day-9/, we were waiting on GNOME decision to keep or remove this transparency top panel which made debates. The final release kept it.

We thus need to change the Ubuntu Dock transparency feature to go well visually with it. I have been working with upstream Dash to Dock for a week on this and we iterated on https://github.com/micheleg/dash-to-dock/pull/513. There is multiple modes proposed, but the one we will default to in ubuntu dock is to link panel and dock opacity:
- The Dock will be at 0.2 (over 1) opacity when no window touches nor the panel neither the Dock itself.
- The Dock will be have the same transparency level as the current version when any window touches the panel or dock in the current workspace.

The testing is in progress as well as the review is. The code is quite stable (being testing for the whole day, and will continue over the week-end) and we aim at getting that merged in the upstream repo quickly (ideally this Monday).

Along the way, I'm using this opportunity to rationalize as well some keybindings and mouse interactions (which are just gsettings override):
- Click is focus or showing up window previews. Same than Super + number (it's already the default)
- Shift + click launch a new instance. Same than Super + Shift + number, bringing back similar keybindings than unity
- Middle click does the same than above (similar behavior than middle clicking on a link in a browser opening a new tab).
- Shift + middle click minimize the last focused window from the selected application.

There is no new strings to translate that we expose.

The rest of this update will be cherry-picked fixes from upstream repo (not a full rebase, as there are new features in it as well).

Didier Roche (didrocks) on 2017-09-15
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

No problem from a docs POV.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Duplicate of bug 1712992, but let's keep this one.

Didier Roche (didrocks) on 2017-09-18
description: updated
Didier Roche (didrocks) wrote :

Attaching the diff of the changes.
The .ui changes aren't exposed to the users as ubuntu-dock doesn't have any configuration UI, contrary to dash to dock.

That said the upper bar is unneeded. It's better shown when pressing the apps button only, and an extension already allows to configure it that way.

More generally UI elements are better shown only just when needed, or if they are used constantly. Everything else is better hidden.

At the same time the Activities button does nothing else that the dock already provides, been the second one more functional.

(https://i11.servimg.com/u/f11/16/19/87/90/screen10.jpg)
(https://i11.servimg.com/u/f11/16/19/87/90/screen12.jpg)

Iain Lane (laney) wrote :

Ok, providing you've tested it well, go for it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-ubuntu-dock - 0.5

---------------
gnome-shell-extension-ubuntu-dock (0.5) artful; urgency=medium

  [ Didier Roche ]
  * Cherry-pick dynamic and adaptive transparency feature to look and behave
    better with GNOME Shell 3.26. We only enable adaptive transparency.
    (LP: #1717509).
  * Rationalize some keyboard and key + mouse shortcuts:
    - Click is focus or showing up window previews. Same than Super + number
      (was already the default)
    - Shift + click launch a new instance. Same than Super + Shift + number
    - Middle click launch a new instance as well. This is to be consistent
      when middle clicking a link in a web browser opening a new tab.
    - Shift + middle click minimize the last focused window from the selected
      application.
  * Cherry-pick some fixes from dash to dock branch (without taking the other
    new features):
    - Hotkeys: remove keypad hotkeys
    - Define externally accessible classes and constants with 'var'
  * Fix uninitialized value for dock disabled by default
    (LP: #1712698, #1714219)
  * updated translations
  * Remove prefs.js as deleted from to localize list
  * Add Vcs-Git reference

  [ Sebastien Bacher ]
  * debian/control, debian/rules:
    - use dh_translations, update the template during the build

 -- Didier Roche <email address hidden> Wed, 20 Sep 2017 08:01:22 +0200

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Confirmed → Fix Released
Frogs Hair (detaill) wrote :

I see opacity changes when using Thunderbird Mail and Conky. The dock changes from dark gray transparent to almost black.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers