Thumbnail is stretched if its aspect ratio is less than that of the container

Bug #1880031 reported by riu on 2020-05-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell-extension-desktop-icons
Unknown
Unknown
gnome-shell-extension-desktop-icons (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[ Impact ]

Image thumbnails are stretched if the aspect ratio is less than the one of the container

[ Test case ]

To reproduce, create an image that has aspect ratio, e.g., ~0.5 (e.g. width = 250 and height = 500)

Save it in the desktop and ensure that the image has proper proportions.

[ Regression potential ]

Image thumbnails are distorted

----

This was discovered when investigating fix for bug #1868529.

Aspect ratio is still not correct for images that are more narrow than the container. To reproduce, create an image that has aspect ratio, e.g., ~0.5 (e.g. width = 250 and height = 500).

Line in fileItem.js where we calculate icon width does not count the margins (zero is used instead of actual margins):

let containerWidth = Prefs.getDesiredWidth(scaleFactor, 0);

Here is how the margins are being calculated in desktopGrid.js:

        this._extra_width = themeNode.get_margin(St.Side.LEFT) +
                             themeNode.get_margin(St.Side.RIGHT) +
                             themeNode.get_border_width(St.Side.LEFT) +
                             themeNode.get_border_width(St.Side.RIGHT) +
                             themeNode.get_horizontal_padding();
        this._extra_height = themeNode.get_margin(St.Side.TOP) +
                             themeNode.get_margin(St.Side.BOTTOM) +
                             themeNode.get_border_width(St.Side.TOP) +
                             themeNode.get_border_width(St.Side.BOTTOM) +
                             themeNode.get_vertical_padding();

riu (stanray) on 2020-05-21
description: updated
riu (stanray) on 2020-05-21
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please include a screenshot/photo of the problem and report it to the developers at:

  https://gitlab.gnome.org/World/ShellExtensions/desktop-icons/-/issues

tags: added: focal
Revision history for this message
riu (stanray) wrote :

I have reported the bug to upstream:

Narrow desktop thumbnails are stretched (#205) · Issues · World / Shell extensions / Desktop Icons · GitLab
https://gitlab.gnome.org/World/ShellExtensions/desktop-icons/-/issues/205

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: New → Fix Committed
tags: added: fixed-upstream
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0-3

---------------
gnome-shell-extension-desktop-icons (20.04.0-3) unstable; urgency=medium

  * d/p/Fix-incorrect-aspect-ratio.patch,
    d/p/desktopGrid.js-fix-errors-when-screen-size-changes.patch:
    - Fix incorrect icon aspect ratio (LP: #1880031)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 21 Jul 2020 18:16:08 +0200

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: New → Fix Committed
description: updated
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello riu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/20.04.0-3~ubuntu20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
Revision history for this message
riu (stanray) wrote :

I have installed gnome-shell-extension-desktop-icons 20.04.0-3~ubuntu20.04.1 from focal-proposed.

The issue is fixed now: aspect ratio of desktop thumbnails is correct.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for gnome-shell-extension-desktop-icons has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0-3~ubuntu20.04.1

---------------
gnome-shell-extension-desktop-icons (20.04.0-3~ubuntu20.04.1) focal; urgency=medium

  * No-change backport to focal

gnome-shell-extension-desktop-icons (20.04.0-3) unstable; urgency=medium

  * d/p/Fix-incorrect-aspect-ratio.patch,
    d/p/desktopGrid.js-fix-errors-when-screen-size-changes.patch:
    - Fix incorrect icon aspect ratio (LP: #1880031)

 -- Marco Trevisan (Treviño) <email address hidden> Tue, 21 Jul 2020 18:30:14 +0200

Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Antonin Chambolle (antonin-chambolle) wrote :

I still have the bug with the updated package... (see screenshot)

[upgraded yesterday from 18.04 on Dell XPS 13 system]

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

^^^
That is being tracked in bug 1892276 now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.