Stretched image previews on desktop

Bug #1868529 reported by Igor Zubarev on 2020-03-23
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-desktop-icons
Unknown
Unknown
gnome-shell-extension-desktop-icons (Ubuntu)
Low
Unassigned

Bug Description

After upgrade to 20.04 desktop previews of pictures and documents became stretched. The regular previews in Nautilus have normal sizes. See attached pic

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-shell-extension-desktop-icons 19.10.2+git20200223-1
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia wl
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 23 11:44:13 2020
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell-extension-desktop-icons
UpgradeStatus: No upgrade log present (probably fresh install)

Igor Zubarev (igor.zubarev) wrote :
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report!

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - Stretched picture or pdf preview icon on desktop
+ Stretched image previews on desktop
Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: Confirmed → Triaged

I'm the developer of desktop icons. I have a patch waiting review that should fix this at https://gitlab.gnome.org/World/ShellExtensions/desktop-icons/-/issues/190

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0-1

---------------
gnome-shell-extension-desktop-icons (20.04.0-1) unstable; urgency=medium

  * New upstream (bugfix) release
    - Fixed stretched thumbnails (LP: #1868529)
    - Honor the "don't show thumbnails" setting
    - Shows the hand cursor when using "single click" option
    - Clear file selection after a desktop refresh
  * debian/patches: cherry-pick new translations from git

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 16 Apr 2020 09:10:08 +0200

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: Fix Committed → Fix Released
riu (stanray) wrote :

It is much better with the fix. We don't count margins, so the aspect ratio is still not valid for narrow images.

Line in fileItem.js

let width = Prefs.getDesiredWidth(scaleFactor, 0)

was also erroneous, because margins are not 0 (at least, with default theme).

Here is how the margins are being calculated:

        this._extra_width = themeNode.get_margin(St.Side.LEFT) +
                             themeNode.get_margin(St.Side.RIGHT) +
                             themeNode.get_border_width(St.Side.LEFT) +
                             themeNode.get_border_width(St.Side.RIGHT) +
                             themeNode.get_horizontal_padding();
        this._extra_height = themeNode.get_margin(St.Side.TOP) +
                             themeNode.get_margin(St.Side.BOTTOM) +
                             themeNode.get_border_width(St.Side.TOP) +
                             themeNode.get_border_width(St.Side.BOTTOM) +
                             themeNode.get_vertical_padding();

(they are used in Prefs.getDesiredWidth and Prefs.getDesiredHeight functions)

Aspect ratio is still not correct for narrow images. To reproduce, create an image that has aspect ratio ~0.5 (e.g. width = 250 and height = 500).

riu (stanray) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.