Changing Dock icon size (Settings-Dock-Icon size) the icons on desktop disappear

Bug #1811717 reported by corrado venturini on 2019-01-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-desktop-icons (Ubuntu)
Undecided
Unassigned

Bug Description

I have some icons on desktop (applications folders and files)
Changing Dock Icon size (Settings-Dock-Icon size) the icons on desktop disappear, they reappear creating a file or a folder in the desktop or in /Home/Desktop
sometimes they reappear also changing Icon size again.

Problem happen both with x11 and wayland session.

corrado@corrado-p6-dd-1227:~$ inxi -SCGx
System:
  Host: corrado-p6-dd-1227 Kernel: 4.18.0-11-generic x86_64 bits: 64
  compiler: gcc v: 8.2.0 Desktop: Gnome 3.30.2
  Distro: Ubuntu 19.04 (Disco Dingo)
CPU:
  Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP
  arch: Kaby Lake rev: 9 L2 cache: 3072 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31296
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
Graphics:
  Device-1: Intel HD Graphics 630 vendor: ASRock driver: i915 v: kernel
  bus ID: 00:02.0
  Display: x11 server: X.Org 1.20.3 driver: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
  v: 4.5 Mesa 18.2.6 direct render: Yes
corrado@corrado-p6-dd-1227:~$

corrado@corrado-p6-dd-1227:~$ apt policy nautilus
nautilus:
  Installed: 1:3.30.4-1ubuntu1
  Candidate: 1:3.30.4-1ubuntu1
  Version table:
 *** 1:3.30.4-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu disco/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p6-dd-1227:~$

gnome-shell-extension-desktop-icons:
  Installed: 18.11~rc+git20181217-1
  Candidate: 18.11~rc+git20181217-1
  Version table:
 *** 18.11~rc+git20181217-1 500
        500 http://archive.ubuntu.com/ubuntu disco/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu disco/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: nautilus 1:3.30.4-1ubuntu1
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu18
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Jan 14 20:10:16 2019
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'initial-size' b'(1252, 581)'
 b'org.gnome.nautilus.list-view' b'default-column-order' b"['name', 'size', 'type', 'owner', 'group', 'permissions', 'where', 'date_modified', 'date_modified_with_time', 'date_accessed', 'recency', 'starred', 'detailed_type']"
InstallationDate: Installed on 2018-12-27 (18 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181227)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_nautilus:

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1811717

tags: added: iso-testing
Iain Lane (laney) wrote :

can you post a screencast please (using ctrl-alt-shift-r, then look in ~/Videos)? I tried to make this happen and couldn't - see this attachment.

Paul White (paulw2u) wrote :

My screencast attached using a freshly booted live session, today's ISO (20190115). I can also reproduce this with KVM and a single display.

Doug McMahon (mc3man) wrote :

Testing the latest git of desktop icons (git-d1027f8 from 20190114) the issue seems resolved.
When using the current package in disco saw the same as been reported,

affects: nautilus (Ubuntu) → gnome-shell-extension-desktop-icons (Ubuntu)
Iain Lane (laney) wrote :

I'm uploading 1.0 now, please try again when that arrives

Problem solved after installing new:
corrado@corrado-p5-dd-0115:~$ apt policy gnome-shell-extension-desktop-icons
gnome-shell-extension-desktop-icons:
  Installed: 19.01-1
  Candidate: 19.01-1
  Version table:
 *** 19.01-1 500
        500 http://archive.ubuntu.com/ubuntu disco/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu disco/main i386 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p5-dd-0115:~$

Iain Lane (laney) wrote :

thx

Changed in gnome-shell-extension-desktop-icons (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers