Hard to detect double-clicks on the HiDPI touchscreen system

Bug #1917010 reported by jeremyszu
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell-extension-desktop-icons (Ubuntu)
Fix Committed
Medium
Unassigned
Focal
Fix Released
Medium
Kai-Heng Feng
Hirsute
Fix Released
Medium
Kai-Heng Feng
gnome-shell-extension-desktop-icons-ng (Ubuntu)
Fix Released
High
Unassigned
Hirsute
Fix Released
High
Kai-Heng Feng
Impish
Fix Released
High
Unassigned

Bug Description

== SRU Justification ==
[Impact]
Double tap desktop icons on a touchscreen barely works.

[Fix]
Because tapping isn't as precise as clicking, ignore the double click distance as long as the icon is tapped.

[Test]
Roughly double tap the desktop icon and nothing happens.
After applying the fix, double tap can 100% open the app or directory.
[racb] Since single click code is also being adjusted, please also test that single clicking behaviour has not changed.
[racb] Since clicking with modifiers (holding Shift and/or Ctrl) is also being adjusted, please also test that modifier clicking behaviour has not changed.

[Where problems could occur]
If the new code throws any exception, clicking can also be affected.

== Original Bug Report ==
Double-clicks touchscreen on HiDPI system, sometime it will not be detected.
Here is a related patch on upstream
https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/1487

jeremyszu (os369510)
tags: added: oem-priority originate-from-1898663 stella
Changed in oem-priority:
assignee: nobody → jeremyszu (os369510)
importance: Undecided → High
status: New → Triaged
tags: added: touchscreen
Changed in mutter (Ubuntu):
status: New → In Progress
assignee: nobody → Kai-Heng Feng (kaihengfeng)
Changed in mutter (Ubuntu):
status: In Progress → Confirmed
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :
Changed in mutter (Ubuntu):
status: Confirmed → Invalid
no longer affects: mutter (Ubuntu)
no longer affects: oem-priority
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Focal):
status: New → Invalid
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Hirsute):
status: New → Confirmed
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
status: New → Confirmed
Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: New → Confirmed
Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
status: New → Confirmed
Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
status: New → Confirmed
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons-ng debdiff for Impish.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons-ng debdiff for Hirsute.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "gnome-shell-extension-desktop-icons-ng_0.17.0-1ubuntu2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons debdiff for Impish.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons debdiff for Hirsute.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons debdiff for Focal.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your patches, Kai-Heng Feng!

I just uploaded everything upstream, including this fix, to impish. Forgot the gir1.2-clutter-1.0 dependency, though.. will fix that soon.

As regards the SRUs, can you please edit the bug description to comply with the template:

https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Also, will you be available to verify the packages in -proposed when it's time for that?

Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
status: Confirmed → Fix Committed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

impish fix of gnome-shell-extension-desktop-icons uploaded to experimental to start with.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons-ng - 0.18.0-0ubuntu1

---------------
gnome-shell-extension-desktop-icons-ng (0.18.0-0ubuntu1) impish; urgency=medium

  * New upstream release
    - Fixed LP: #1917044 through e31c9df1 "Update desktop via dbus
      metadata change"
  * d/p/fileItem.js_Add_support_for_rendering_at_high_DPI_scales.patch:
    - Dropped, applied upstream
  * d/p/upstream-commits-until-20210712.patch
    - All upstream commits since the 0.18.0 release (LP: #1826056,
      LP: #1917010)
  * d/p/desktopGrid_Compare_rubberband_bounds_in_global_coord.patch:
    - Dropped, applied upstream

 -- Gunnar Hjalmarsson <email address hidden> Wed, 14 Jul 2021 19:31:45 +0200

Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
status: Fix Committed → Fix Released
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons-ng - 0.18.0-0ubuntu2

---------------
gnome-shell-extension-desktop-icons-ng (0.18.0-0ubuntu2) impish; urgency=medium

  * debian/control*:
    - Depend on gir1.2-clutter-1.0 (completes LP: #1917010)

 -- Gunnar Hjalmarsson <email address hidden> Wed, 14 Jul 2021 23:08:55 +0200

Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0+git20200908-6

---------------
gnome-shell-extension-desktop-icons (20.04.0+git20200908-6) experimental; urgency=medium

  * d/p/fileItem-Ignore-double-click-distance-clicking-on-items.patch:
    - Cherry picked upstream commit (LP: #1917010)
  * debian/control:
    - Add dependency gir1.2-clutter-1.0.

 -- Kai-Heng Feng <email address hidden> Wed, 14 Jul 2021 20:56:32 +0800

Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-07-15 09:42, Launchpad Bug Tracker wrote:
> This bug was fixed in the package gnome-shell-extension-desktop-icons -
> 20.04.0+git20200908-6

In impish it was subsequently demoted to -proposed (bug #1936311). That won't prevent us from fixing it in previous releases, though, especially focal where the package is in main.

So I'm willing to sponsor the proposed uploads for stable release updates of both packages, but only when

1. The bug description complies with the SRU bug template, and

2. Somebody has stepped up and said "yes, I will accomplish the testing
   and verification". (This needs to be done by somebody with access to
   the applicable hardware.)

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Yes, I will accomplish the testing and verification.

However, gnome-shell-extension-desktop-icons gets uninstalled on Impish because the gnome-shell in -proposed breaks gnome-shell-extension-desktop-icons (<< 21.04).

description: updated
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-07-16 08:19, Kai-Heng Feng wrote:
> However, gnome-shell-extension-desktop-icons gets uninstalled on
> Impish because the gnome-shell in -proposed breaks
> gnome-shell-extension- desktop-icons (<< 21.04).

Right, and that's because the package is not (yet) adapted to GNOME 40.

I sponsored the SRUs. They are now in respective queue for review by the SRU team.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
status: Confirmed → In Progress
Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
status: Confirmed → In Progress
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Hirsute):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
status: Confirmed → In Progress
Robie Basak (racb)
description: updated
description: updated
Revision history for this message
Robie Basak (racb) wrote :

I noticed that newer uploads in Impish for -ng provide:

+ gir1.2-clutter-gst-3.0,
+ gir1.2-gtkclutter-1.0,

Are these needed for the -ng SRU to Hirsute?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-07-21 20:44, Robie Basak wrote:
> I noticed that newer uploads in Impish for -ng provide:
>
> + gir1.2-clutter-gst-3.0,
> + gir1.2-gtkclutter-1.0,

Right, that was due to this upstream commit:

https://gitlab.com/rastersoft/desktop-icons-ng/-/commit/7de8e1cb

and the day after upstream committed:

https://gitlab.com/rastersoft/desktop-icons-ng/-/commit/c3afe696

so we'll soon drop those dependencies in impish.

> Are these needed for the -ng SRU to Hirsute?

Good question. @Kai-Heng Feng, would those be needed without the related upstream change in fileItem.js?

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

If we don't want the extra dependencies then we should include the additional commits.

Do you want me to generate new debdiffs?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-07-22 08:45, Kai-Heng Feng wrote:
> If we don't want the extra dependencies then we should include the
> additional commits.

Ouch! Ok..

> Do you want me to generate new debdiffs?

Not necessary. We have repos at salsa.debian.org, and I just fixed the -ng package for hirsute and uploaded again.

https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell-extension-desktop-icons-ng/-/commit/5e109eb9

I chose to add the extra deps to match what we have in impish ATM.

But what about gnome-shell-extension-desktop-icons? Do we have to change those as well?

P.S. Good catch, Robie!

Mathew Hodson (mhodson)
no longer affects: gnome-shell-extension-desktop-icons-ng (Ubuntu Focal)
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Hirsute):
importance: Undecided → High
Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Impish):
importance: Undecided → High
Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
importance: Undecided → Medium
Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
importance: Undecided → Medium
Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
importance: Undecided → Medium
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

gnome-shell-extension-desktop-icons still uses Clutter.Settings, so the dependency is still required.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Kai-Heng Feng: Yes, but I meant to ask if the *additional* dependencies (gir1.2-clutter-gst-3.0 and gir1.2-gtkclutter-1.0) are required, i.e. is there a need to change the gnome-shell-extension-desktop-icons uploads as well?

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Yes, the new dependency is still required for gnome-shell-extension-desktop-icons.

Revision history for this message
Steve Langasek (vorlon) wrote :

Per https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update_the_packaging the preferred version number here is 20.04.0+git20200908-5ubuntu0.1, not 20.04.0+git20200908-6~ubuntu21.04.1, despite the contents being equivalent to the 20.04.0+git20200908-6 in impish. I am reuploading with a fixed-up changelog for cleanliness.

Also, please do not point Vcs-Git for Ubuntu packages at repositories that are not writable by everyone who has upload rights to the package. There are many schemas you can use to host such branches in launchpad, writable by ~ubuntu-dev.

Revision history for this message
Steve Langasek (vorlon) wrote : Please test proposed package

Hello jeremyszu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons-ng into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons-ng/0.15.0-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Hirsute):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello jeremyszu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/20.04.0+git20200908-5ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
status: In Progress → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

Hello jeremyszu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/20.04.0-3~ubuntu20.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Since I hadn't yet added the extra dependencies to gnome-shell-extension-desktop-icons, I set "verification-failed-focal" and "verification-failed-hirsute" for now, so they don't get accidentally moved to -updates. (It doesn't mean there is anything wrong with the -ng package in hirsute-proposed, but there is no tag available to specify the package...)

I'll upload gnome-shell-extension-desktop-icons to experimental/impish again with the extra dependencies, and propose new SRUs for hirsute and focal.

tags: added: verification-failed-focal verification-failed-hirsute
removed: verification-needed-focal verification-needed-hirsute
Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
status: Fix Committed → In Progress
Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
status: Fix Released → In Progress
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Ok, I have now sync'ed gnome-shell-extension-desktop-icons from Debian experimental to impish and uploaded new versions of the package to hirsute and focal. Once the latter have been approved by the SRU team, it's time to verify all the -proposed packages.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Impish):
status: In Progress → Fix Committed
tags: added: block-proposed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

The purpose of the temporary block-proposed tag is to prevent gnome-shell-extension-desktop-icons from being considered for migration on impish. See bug #1936311 about the background.

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello jeremyszu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/20.04.0+git20200908-5ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
status: In Progress → Fix Committed
tags: added: verification-needed-hirsute
removed: verification-failed-hirsute
Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
removed: verification-failed-focal
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello jeremyszu, or anyone else affected,

Accepted gnome-shell-extension-desktop-icons into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/20.04.0-3~ubuntu20.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

block-proposed tag dropped after consultation with Sebastien Bacher.

tags: removed: block-proposed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Kai-Heng Feng: Don't forget the verification of the SRUs. The packages will stay in -proposed until that has happened.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

For gnome-shell-extension-desktop-icons on Hirsute:

1) Boot to a live Hirsute USB
2) Enable -proposed pocket and add universe to the repo
3) Remove gnome-shell-extension-desktop-icons-ng
4) Install gnome-shell-extension-desktop-icons
5) Logout and login to restart gnome-shell
6) Install gnome-tweaks and enable "Desktop icons" under the extension tab
7) Use the touchscreen to double tap on "Home" and "Trash" icons, the respective directories can be opened all the time.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Karl-Heng Feng: Thanks.

But that sounds more like a plan to me. ;) Please note that the wording of a verification comment preferably should have the form of a positive statement which documents that some steps were carried out successfully.

Then, in this case, the tag verification-needed-hirsute should be changed to verification-done-hirsute, but since also the -ng package is SRUed via this bug report, that tag should be changed only when also the -ng package in hirsute-proposed has been verified.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

For gnome-shell-extension-desktop-icons on Focal:

1) Boot to a live Focal USB
2) Enable -proposed pocket and add universe to the repo
3) Upgrade gnome-shell-extension-desktop-icons to 20.04.0-3~ubuntu20.04.3
4) Logout and login to restart gnome-shell
5) Use the touchscreen to double tap on "Home" and "Trash" icons, the respective directories can be opened all the time.

tags: added: verification-done verification-done-focal verification-done-hirsute
removed: verification-needed verification-needed-focal verification-needed-hirsute
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Ah, I didn't notice gnome-shell-extension-desktop-icons-ng is also in the Hirsute. Let me verify it too.

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

For gnome-shell-extension-desktop-icons-ng on Hirsute:

1) Boot to a live Hirsute USB
2) Enable -proposed pocket and add universe to the repo
3) Upgrade gnome-shell-extension-desktop-icons-ng
4) Logout and login to restart gnome-shell
5) Use the touchscreen to double tap on "Home" and "Trash" icons, the respective directories can be opened all the time.

So I can confirm the SRU fixes the double-tap issue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0+git20200908-5ubuntu0.2

---------------
gnome-shell-extension-desktop-icons (20.04.0+git20200908-5ubuntu0.2) hirsute; urgency=medium

  [ Kai-Heng Feng ]
  * debian/control: Further clutter dependencies (LP: #1917010)

gnome-shell-extension-desktop-icons (20.04.0+git20200908-5ubuntu0.1) hirsute; urgency=medium

  * d/p/fileItem-Ignore-double-click-distance-clicking-on-items.patch:
    - Cherry picked upstream commit (LP: #1917010)
  * debian/control:
    - Add dependency gir1.2-clutter-1.0.

 -- Gunnar Hjalmarsson <email address hidden> Sat, 31 Jul 2021 13:11:53 +0200

Changed in gnome-shell-extension-desktop-icons (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons-ng - 0.15.0-0ubuntu4.2

---------------
gnome-shell-extension-desktop-icons-ng (0.15.0-0ubuntu4.2) hirsute; urgency=medium

  * d/p/Ignore-double-click-distance-clicking-on-items.patch:
    - Cherry picked upstream merge request (LP: #1917010)
  * debian/control:
    - Add dependencies gir1.2-clutter-1.0, gir1.2-clutter-gst-3.0,
      gir1.2-gtkclutter-1.0

 -- Kai-Heng Feng <email address hidden> Thu, 22 Jul 2021 11:26:32 +0200

Changed in gnome-shell-extension-desktop-icons-ng (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for gnome-shell-extension-desktop-icons has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extension-desktop-icons - 20.04.0-3~ubuntu20.04.3

---------------
gnome-shell-extension-desktop-icons (20.04.0-3~ubuntu20.04.3) focal; urgency=medium

  [ Kai-Heng Feng ]
  * debian/control: Further clutter dependencies (LP: #1917010)

gnome-shell-extension-desktop-icons (20.04.0-3~ubuntu20.04.2) focal; urgency=medium

  * d/p/fileItem-Ignore-double-click-distance-clicking-on-items.patch:
    - Cherry picked upstream commit (LP: #1917010)
  * debian/control:
    - Add dependency gir1.2-clutter-1.0.

 -- Gunnar Hjalmarsson <email address hidden> Sat, 31 Jul 2021 13:14:19 +0200

Changed in gnome-shell-extension-desktop-icons (Ubuntu Focal):
status: Fix Committed → Fix Released
no longer affects: gnome-shell-extension-desktop-icons (Ubuntu Impish)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers