Aardvark Daily: Indicator-Multiload doesn't show full-width

Bug #1714804 reported by Damiön la Bagh on 2017-09-03
This bug affects 162 people
Affects Status Importance Assigned to Milestone
System Load Indicator
gnome-shell-extension-appindicator (Ubuntu)

Bug Description

In Ubuntu Indicator-Multiload is an essential application as it shows that computer is actually doing something even when an application is giving no feedback for a long period of time. Conky is not an option as it gets hidden behind full screen applications.

Unfortunately the move to Gnome has broken indicator-multiload so that it can't show all of the indicators.
System Load

I've tried the developers suggestion of installing TopIcons and TopIconsplus to no avail. I see that Ubuntu App-Indicator is also installed so maybe app-indicator extension is broken in Gnome and not indicator-multiload.

Anyway steps to reproduce:
Install Ubuntu 16.04.x LTS
Install indicator-multiload
Open the settings of indicator-multiload by clicking on it and choosing settings
Click all of the sources on
You will now see 6 panels showing the earlier described graphs.

Now install Ubuntu 17.10 Daily
Install indicator-multiload
Mouse over the top bar to faintly get an idea where indicator-multiload is running
click on it and open the settings
Click all of the sources on
You will now see tiny faint lines which give no clue whatsoever as to what is going on with the machine.

Please fix either app-indicator extension or indicator-multiload to work with Gnome. Thanks

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: indicator-multiload 0.4-0ubuntu5
ProcVersionSignature: Ubuntu 4.12.0-12.13-generic 4.12.8
Uname: Linux 4.12.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Sep 3 19:12:33 2017
InstallationDate: Installed on 2017-09-03 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170902)
 PATH=(custom, no user)
SourcePackage: indicator-multiload
UpgradeStatus: No upgrade log present (probably fresh install)

Damiön la Bagh (kat-amsterdam) wrote :
Damiön la Bagh (kat-amsterdam) wrote :

Please see the screenshot for the difference between 16.04.3LTS and 17.10 Alpha

Damiön la Bagh (kat-amsterdam) wrote :

Please see the screenshot to show the settings are exactly the same for 16.04.3LTS and 17.10Daily.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-multiload (Ubuntu):
status: New → Confirmed
Michael Hofmann (mh21) wrote :

GNOME Shell already has a nice system monitor (https://extensions.gnome.org/extension/120/system-monitor/), so I'm not sure it is worth the hassle to fix the indicator.

Dimitri John Ledkov (xnox) wrote :

We still have Ubuntu Flavours that are non-gnome-shell based and use indicators.

Dane Powell (danepowell) wrote :

Thanks, I wasn't aware of the GNOME Shell System Monitor, and I agree it largely obviates the need for indicator-multiload on GNOME.

For other folks who haven't used it before, install with `sudo apt-get install gnome-shell-extension-system-monitor`, then enable using GNOME Tweak Tool (this worked for me anyway).

Colan Schwartz (colan) wrote :

Couldn't get it enabled via apt, but flipping the switch on the extension page (https://extensions.gnome.org/extension/120/system-monitor/) worked.

Damiön la Bagh (kat-amsterdam) wrote :

I was under the impression that things offered via the Software Center are officially supported (by the Community and some by Canoncial) and scanned for vulnerabilities and compatibility. It's very uncomfortable to be enabling and disabling operating system extensions through a website. It appears as if indicator-multiload is safer to use and would be nice if it were fixed.

Also it is odd to say something is unnecessary because another application has a similar function in a similar way. Why should the developers behind Cerin (gnome-shell-system-monitor) get preference on a platform above the developers behind Michael Hofmann's Indicator-Multiload (aka System Load Indicator)?

Colan Schwartz (colan) wrote :

Because that application was written for the platform that Ubuntu is now using (Gnome), and the other one wasn't.

Open-source developers' time is in short supply. It doesn't make sense to spend time porting non-native applications when native applications already exist that can do the job.

It's tricky for users (us) to switch applications whenever the platform changes, but that's the price you pay for not building a GNU/Linux system yourself. Feel free to build and use one that never changes subsystems. ;)

"It doesn't make sense to spend time porting non-native applications when native applications already exist that can do the job."

A open source developer is proud of his code and wants it to run on as many subsystems as possible. The whole point of GNU is that software is agnostic to its platform.

I can't imagine someone wants to just throw away very well written quality code and hand it over to some really terrible, non-functional, and unsafe code.

The subsystem (gnome) is hopefully mature and modular enough to fix indicator-multiload with only a small effort. The Unity desktop environment is End of Life so this is just basic life-cycle management.

Getting gnome-shell-system-monitor up to indicator-multiload's quality standards will take much, much, much more effort and time before all the bug reports get filed and fixed.

I have no problem with change. I have a problem with quality degradation because people put their principles above quality.

Matthew Paul Thomas (mpt) wrote :

Ubuntu has used Gnome by default for every version since 2004. This bug has nothing to do with “non-native applications”.

In Ubuntu 10.04 and 10.10, Ubuntu’s Gnome presented app indicators in indicator-applet.

From 11.04 to 17.04, Ubuntu’s Gnome presented app indicators in the Unity shell.

In 17.10 and later, Ubuntu’s Gnome presented app indicators in a Gnome Shell extension, gnome-shell-extension-appindicator.

If the Gnome Shell extension has a problem presenting an app indicator the same way the previous two implementations did, that’s a problem with the extension, not with the indicator. Probably the same bug occurs whenever any other app indicator tries to use non-square dimensions.

affects: indicator-multiload (Ubuntu) → gnome-shell-extension-appindicator (Ubuntu)
no longer affects: libappindicator
Changed in gnome-shell-extension-appindicator (Ubuntu):
importance: Undecided → Low
Frank Hoonakker (flccrakers) wrote :

I's also affect me and it's very annoying since I use this indicator all the day along.

description: updated
no longer affects: ubuntukylin
Jacopo (rad750) wrote :

Also affects me.

Colan Schwartz (colan) wrote :

@Jacopo (rad750): If it affects you, please just click on the link at the top, and do not add comments to that effect as it only serves to spam everyone subscribed to the ticket without adding any progression to the issue. Thanks.

Jacopo (rad750) wrote :

@Colan Schwartz (colan) and everyone who was annoyed: I am really sorry for that, it is the first time I comment on a bug report. I found the "affects me too" link only after posting the comment.

ViBE (vibe) wrote :

same here. it stucked on my system and the animation is rolling back and moving slowly on ubuntu 18.04 beta 2.

John Hu (john-hu) wrote :

Same problem here.

I tried to enlarge the size of it to see if it gets larger. But it crashes my desktop and goes back to login page after enlarging it.

Currently, I don't know how to clear the settings even if using apt-get purge indicator-multiload....

Martin Vysny (vyzivus) wrote :

You can reset the width using

dconf reset /de/mh21/indicator-multiload/general/width

Martin Vysny (vyzivus) wrote :

Workaround is simply to use the gnome-shell-extension-system-monitor instead - it's essentially the indicator-multiload but better integrated with gnome-shell. To install it:

sudo apt install gnome-shell-extension-system-monitor

To enable it, you need to install gnome-tweak tool:

sudo apt install gnome-tweak-tool

Then launch it in console by running gnome-tweaks ; then head to the Extensions tab and make sure the System-monitor extension is enabled. You can configure it by pressing the cog-wheel button; I tend to set the Graph width to 40px and Refresh time to 500 for all shown graphs.

I can confirm that Martin Vysny's solution/workaround works in Ubuntu 18.04.1LTS.
(this was not the case in Ubuntu Alpha when I reported this bug)

Please note that you have to reboot (or log-off and logon again) for the system-monitor to show up in the gnome-tweaks extensions page.

Time to say goodbye to indicator-multiload and thank Michael Hofmann for the years of enjoyment we had from his software indicator-multiload.

Thank you Michael

Well, please see i just fixed the official gnome shell extension for the indicator-multiload. Source:




I think more work is needed to really support non homogeneous indicator in general. Please note that probably the main inconsistency is that the extension not return the indicator as the same type of actors, that is wrong in my opinion, because cause some inconsistencies, but is easy to fix that also.

While I suggest you to use syspeek (as it causes the shell not to use as much CPU as indicator-multiload), this is now fixed by version 32-1

Changed in gnome-shell-extension-appindicator (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-multiload:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers